summaryrefslogtreecommitdiff
path: root/makefiles
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2005-04-05 18:24:06 +0000
committerAaron M. Ucko <ucko@debian.org>2005-04-05 18:24:06 +0000
commit555037577b9953b61df882da1e0c2e640a90cbbf (patch)
treed6517512c6dab145e81033603c480505db8b8cc9 /makefiles
parent3a30e2c54fc02778dae48d4da42a89ef58097179 (diff)
Load fltk-1.1.3 into branches/upstream/current.
Diffstat (limited to 'makefiles')
-rw-r--r--makefiles/Makefile.mingw96
-rw-r--r--makefiles/Makefile.os2x78
-rw-r--r--makefiles/config.mingw219
-rw-r--r--makefiles/config.os2x224
-rw-r--r--makefiles/makeinclude.mingw126
-rw-r--r--makefiles/makeinclude.mingw31126
-rw-r--r--makefiles/makeinclude.os2x128
7 files changed, 997 insertions, 0 deletions
diff --git a/makefiles/Makefile.mingw b/makefiles/Makefile.mingw
new file mode 100644
index 0000000..9586c98
--- /dev/null
+++ b/makefiles/Makefile.mingw
@@ -0,0 +1,96 @@
+#
+# "$Id: Makefile.mingw,v 1.1.2.2 2001/01/22 15:13:39 easysw Exp $"
+#
+# Top-level makefile for the Fast Light Tool Kit (FLTK).
+#
+# Copyright 1998-2001 by Bill Spitzak and others.
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+#
+# Please report all bugs and problems to "fltk-bugs@fltk.org".
+#
+
+# By default use a Un*x-style shell
+#
+# uncomment next line to use NT command shell
+# SHELL=cmd.exe
+#
+# or uncomment next line to explicitly use a unix-compatible shell
+# SHELL=sh.exe
+#
+# If we are using a Un*x-based make, make sure the environmental var is set
+# set MAKE_MODE=unix
+#
+# By default, a Un*x style make is assumed, so towards the bottom of this
+# file filenames are copied with 'cp' and use forward slashes throughout
+# in filepaths.
+#
+# Changing to a Windows-based command line would require 'cp' replaced with
+# a local equivalent ('copy' is OK) and potentially for forward-slashes in
+# filepaths to be replaced by back-slashes.
+
+
+all: makeinclude config.h
+ echo "=== making src ==="
+ touch src/makedepend
+ cd src ; $(MAKE)
+ echo "=== making fluid ==="
+ touch fluid/makedepend
+ cd fluid ; $(MAKE)
+ echo "=== making test ==="
+ touch test/makedepend
+ cd test ; $(MAKE)
+
+install:
+ echo "=== installing src ==="
+ touch src/makedepend
+ cd src ; $(MAKE) install
+ echo "=== installing fluid ==="
+ touch fluid/makedepend
+ cd fluid ; $(MAKE) install
+
+depend:
+ echo "=== making src dependencies ==="
+ touch src/makedepend
+ cd src ; $(MAKE) depend
+ echo "=== making fluid dependencies ==="
+ touch fluid/makedepend
+ cd fluid ; $(MAKE) depend
+ echo "=== making test dependencies ==="
+ touch test/makedepend
+ cd test ; $(MAKE) depend
+
+clean:
+ -@ rm -f core config.cache *.o *.bck
+ echo "=== cleaning src ==="
+ touch src/makedepend
+ cd src ; $(MAKE) clean
+ echo "=== cleaning fluid ==="
+ touch fluid/makedepend
+ cd fluid ; $(MAKE) clean
+ echo "=== cleaning test ==="
+ touch test/makedepend
+ cd test ; $(MAKE) clean
+
+config.h: makefiles/config.mingw
+ cp $< $@
+
+makeinclude: makefiles/makeinclude.mingw
+ cp $< $@
+
+#
+# End of "$Id: Makefile.mingw,v 1.1.2.2 2001/01/22 15:13:39 easysw Exp $".
+#
diff --git a/makefiles/Makefile.os2x b/makefiles/Makefile.os2x
new file mode 100644
index 0000000..6373be6
--- /dev/null
+++ b/makefiles/Makefile.os2x
@@ -0,0 +1,78 @@
+#
+# "$Id: Makefile.os2x,v 1.6.2.7 2001/04/26 07:11:58 spitzak Exp $"
+#
+# Top-level makefile for the Fast Light Tool Kit (FLTK).
+#
+# Copyright 1998-2000 by Bill Spitzak and others.
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+#
+# Please report all bugs and problems to "fltk-bugs@fltk.org".
+#
+
+# SHELL=cmd.exe
+
+all: makeinclude config.h
+ echo "=== making src ==="
+ touch src/makedepend
+ cd src & $(MAKE)
+ echo "=== making fluid ==="
+ touch fluid/makedepend
+ cd fluid & $(MAKE)
+ echo "=== making test ==="
+ touch test/makedepend
+ cd test & $(MAKE)
+
+install:
+ echo "=== installing src ==="
+ touch src/makedepend
+ cd src & $(MAKE) install
+ echo "=== installing fluid ==="
+ touch fluid/makedepend
+ cd fluid & $(MAKE) install
+
+depend:
+ echo "=== making src dependencies ==="
+ touch src/makedepend
+ cd src & $(MAKE) depend
+ echo "=== making fluid dependencies ==="
+ touch fluid/makedepend
+ cd fluid & $(MAKE) depend
+ echo "=== making test dependencies ==="
+ touch test/makedepend
+ cd test & $(MAKE) depend
+
+clean:
+ -@ rm -f core config.cache *.o *.bck
+ echo "=== cleaning src ==="
+ touch src/makedepend
+ cd src & $(MAKE) clean
+ echo "=== cleaning fluid ==="
+ touch fluid/makedepend
+ cd fluid & $(MAKE) clean
+ echo "=== cleaning test ==="
+ touch test/makedepend
+ cd test & $(MAKE) clean
+
+config.h: makefiles/config.os2x
+ cp $< $@
+
+makeinclude: makefiles/makeinclude.os2x
+ cp $< $@
+
+#
+# End of "$Id: Makefile.os2x,v 1.6.2.7 2001/04/26 07:11:58 spitzak Exp $".
+#
diff --git a/makefiles/config.mingw b/makefiles/config.mingw
new file mode 100644
index 0000000..00cabd9
--- /dev/null
+++ b/makefiles/config.mingw
@@ -0,0 +1,219 @@
+/*
+ * "$Id: config.mingw,v 1.1.2.3.2.10 2003/01/30 21:41:07 easysw Exp $"
+ *
+ * Configuration file for the Fast Light Tool Kit (FLTK).
+ *
+ * Copyright 1998-2003 by Bill Spitzak and others.
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Library General Public
+ * License as published by the Free Software Foundation; either
+ * version 2 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Library General Public License for more details.
+ *
+ * You should have received a copy of the GNU Library General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+ * USA.
+ *
+ * Please report all bugs and problems to "FLTK-bugs@fltk.org".
+ */
+
+/*
+ * Where to find files...
+ */
+
+#define FLTK_DATADIR "C:/FLTK"
+#define FLTK_DOCDIR "C:/FLTK/DOC"
+
+/*
+ * BORDER_WIDTH:
+ *
+ * Thickness of FL_UP_BOX and FL_DOWN_BOX. Current 1,2, and 3 are
+ * supported.
+ *
+ * 3 is the historic FLTK look.
+ * 2 is the default and looks like Microsoft Windows, KDE, and Qt.
+ * 1 is a plausible future evolution...
+ *
+ * Note that this may be simulated at runtime by redefining the boxtypes
+ * using Fl::set_boxtype().
+ */
+
+#define BORDER_WIDTH 2
+
+/*
+ * HAVE_GL:
+ *
+ * Do you have OpenGL? Set this to 0 if you don't have or plan to use
+ * OpenGL, and FLTK will be smaller.
+ *
+ * In order to set to 1 you will need to obtain the OpenGL header and
+ * library files. Consult the README.win32 file for further details.
+ */
+
+#define HAVE_GL 1
+
+/*
+ * HAVE_GL_GLU_H:
+ *
+ * Do you have the OpenGL Utility Library header file?
+ * (many broken Mesa RPMs do not...)
+ */
+
+#define HAVE_GL_GLU_H 1
+
+/*
+ * USE_COLORMAP:
+ *
+ * Setting this to zero will save a good deal of code (especially for
+ * fl_draw_image), but FLTK will only work on TrueColor visuals.
+ */
+
+#define USE_COLORMAP 1
+
+/*
+ * USE_XFT
+ *
+ * Use the new Xft library to draw anti-aliased text.
+ */
+
+#define USE_XFT 0
+
+/*
+ * HAVE_XDBE:
+ *
+ * Do we have the X double-buffer extension?
+ */
+
+#define HAVE_XDBE 0
+
+/*
+ * USE_XDBE:
+ *
+ * Actually try to use the double-buffer extension? Set this to zero
+ * disable use of XDBE without breaking the list_visuals program.
+ */
+
+#define USE_XDBE HAVE_XDBE
+
+/*
+ * HAVE_OVERLAY:
+ *
+ * Use the X overlay extension? FLTK will try to use an overlay
+ * visual for Fl_Overlay_Window, the Gl_Window overlay, and for the
+ * menus. Setting this to zero will remove a substantial amount of
+ * code from FLTK. Overlays have only been tested on SGI servers!
+ */
+
+#define HAVE_OVERLAY 0
+
+/*
+ * HAVE_GL_OVERLAY:
+ *
+ * It is possible your GL has an overlay even if X does not. If so,
+ * set this to 1.
+ */
+
+#define HAVE_GL_OVERLAY HAVE_OVERLAY
+
+/*
+ * WORDS_BIGENDIAN:
+ *
+ * Byte order of your machine: 1 = big-endian, 0 = little-endian.
+ */
+
+#define WORDS_BIGENDIAN 0
+
+/*
+ * U16, U32, U64:
+ *
+ * Types used by fl_draw_image. One of U32 or U64 must be defined.
+ * U16 is optional but FLTK will work better with it!
+ */
+
+#define U16 unsigned short
+#define U32 unsigned
+/* #undef U64 */
+
+/*
+ * HAVE_DIRENT_H, HAVE_SYS_NDIR_H, HAVE_SYS_DIR_H, HAVE_NDIR_H, HAVE_SCANDIR:
+ *
+ * Where is <dirent.h> (used only by fl_file_chooser and scandir).
+ */
+
+#define HAVE_DIRENT_H 1
+/* #undef HAVE_SYS_NDIR_H */
+/* #undef HAVE_SYS_DIR_H */
+/* #undef HAVE_NDIR_H */
+/* #undef HAVE_SCANDIR */
+
+/*
+ * Possibly missing sprintf-style functions:
+ */
+
+/* #undef HAVE_VSNPRINTF */
+/* #undef HAVE_SNPRINTF */
+
+/*
+ * String functions...
+ */
+
+/* #undef HAVE_STRINGS_H */
+#define HAVE_STRCASECMP 1
+/* #undef HAVE_STRLCAT */
+/* #undef HAVE_STRLCPY */
+
+/*
+ * HAVE_SYS_SELECT_H:
+ *
+ * Whether or not select() call has its own header file.
+ */
+
+/* #undef HAVE_SYS_SELECT_H */
+
+/*
+ * USE_POLL:
+ *
+ * Use poll() if we don't have select().
+ */
+
+#define USE_POLL 0
+
+/*
+ * Do we have various image libraries?
+ */
+
+/* #undef HAVE_LIBPNG */
+/* #undef HAVE_LIBZ */
+/* #undef HAVE_LIBJPEG */
+
+/*
+ * Which header file do we include for libpng?
+ */
+
+/* #undef HAVE_PNG_H */
+/* #undef HAVE_LIBPNG_PNG_H */
+
+/*
+ * Do we have the png_xyz() functions?
+ */
+
+/* #undef HAVE_PNG_GET_VALID */
+/* #undef HAVE_PNG_SET_TRNS_TO_ALPHA */
+
+/*
+ * Do we have POSIX threading?
+ */
+
+/* #undef HAVE_PTHREAD */
+/* #undef HAVE_PTHREAD_H */
+
+
+/*
+ * End of "$Id: config.mingw,v 1.1.2.3.2.10 2003/01/30 21:41:07 easysw Exp $".
+ */
diff --git a/makefiles/config.os2x b/makefiles/config.os2x
new file mode 100644
index 0000000..353a24f
--- /dev/null
+++ b/makefiles/config.os2x
@@ -0,0 +1,224 @@
+/* config.h. Generated automatically by configure. */
+/*
+ * "$Id: config.os2x,v 1.1.2.4.2.12 2003/01/30 21:41:08 easysw Exp $"
+ *
+ * Configuration file for the Fast Light Tool Kit (FLTK).
+ *
+ * Copyright 1998-2003 by Bill Spitzak and others.
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Library General Public
+ * License as published by the Free Software Foundation; either
+ * version 2 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Library General Public License for more details.
+ *
+ * You should have received a copy of the GNU Library General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+ * USA.
+ *
+ * Please report all bugs and problems to "fltk-bugs@fltk.org".
+ */
+
+/*
+ * Where to find files...
+ */
+
+#define FLTK_DATADIR "/usr/local/share/fltk"
+#define FLTK_DOCDIR "/usr/local/share/doc/fltk"
+
+/*
+ * BORDER_WIDTH:
+ *
+ * Thickness of FL_UP_BOX and FL_DOWN_BOX. Current 1,2, and 3 are
+ * supported.
+ *
+ * 3 is the historic FLTK look.
+ * 2 is the default and looks like Microsoft Windows, KDE, and Qt.
+ * 1 is a plausible future evolution...
+ *
+ * Note that this may be simulated at runtime by redefining the boxtypes
+ * using Fl::set_boxtype().
+ */
+
+#define BORDER_WIDTH 2
+
+/*
+ * HAVE_GL:
+ *
+ * Do you have OpenGL? Set this to 0 if you don't have or plan to use
+ * OpenGL, and FLTK will be smaller.
+ */
+
+#define HAVE_GL 0
+
+/*
+ * HAVE_GL_GLU_H:
+ *
+ * Do you have the OpenGL Utility Library header file?
+ * (many broken Mesa RPMs do not...)
+ */
+
+#define HAVE_GL_GLU_H 1
+
+/*
+ * USE_COLORMAP:
+ *
+ * Setting this to zero will save a good deal of code (especially for
+ * fl_draw_image), but FLTK will only work on TrueColor visuals.
+ */
+
+#define USE_COLORMAP 1
+
+/*
+ * USE_XFT
+ *
+ * Use the new Xft library to draw anti-aliased text.
+ */
+
+#define USE_XFT 0
+
+/*
+ * HAVE_XDBE:
+ *
+ * Do we have the X double-buffer extension?
+ */
+
+#define HAVE_XDBE 1
+
+/*
+ * USE_XDBE:
+ *
+ * Actually try to use the double-buffer extension?
+ */
+
+#define USE_XDBE HAVE_XDBE
+
+/*
+ * HAVE_OVERLAY:
+ *
+ * Use the X overlay extension? FLTK will try to use an overlay
+ * visual for Fl_Overlay_Window, the Gl_Window overlay, and for the
+ * menus. Setting this to zero will remove a substantial amount of
+ * code from FLTK. Overlays have only been tested on SGI servers!
+ */
+
+#define HAVE_OVERLAY 0
+
+/*
+ * HAVE_GL_OVERLAY:
+ *
+ * It is possible your GL has an overlay even if X does not. If so,
+ * set this to 1.
+ */
+
+#define HAVE_GL_OVERLAY HAVE_OVERLAY
+
+/*
+ * WORDS_BIGENDIAN:
+ *
+ * Byte order of your machine: 1 = big-endian, 0 = little-endian.
+ */
+
+#define WORDS_BIGENDIAN 0
+
+/*
+ * U16, U32, U64:
+ *
+ * Types used by fl_draw_image. One of U32 or U64 must be defined.
+ * U16 is optional but FLTK will work better with it!
+ */
+
+#define U16 unsigned short
+#define U32 unsigned
+/* #undef U64 */
+
+/*
+ * HAVE_DIRENT_H, HAVE_SYS_NDIR_H, HAVE_SYS_DIR_H, HAVE_NDIR_H, HAVE_SCANDIR:
+ *
+ * Where is <dirent.h> (used only by fl_file_chooser and scandir).
+ */
+
+#define HAVE_DIRENT_H 1
+/* #undef HAVE_SYS_NDIR_H */
+/* #undef HAVE_SYS_DIR_H */
+/* #undef HAVE_NDIR_H */
+/* #undef HAVE_SCANDIR */
+
+/*
+ * Possibly missing sprintf-style functions:
+ */
+
+#define HAVE_VSNPRINTF 1
+#define HAVE_SNPRINTF 1
+
+/*
+ * String functions and headers...
+ */
+
+#define HAVE_STRINGS_H 1
+#define HAVE_STRCASECMP 1
+/* #undef HAVE_STRLCAT*/
+/* #undef HAVE_STRLCPY*/
+
+/*
+ * HAVE_SYS_SELECT_H:
+ *
+ * Whether or not select() call has its own header file.
+ */
+
+#define HAVE_SYS_SELECT_H 1
+
+/*
+ * HAVE_SYS_STDTYPES_H:
+ *
+ * Whether or not we have the <sys/stdtypes.h> header file.
+ */
+
+/* #undef HAVE_SYS_STDTYPES_H */
+
+/*
+ * USE_POLL:
+ *
+ * Use the poll() call provided on Linux and Irix instead of select()
+ */
+
+#define USE_POLL 0
+
+/*
+ * Do we have various image libraries?
+ */
+
+#define HAVE_LIBPNG 1
+#define HAVE_LIBZ 1
+#define HAVE_LIBJPEG 1
+
+/*
+ * Which header file do we include for libpng?
+ */
+
+#define HAVE_PNG_H 1
+/* #undef HAVE_LIBPNG_PNG_H */
+
+/*
+ * Do we have the png_xyz() functions?
+ */
+
+#define HAVE_PNG_GET_VALID 1
+/* #undef HAVE_PNG_SET_TRNS_TO_ALPHA */
+
+/*
+ * Do we have POSIX threading?
+ */
+
+/* #undef HAVE_PTHREAD */
+/* #undef HAVE_PTHREAD_H */
+
+
+/*
+ * End of "$Id: config.os2x,v 1.1.2.4.2.12 2003/01/30 21:41:08 easysw Exp $".
+ */
diff --git a/makefiles/makeinclude.mingw b/makefiles/makeinclude.mingw
new file mode 100644
index 0000000..ed0d008
--- /dev/null
+++ b/makefiles/makeinclude.mingw
@@ -0,0 +1,126 @@
+#
+# "$Id: makeinclude.mingw,v 1.1.2.3.2.11 2002/07/14 17:03:31 easysw Exp $"
+#
+# Make include file for the Fast Light Tool Kit (FLTK).
+# (this file for MingW using GCC 2.95.x)
+#
+# Copyright 1998-2001 by Bill Spitzak and others.
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+#
+# Please report all bugs and problems to "fltk-bugs@fltk.org".
+#
+
+# Notes:
+#
+# 1) Console windows appearing
+#
+# Consoles will not appear when run from a command line prompt
+# but will cause an 'unnecessary' console to appear when run directly from
+# windows (say explorer). It provides i/o for stdin/stdout for debugging
+#
+# To avoid this add "-mwindows" to LDLIBS and GLDLIBS below
+#
+# 2) Stripping the executable to reduce size
+#
+# An external program may be run to strip out any debug symbols:
+# strip filename.exe
+#
+# Alternatively add -s option to LDLIBS and GLDLIBS below to strip all
+# symbols. (or -S for stripping of debug symbols only). See 'ld' man page
+# for other useful link-time options.
+#
+# The default is to leave -mwindows and the stripping off, so as to facilitate
+# debugging. For release it may be appropriate to add these additional switches
+
+
+prefix = /usr/local
+exec_prefix = ${prefix}
+bindir = ${exec_prefix}/bin
+includedir = ${prefix}/include
+libdir = ${exec_prefix}/lib
+srcdir = .
+
+# programs we use...
+CHMOD = :
+CP = copy
+HTMLDOC = htmldoc.exe
+LN = :
+MKDIR = md
+NROFF = nroff
+RM = del
+RMDIR = rd
+STRIP = :
+
+# compiler names:
+CXX = g++
+CC = gcc
+MAKEDEPEND = $(CXX) -M
+POSTBUILD = :
+
+# flags for C++ compiler:
+CFLAGS = -Wall -O2 -DWIN32
+CXXFLAGS = -Wall -O2 -DWIN32
+
+# program to make the archive:
+LIBNAME = ../lib/libfltk.a
+FLLIBNAME = ../lib/libfltk_forms.a
+GLLIBNAME = ../lib/libfltk_gl.a
+IMGLIBNAME = ../lib/libfltk_images.a
+LIBCOMMAND = ar -ruv
+RANLIB = ranlib
+DSONAME =
+FLDSONAME =
+GLDSONAME =
+IMGDSONAME =
+DSOCOMMAND = echo
+
+# libraries to link with (in addition to default libs):
+LDLIBS =-mwindows -lgdi32 -lcomctl32 -lwsock32
+GLDLIBS =-mwindows -lglu32 -lopengl32 -lgdi32 -lcomctl32 -lwsock32
+LINKFLTK =-L../lib -lfltk
+LINKFLTKGL =-L../lib -lfltk_gl
+LINKFLTKFORMS =-L../lib -lfltk_forms -lfltk
+LINKFLTKIMG =-L../lib -lfltk_images -lfltk
+IMAGELIBS =
+
+# Do we build the OpenGL demos?
+GLDEMOS =gldemos
+
+# Do we build the threads demo?
+THREADS =threads
+
+# Be quiet when building...
+.SILENT:
+
+# Build commands and filename extensions...
+.SUFFIXES: .c .cxx .h .fl .o
+
+.cxx:
+ echo Compiling and linking $@...
+ $(CXX) -I.. $(CXXFLAGS) $< $(LINKFLTK) $(LDLIBS) -o $@
+
+.c.o:
+ echo Compiling $@...
+ $(CC) -I.. $(CXXFLAGS) $< -c
+
+.cxx.o:
+ echo Compiling $@...
+ $(CXX) -I.. $(CXXFLAGS) $< -c
+
+#
+# End of "$Id: makeinclude.mingw,v 1.1.2.3.2.11 2002/07/14 17:03:31 easysw Exp $".
+#
diff --git a/makefiles/makeinclude.mingw31 b/makefiles/makeinclude.mingw31
new file mode 100644
index 0000000..b726a38
--- /dev/null
+++ b/makefiles/makeinclude.mingw31
@@ -0,0 +1,126 @@
+#
+# "$Id: makeinclude.mingw31,v 1.1.2.3 2003/01/30 21:41:09 easysw Exp $"
+#
+# Make include file for the Fast Light Tool Kit (FLTK).
+# (this file for MingW using GCC 3.1.x)
+#
+# Copyright 1998-2003 by Bill Spitzak and others.
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+#
+# Please report all bugs and problems to "fltk-bugs@fltk.org".
+#
+
+# Notes:
+#
+# 1) Console windows appearing
+#
+# Consoles will not appear when run from a command line prompt
+# but will cause an 'unnecessary' console to appear when run directly from
+# windows (say explorer). It provides i/o for stdin/stdout for debugging
+#
+# To avoid this add "-mwindows" to LDLIBS and GLDLIBS below
+#
+# 2) Stripping the executable to reduce size
+#
+# An external program may be run to strip out any debug symbols:
+# strip filename.exe
+#
+# Alternatively add -s option to LDLIBS and GLDLIBS below to strip all
+# symbols. (or -S for stripping of debug symbols only). See 'ld' man page
+# for other useful link-time options.
+#
+# The default is to leave -mwindows and the stripping off, so as to facilitate
+# debugging. For release it may be appropriate to add these additional switches
+
+
+prefix = /usr/local
+exec_prefix = ${prefix}
+bindir = ${exec_prefix}/bin
+includedir = ${prefix}/include
+libdir = ${exec_prefix}/lib
+srcdir = .
+
+# programs we use...
+CHMOD = :
+CP = copy
+HTMLDOC = htmldoc.exe
+LN = :
+MKDIR = md
+NROFF = nroff
+RM = del
+RMDIR = rd
+STRIP = :
+
+# compiler names:
+CXX = g++
+CC = gcc
+MAKEDEPEND = $(CXX) -M
+POSTBUILD = :
+
+# flags for C++ compiler:
+CFLAGS = -Wall -O2 -DWIN32
+CXXFLAGS = -Wall -O2 -DWIN32
+
+# program to make the archive:
+LIBNAME = ../lib/libfltk.a
+FLLIBNAME = ../lib/libfltk_forms.a
+GLLIBNAME = ../lib/libfltk_gl.a
+IMGLIBNAME = ../lib/libfltk_images.a
+LIBCOMMAND = ar -ruv
+RANLIB = ranlib
+DSONAME =
+FLDSONAME =
+GLDSONAME =
+IMGDSONAME =
+DSOCOMMAND = echo
+
+# libraries to link with (in addition to default libs):
+LDLIBS =-mwindows -lole32 -luuid -lgdi32 -lcomctl32 -lwsock32 -lsupc++
+GLDLIBS =-mwindows -lole32 -luuid -lglu32 -lopengl32 -lgdi32 -lcomctl32 -lwsock32 -lsupc++
+LINKFLTK =-L../lib -lfltk
+LINKFLTKGL =-L../lib -lfltk_gl
+LINKFLTKFORMS =-L../lib -lfltk_forms -lfltk
+LINKFLTKIMG =-L../lib -lfltk_images -lfltk
+IMAGELIBS =
+
+# Do we build the OpenGL demos?
+GLDEMOS =gldemos
+
+# Do we build the threads demo?
+THREADS =threads
+
+# Be quiet when building...
+.SILENT:
+
+# Build commands and filename extensions...
+.SUFFIXES: .c .cxx .h .fl .o
+
+.cxx:
+ echo Compiling and linking $@...
+ $(CXX) -I.. $(CXXFLAGS) $< $(LINKFLTK) $(LDLIBS) -o $@
+
+.c.o:
+ echo Compiling $@...
+ $(CC) -I.. $(CXXFLAGS) $< -c
+
+.cxx.o:
+ echo Compiling $@...
+ $(CXX) -I.. $(CXXFLAGS) $< -c
+
+#
+# End of "$Id: makeinclude.mingw31,v 1.1.2.3 2003/01/30 21:41:09 easysw Exp $".
+#
diff --git a/makefiles/makeinclude.os2x b/makefiles/makeinclude.os2x
new file mode 100644
index 0000000..9356c07
--- /dev/null
+++ b/makefiles/makeinclude.os2x
@@ -0,0 +1,128 @@
+#
+# "$Id: makeinclude.os2x,v 1.1.2.4.2.11 2003/01/30 21:41:10 easysw Exp $"
+#
+# Make include file for the Fast Light Tool Kit (FLTK).
+#
+# Copyright 1998-2003 by Bill Spitzak and others.
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+#
+# Please report all bugs and problems to "fltk-bugs@fltk.org".
+#
+
+prefix = /usr/local
+exec_prefix = ${prefix}
+bindir = ${exec_prefix}/bin
+datadir = ${prefix}/share
+includedir = ${prefix}/include
+libdir = ${exec_prefix}/lib
+mandir = ${prefix}/man
+srcdir = ./.
+VPATH = ./.
+
+# programs we use...
+CHMOD = :
+CP = copy
+HTMLDOC = htmldoc.exe
+LN = :
+MKDIR = md
+NROFF = nroff
+RM = del
+RMDIR = rd
+STRIP = :
+
+# compiler names:
+CXX = gcc.exe
+CC = gcc.exe
+MAKEDEPEND = $(CXX) -M
+
+# flags for C++ compiler:
+OPTIM = -O2 -Wall -fno-exceptions
+CFLAGS = $(OPTIM) -O4 -mpentium -Zmt
+CXXFLAGS = $(OPTIM) -O4 -mpentium -Zmt
+
+# program to make the archive:
+LIBNAME = ../lib/libfltk.a
+FLLIBNAME = ../lib/libfltk_forms.a
+GLLIBNAME =
+IMGLIBNAME = ../lib/libfltk_images.a
+LIBCOMMAND = ar.exe cr
+RANLIB = ar.exe s
+DSONAME =
+FLDSONAME =
+GLDSONAME =
+IMGDSONAME =
+DSOCOMMAND =echo
+
+# libraries to link with:
+LDLIBS = -s -Zmt -Zcrtdll -Zbsd-signals -lXext -lX11 -lsocket
+GLDLIBS = -s -Zmt -Zcrtdll -Zbsd-signals -lXext -lX11 -lsocket -lshm
+LINKFLTK = ../lib/libfltk.a
+LINKFLTKGL = -L../lib
+LINKFLTKFORMS = ../lib/libfltk_forms.a ../lib/libfltk.a
+LINKFLTKIMG = ../lib/libfltk_images.a ../lib/libfltk.a
+IMAGELIBS = -lpng -ljpeg -lz
+
+# Do we build the OpenGL demos?
+GLDEMOS =
+
+# Do we build the threads demo?
+THREADS =
+
+# The extension to use for executables...
+EXEEXT =.exe
+
+# Possible steps after linking...
+POSTBUILD =:
+
+# Man page extensions...
+CAT1EXT =1
+CAT3EXT =3
+
+# Be quiet when building...
+.SILENT:
+
+# Build commands and filename extensions...
+.SUFFIXES: .0 .1 .3 .c .cxx .h .fl .man .o .z $(EXEEXT)
+
+.o$(EXEEXT):
+ echo Linking $@...
+ $(CXX) -I.. $(CXXFLAGS) $< $(LINKFLTK) $(LDLIBS) -o $@
+ $(POSTBUILD) $@ ../FL/mac.r
+
+.c.o:
+ echo Compiling $<...
+ $(CC) -I.. $(CFLAGS) -c $<
+
+.cxx.o:
+ echo Compiling $<...
+ $(CXX) -I.. $(CXXFLAGS) -c $<
+
+.man.0 .man.1 .man.3:
+ echo Formatting $<...
+ rm -f $@
+ $(NROFF) -man $< >$@
+
+.man.z:
+ echo Formatting $<...
+ rm -f $@ t.z
+ $(NROFF) -man $< >t
+ pack -f t
+ mv t.z $@
+
+#
+# End of "$Id: makeinclude.os2x,v 1.1.2.4.2.11 2003/01/30 21:41:10 easysw Exp $".
+#