summaryrefslogtreecommitdiff
path: root/makefiles
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2006-01-20 02:00:49 +0000
committerAaron M. Ucko <ucko@debian.org>2006-01-20 02:00:49 +0000
commita7324bb0c2a26bb02be3362dff2126dc6c6af3a4 (patch)
tree64e6a26efbbc09e90a07afcf91a4b968d906955e /makefiles
parent561e57f79c1c365a2ff6c31fc32f36ba70d21cae (diff)
Load /tmp/.../fltk1.1-1.1.7 into
branches/upstream/current.
Diffstat (limited to 'makefiles')
-rw-r--r--makefiles/Makefile.mingw4
-rw-r--r--makefiles/Makefile.os2x4
-rw-r--r--makefiles/config.mingw11
-rw-r--r--makefiles/config.os2x11
-rw-r--r--makefiles/makeinclude.mingw4
-rw-r--r--makefiles/makeinclude.mingw314
-rw-r--r--makefiles/makeinclude.os2x4
7 files changed, 28 insertions, 14 deletions
diff --git a/makefiles/Makefile.mingw b/makefiles/Makefile.mingw
index 82ff02a..ca4fd15 100644
--- a/makefiles/Makefile.mingw
+++ b/makefiles/Makefile.mingw
@@ -1,5 +1,5 @@
#
-# "$Id: Makefile.mingw,v 1.1.2.2.2.1 2004/10/18 20:22:22 easysw Exp $"
+# "$Id: Makefile.mingw 4052 2005-02-24 21:55:12Z mike $"
#
# Top-level makefile for the Fast Light Tool Kit (FLTK).
#
@@ -110,5 +110,5 @@ makeinclude: makefiles/makeinclude.mingw
cp $< $@
#
-# End of "$Id: Makefile.mingw,v 1.1.2.2.2.1 2004/10/18 20:22:22 easysw Exp $".
+# End of "$Id: Makefile.mingw 4052 2005-02-24 21:55:12Z mike $".
#
diff --git a/makefiles/Makefile.os2x b/makefiles/Makefile.os2x
index 6373be6..7659699 100644
--- a/makefiles/Makefile.os2x
+++ b/makefiles/Makefile.os2x
@@ -1,5 +1,5 @@
#
-# "$Id: Makefile.os2x,v 1.6.2.7 2001/04/26 07:11:58 spitzak Exp $"
+# "$Id: Makefile.os2x 4052 2005-02-24 21:55:12Z mike $"
#
# Top-level makefile for the Fast Light Tool Kit (FLTK).
#
@@ -74,5 +74,5 @@ makeinclude: makefiles/makeinclude.os2x
cp $< $@
#
-# End of "$Id: Makefile.os2x,v 1.6.2.7 2001/04/26 07:11:58 spitzak Exp $".
+# End of "$Id: Makefile.os2x 4052 2005-02-24 21:55:12Z mike $".
#
diff --git a/makefiles/config.mingw b/makefiles/config.mingw
index 00cabd9..cf3d3e9 100644
--- a/makefiles/config.mingw
+++ b/makefiles/config.mingw
@@ -1,5 +1,5 @@
/*
- * "$Id: config.mingw,v 1.1.2.3.2.10 2003/01/30 21:41:07 easysw Exp $"
+ * "$Id: config.mingw 4454 2005-07-24 18:41:30Z matt $"
*
* Configuration file for the Fast Light Tool Kit (FLTK).
*
@@ -169,6 +169,13 @@
/* #undef HAVE_STRLCPY */
/*
+ * Do we have POSIX locale support?
+ */
+
+#define HAVE_LOCALE_H 1
+#define HAVE_LOCALECONV 1
+
+/*
* HAVE_SYS_SELECT_H:
*
* Whether or not select() call has its own header file.
@@ -215,5 +222,5 @@
/*
- * End of "$Id: config.mingw,v 1.1.2.3.2.10 2003/01/30 21:41:07 easysw Exp $".
+ * End of "$Id: config.mingw 4454 2005-07-24 18:41:30Z matt $".
*/
diff --git a/makefiles/config.os2x b/makefiles/config.os2x
index 353a24f..2ecec3b 100644
--- a/makefiles/config.os2x
+++ b/makefiles/config.os2x
@@ -1,6 +1,6 @@
/* config.h. Generated automatically by configure. */
/*
- * "$Id: config.os2x,v 1.1.2.4.2.12 2003/01/30 21:41:08 easysw Exp $"
+ * "$Id: config.os2x 4454 2005-07-24 18:41:30Z matt $"
*
* Configuration file for the Fast Light Tool Kit (FLTK).
*
@@ -166,6 +166,13 @@
/* #undef HAVE_STRLCPY*/
/*
+ * Do we have POSIX locale support?
+ */
+
+#define HAVE_LOCALE_H 1
+#define HAVE_LOCALECONV 1
+
+/*
* HAVE_SYS_SELECT_H:
*
* Whether or not select() call has its own header file.
@@ -220,5 +227,5 @@
/*
- * End of "$Id: config.os2x,v 1.1.2.4.2.12 2003/01/30 21:41:08 easysw Exp $".
+ * End of "$Id: config.os2x 4454 2005-07-24 18:41:30Z matt $".
*/
diff --git a/makefiles/makeinclude.mingw b/makefiles/makeinclude.mingw
index 5891334..01d4b9c 100644
--- a/makefiles/makeinclude.mingw
+++ b/makefiles/makeinclude.mingw
@@ -1,5 +1,5 @@
#
-# "$Id: makeinclude.mingw,v 1.1.2.3.2.14 2004/10/18 20:22:22 easysw Exp $"
+# "$Id: makeinclude.mingw 4052 2005-02-24 21:55:12Z mike $"
#
# Make include file for the Fast Light Tool Kit (FLTK).
# (this file for MingW using GCC 2.95.x)
@@ -140,5 +140,5 @@ CAT3EXT = 3
$(CXX) -I.. -I../png -I../jpeg -I../zlib $(CXXFLAGS) $< -c
#
-# End of "$Id: makeinclude.mingw,v 1.1.2.3.2.14 2004/10/18 20:22:22 easysw Exp $".
+# End of "$Id: makeinclude.mingw 4052 2005-02-24 21:55:12Z mike $".
#
diff --git a/makefiles/makeinclude.mingw31 b/makefiles/makeinclude.mingw31
index ba75a83..7239526 100644
--- a/makefiles/makeinclude.mingw31
+++ b/makefiles/makeinclude.mingw31
@@ -1,5 +1,5 @@
#
-# "$Id: makeinclude.mingw31,v 1.1.2.4 2004/07/23 19:26:26 easysw Exp $"
+# "$Id: makeinclude.mingw31 4052 2005-02-24 21:55:12Z mike $"
#
# Make include file for the Fast Light Tool Kit (FLTK).
# (this file for MingW using GCC 3.1.x)
@@ -123,5 +123,5 @@ THREADS =threads
$(CXX) -I.. $(CXXFLAGS) $< -c
#
-# End of "$Id: makeinclude.mingw31,v 1.1.2.4 2004/07/23 19:26:26 easysw Exp $".
+# End of "$Id: makeinclude.mingw31 4052 2005-02-24 21:55:12Z mike $".
#
diff --git a/makefiles/makeinclude.os2x b/makefiles/makeinclude.os2x
index 2c5c2f0..698dba0 100644
--- a/makefiles/makeinclude.os2x
+++ b/makefiles/makeinclude.os2x
@@ -1,5 +1,5 @@
#
-# "$Id: makeinclude.os2x,v 1.1.2.4.2.13 2004/07/23 19:26:26 easysw Exp $"
+# "$Id: makeinclude.os2x 4052 2005-02-24 21:55:12Z mike $"
#
# Make include file for the Fast Light Tool Kit (FLTK).
#
@@ -125,5 +125,5 @@ CAT3EXT =3
mv t.z $@
#
-# End of "$Id: makeinclude.os2x,v 1.1.2.4.2.13 2004/07/23 19:26:26 easysw Exp $".
+# End of "$Id: makeinclude.os2x 4052 2005-02-24 21:55:12Z mike $".
#