summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2015-12-13 11:54:10 -0700
committerDavid Bremner <bremner@debian.org>2019-08-26 16:35:46 -0300
commitfd7a712f53d1d90b0c4594d9db25d72e5a897ad0 (patch)
tree7396b647b9756b39afb3f1832dc21827d3acd02d
parent027aef2f9149d89aec354a7ffa7879bd7d6c650d (diff)
fix-tests
Gbp-Pq: Name 0002-fix-tests.patch
-rw-r--r--Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 84a21f9..202dba8 100644
--- a/Makefile
+++ b/Makefile
@@ -20,17 +20,15 @@ show-version:
echo "EMACS = `which ${EMACS}`"
${EMACS} --version
-install-ert:
- emacs --batch -L "${PWD}/lib/ert/lisp/emacs-lisp" --eval "(require 'ert)" || ( git clone git://github.com/ohler/ert.git lib/ert && cd lib/ert && git checkout 00aef6e43 )
-
-
-before-test: show-version install-ert
+before-test: show-version
test: before-test
- ${EMACS} -Q -L . -l tests/run-test.el
+ ${EMACS} -batch -Q -L /usr/share/emacs/site-lisp/elpa-src/async-* \
+ -l tests/run-test.el
test-nw: before-test
- ${EMACS} -Q -nw -L . -l tests/run-test.el
+ ${EMACS} -batch -Q -nw -L /usr/share/emacs/site-lisp/elpa-src/async-* \
+ -l tests/run-test.el
travis-ci: before-test
echo ${EMACS-OPTIONS}