summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasudev Kamath <kamathvasudev@gmail.com>2016-01-17 10:17:39 +0530
committerVasudev Kamath <kamathvasudev@gmail.com>2016-01-17 10:17:39 +0530
commit1f36f6137d4669095ce2f89b6c7ae1b04cb1f0ce (patch)
tree08d8c39a488d62ce42ffbed34e9fb9c08b10a01f
parent4c2c5a8b03133737c49c8a4f15c124911e95761a (diff)
Use github API to pull down source from commit
-rwxr-xr-xdebian/rules11
1 files changed, 8 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index cd9f745..943ac67 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,9 +24,14 @@ include /usr/share/cdbs/1/rules/upstream-tarball.mk
include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/rules/debhelper.mk
-# Uncomment below lines once upstream tags its releases.
-# DEB_UPSTREAM_URL = https://github.com/zeux/pugixml/archive
-# DEB_UPSTREAM_TARBALL_BASENAME = v$(DEB_UPSTREAM_TARBALL_VERSION)
+
+DEB_UPSTREAM_URL = https://github.com/google/roboto/archive
+DEB_UPSTREAM_PACKAGE = RobotoFonts
+DEB_UPSTREAM_TARBALL_SRCDIR = roboto-fonts-$(DEB_UPSTREAM_TARBALL_BASENAME)
+
+DEB_UPSTREAM_TARBALL_SRCDIR += $(if \
+ $(filter $(DEB_UPSTREAM_PACKAGE)-%,$(DEB_UPSTREAM_TARBALL_BASENAME)),\
+ $(error set DEB_UPSTREAM_TARBALL_BASENAME to commit hash))
# extract metadata from images before copyright check
CDBS_BUILD_DEPENDS +=, libregexp-assemble-perl, libimage-exiftool-perl