summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoozbeh Pournader <roozbeh@google.com>2014-07-26 18:22:18 -0700
committerRoozbeh Pournader <roozbeh@google.com>2014-07-26 18:22:18 -0700
commit54bfaf54e7eb1fd074a68127c11f4248748a09c8 (patch)
tree34c23721a960471f37e9b0a0119865972bd2be8d
parent68da4c8664d2a242a39723b90651f22812cb73e7 (diff)
Rename bezier curve pieces to .bez to avoid conflict with bzip files.
Also made Makefile clean temporary directories.
-rw-r--r--third_party/fontcrunch/Makefile11
-rw-r--r--third_party/fontcrunch/fontcrunch.py2
2 files changed, 7 insertions, 6 deletions
diff --git a/third_party/fontcrunch/Makefile b/third_party/fontcrunch/Makefile
index a682f73..8c79ce8 100644
--- a/third_party/fontcrunch/Makefile
+++ b/third_party/fontcrunch/Makefile
@@ -14,18 +14,19 @@
#
# Contributor: Raph Levien
-SRC = $(wildcard */*.bz)
-OPT = $(patsubst %.bz, %.bzopt, $(SRC))
+SRC = $(wildcard */*.bez)
+OPT = $(patsubst %.bez, %.bezopt, $(SRC))
dummy: $(OPT)
quadopt: quadopt.cc
$(CXX) $< -std=c++11 -O3 -o $@
-%.bzopt: %.bz quadopt
+%.bezopt: %.bez quadopt
./quadopt $< $@
clean:
rm -f quadopt
- find . -name '*.bz' -delete
- find . -name '*.bzopt' -delete \ No newline at end of file
+ find . -name '*.bez' -delete
+ find . -name '*.bezopt' -delete
+ rmdir ?? \ No newline at end of file
diff --git a/third_party/fontcrunch/fontcrunch.py b/third_party/fontcrunch/fontcrunch.py
index 68f68e4..eba721a 100644
--- a/third_party/fontcrunch/fontcrunch.py
+++ b/third_party/fontcrunch/fontcrunch.py
@@ -325,7 +325,7 @@ def seg_fn(segstr):
if not os.path.exists(dirname):
os.mkdir(dirname)
fn = dirname + '/' + fn[2:]
- fn += '.bz'
+ fn += '.bez'
return fn
def gen_segs(glyph):