summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRoozbeh Pournader <roozbeh@google.com>2014-07-03 23:36:52 -0700
committerRoozbeh Pournader <roozbeh@google.com>2014-07-03 23:36:52 -0700
commit2b5dca5d77e7394df66fa8f2e8a827b1c6fec441 (patch)
tree89c70d0fd07ce51040aacc6c1de6941a4fa82107 /Makefile
parentf61afcb339de59c70645c662fb4b72482b02920d (diff)
Rework the font processing for Android.
yMin and yMax values needed for Android are now set after the subsetting in a separate script. The touchup script is also divided into Android-specific changes and general ones.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index d5cb739..af719f0 100644
--- a/Makefile
+++ b/Makefile
@@ -28,11 +28,13 @@ mono:
open -nWa "$(FONTLAB)" /tmp/makefonts.flw
android:
- rm -rf out/android/temp
- mkdir --parents out/android/temp
- for f in out/RobotoTTF/*.ttf out/RobotoCondensedTTF/*.ttf; do \
- temp_location=out/android/temp/$$(basename $$f); \
- final_location=out/android/$$(basename $$f); \
- python scripts/touchup_for_android.py $$f $$temp_location; \
- python $$HOME/noto/nototools/subset.py $$temp_location $$final_location; \
+ mkdir -p out/android
+ for source in out/RobotoTTF/*.ttf out/RobotoCondensedTTF/*.ttf; do \
+ touched=$$(mktemp); \
+ subsetted=$$(mktemp); \
+ final=out/android/$$(basename $$source); \
+ python scripts/touchup_for_android.py $$source $$touched; \
+ python $$HOME/noto/nototools/subset.py $$touched $$subsetted; \
+ python scripts/force_yminmax.py $$subsetted $$final; \
+ rm $$touched $$subsetted; \
done