summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorVasudev Kamath <kamathvasudev@gmail.com>2015-10-24 18:06:08 +0530
committerVasudev Kamath <kamathvasudev@gmail.com>2015-10-24 18:06:08 +0530
commite367e141ed8f00c307fa55c748e588021f8e59d6 (patch)
tree11791afa6b55637dea148214a77597fadecba2b6 /debian/rules
parent8b1619d1a1cdb9a2da65a3f2bbf823cb96bca08b (diff)
Add rules file and needed script.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules48
1 files changed, 48 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..cd9f745
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,48 @@
+#!/usr/bin/make -f
+
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2013, 2015 Jonas Smedegaard <dr@jones.dk>
+# Copyright © 2013-2015 Vasudev Kamath <kamathvasudev@gmail.com>
+# Description: Main Debian packaging script for pugixml
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+# This needs to declared/run before including CDBS snippets
+
+include /usr/share/cdbs/1/rules/upstream-tarball.mk
+include /usr/share/cdbs/1/rules/utils.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+# Uncomment below lines once upstream tags its releases.
+# DEB_UPSTREAM_URL = https://github.com/zeux/pugixml/archive
+# DEB_UPSTREAM_TARBALL_BASENAME = v$(DEB_UPSTREAM_TARBALL_VERSION)
+
+# extract metadata from images before copyright check
+CDBS_BUILD_DEPENDS +=, libregexp-assemble-perl, libimage-exiftool-perl
+CDBS_BUILD_DEPENDS +=, libfont-ttf-perl
+local_inspection_regex = ttf|ttc
+DEB_COPYRIGHT_CHECK_IGNORE_REGEX = ^((.*/)?[^/]+\.($(local_inspection_regex))|debian/(changelog|copyright(|_hints|_newhints)))$$
+
+debian/stamp-copyright-check: debian/stamp-extract-copyright
+debian/stamp-extract-copyright:
+ find * -type f -regextype posix-extended \
+ -regex '.*\.($(local_inspection_regex))' \
+ -print0 | perl -0 debian/license-miner
+ touch $@
+pre-build:: clean-extracted-copyright-during-build
+clean-extracted-copyright-during-build: debian/stamp-copyright-check
+ find -type f -name '*.metadata_dump' -delete
+clean::
+ find -type f -name '*.metadata_dump' -delete
+ rm -f debian/stamp-extract-copyright