summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDidier Raboud <didier@raboud.com>2010-11-04 15:34:01 +0100
committerDidier Raboud <didier@raboud.com>2010-11-04 16:13:19 +0100
commit8e0673112c3f2af54c1f90904936001704f12b5b (patch)
tree2b41f094311589a4c2bc51111b58cc7b43be56b1 /debian/rules
parent69a9602287b40590335673199ce381f3b13dcbfd (diff)
Remove the pyppd embedded copy, use a separate package.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 6 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 4d8c5cb2..67da6379 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,8 +13,7 @@ override_dh_auto_configure:
override_dh_auto_clean:
dh_auto_clean
rm -f debian/mygzip
- rm -f debian/local/pyppd/*/*.pyc
- rm -f debian/local/pyppd/pyppd-ppdfile
+ rm -f pyppd-ppdfile
rm -rf foomatic
override_dh_install:
@@ -52,16 +51,15 @@ override_dh_install:
# Compress the PPD files with Vitor Baptista's pyppd PPD
# archiving tool. This makes the space needed for PPDs at least
# 10 times smaller.
- (cd debian/local/pyppd/ && \
- PYTHONPATH=. bin/pyppd $(CURDIR)/debian/openprinting-ppds/usr/share/ppd/openprinting && \
+ ( pyppd $(CURDIR)/debian/openprinting-ppds/usr/share/ppd/openprinting && \
install -D -m 755 pyppd-ppdfile $(CURDIR)/debian/openprinting-ppds/usr/lib/cups/driver/openprinting-ppds && \
rm -rf $(CURDIR)/debian/openprinting-ppds/usr/share/ppd && \
- rm -f pyppd-ppdfile && \
- PYTHONPATH=. bin/pyppd $(CURDIR)/foomatic && \
+ rm -f pyppd-ppdfile \
+ )
+ ( pyppd $(CURDIR)/foomatic && \
install -D -m 755 pyppd-ppdfile $(CURDIR)/debian/foomatic-db-compressed-ppds/usr/lib/cups/driver/foomatic-db-compressed-ppds && \
rm -rf $(CURDIR)/foomatic && \
- rm -f pyppd-ppdfile && \
- rm -f */*.pyc \
+ rm -f pyppd-ppdfile \
)
# Install the apport hook on Ubuntu and derivatives