summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules18
3 files changed, 20 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index ccc91e19..d8035a96 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+foomatic-db (20100806-0ubuntu5) maverick; urgency=low
+
+ * debian/control: Added build and runtime dependencies for the PPD archiving
+ and extracting.
+ * debian/rules: Let build process error out if PPD archiving errors out.
+
+ -- Till Kamppeter <till.kamppeter@gmail.com> Wed, 11 Aug 2010 09:57:03 +0200
+
foomatic-db (20100806-0ubuntu4) maverick; urgency=low
* debian/local/pyppd/pyppd/ppd.py: The PPD compressor did not parse the
diff --git a/debian/control b/debian/control
index b45a2636..60809efe 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: text
Priority: optional
Maintainer: Debian Printing Group <debian-printing@lists.debian.org>
Uploaders: Chris Lawrence <lawrencc@debian.org>, Didier Raboud <didier@raboud.com>
-Build-Depends: debhelper (>> 7.0.50)
+Build-Depends: debhelper (>> 7.0.50), xz-utils, python-all-dev
Homepage: http://www.openprinting.org/
Vcs-Git: git://git.debian.org/collab-maint/foomatic-db.git
Vcs-Browser: http://git.debian.org/?p=collab-maint/foomatic-db.git
@@ -31,7 +31,7 @@ Description: OpenPrinting printer support - database
Package: openprinting-ppds
Architecture: all
-Depends: ${misc:Depends}, ${python:Depends}
+Depends: ${misc:Depends}, ${python:Depends}, xz-utils
Recommends: cups, cups-client
Suggests: hpijs-ppds
Replaces: linuxprinting.org-ppds, hp-ppd (<= 0.5)
@@ -55,7 +55,7 @@ Description: OpenPrinting printer support - PostScript PPD files
Package: openprinting-ppds-extra
Architecture: all
-Depends: ${misc:Depends}, ${python:Depends}
+Depends: ${misc:Depends}, ${python:Depends}, xz-utils
Recommends: foomatic-filters, cups, cups-client
Replaces: linuxprinting.org-ppds-extra, hp-ppd (<= 0.5), openprinting-ppds (<< 20100529-1)
Breaks: hp-ppd (<= 0.5), openprinting-ppds (<< 20100529-1)
diff --git a/debian/rules b/debian/rules
index 1f65bc6e..27d58112 100755
--- a/debian/rules
+++ b/debian/rules
@@ -48,15 +48,15 @@ override_dh_install:
# Compress the PPD files with Vitor Baptista's pyppd PPD
# archiving tool. This makes the space needed for PPDs at least
# 10 times smaller.
- (cd debian/local/pyppd/; \
- PYTHONPATH=. bin/pyppd $(CURDIR)/debian/openprinting-ppds/usr/share/ppd/openprinting; \
- install -D -m 755 pyppd-ppdfile $(CURDIR)/debian/openprinting-ppds/usr/lib/cups/driver/openprinting-ppds; \
- rm -rf $(CURDIR)/debian/openprinting-ppds/usr/share/ppd; \
- rm -f pyppd-ppdfile; \
- PYTHONPATH=. bin/pyppd $(CURDIR)/debian/openprinting-ppds-extra/usr/share/ppd/openprinting; \
- install -D -m 755 pyppd-ppdfile $(CURDIR)/debian/openprinting-ppds-extra/usr/lib/cups/driver/openprinting-ppds-extra; \
- rm -rf $(CURDIR)/debian/openprinting-ppds-extra/usr/share/ppd; \
- rm -f */*.pyc pyppd-ppdfile; \
+ (cd debian/local/pyppd/ && \
+ PYTHONPATH=. bin/pyppd $(CURDIR)/debian/openprinting-ppds/usr/share/ppd/openprinting && \
+ install -D -m 755 pyppd-ppdfile $(CURDIR)/debian/openprinting-ppds/usr/lib/cups/driver/openprinting-ppds && \
+ rm -rf $(CURDIR)/debian/openprinting-ppds/usr/share/ppd && \
+ rm -f pyppd-ppdfile && \
+ PYTHONPATH=. bin/pyppd $(CURDIR)/debian/openprinting-ppds-extra/usr/share/ppd/openprinting && \
+ install -D -m 755 pyppd-ppdfile $(CURDIR)/debian/openprinting-ppds-extra/usr/lib/cups/driver/openprinting-ppds-extra && \
+ rm -rf $(CURDIR)/debian/openprinting-ppds-extra/usr/share/ppd && \
+ rm -f */*.pyc pyppd-ppdfile \
)
# Install the apport hook on Ubuntu and derivatives