summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrediano Ziglio <freddy77@gmail.com>2019-03-28 03:54:45 +0000
committerFrediano Ziglio <freddy77@gmail.com>2019-03-28 03:55:14 +0000
commit1e45175bea38f49f8989e10ae3cb407ad1a61bc6 (patch)
tree2109c3408c2a48619aadfd95b3f4faa3dbd6606f
parente39c888cef8705426261a4ca04fdcc6b93ffc90f (diff)
cmake: Allow build from stable packaged version
For stable packaged version the version string was extracted from configure file however the regular expression used not supporting 1.x versions. Signed-off-by: Frediano Ziglio <freddy77@gmail.com>
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c33b7910..796625e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,7 @@ endif(COMMAND cmake_policy)
set(PACKAGE freetds)
unset(VERSION)
if(EXISTS "${CMAKE_SOURCE_DIR}/configure")
- file(STRINGS "${CMAKE_SOURCE_DIR}/configure" VER LIMIT_COUNT 1 REGEX "^[ ]*VERSION[ ]*=.*0")
+ file(STRINGS "${CMAKE_SOURCE_DIR}/configure" VER LIMIT_COUNT 1 REGEX "^[ ]*VERSION[ ]*=.*1[.]")
if(VER MATCHES "VERSION[ ]*=[ ]*'?([^' ]+)")
set(VERSION ${CMAKE_MATCH_1})
endif()