summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatteo F. Vescovi <mfv@debian.org>2018-06-14 09:56:14 -0300
committerMatteo F. Vescovi <mfv@debian.org>2018-06-14 09:56:14 -0300
commitf3d60ce8fc98a266b1d5fee06ed40c48ad7f0020 (patch)
tree8286d02335d82d266e5fb97677ee3e9b43d2958e
parent23ed2326633925e0f94b7d64ce116a526473e5e7 (diff)
parent34ad9ff2a7ca571111c59a738420926d40775346 (diff)
fsm-el (0.2.1-2) unstable; urgency=medium
* Rebuild with dh-elpa 1.13 to fix byte-compilation with unversioned Emacs (Closes: #900720) * debian/control: S-V bump 3.9.8 -> 4.1.4 (no changes needed) * debian/control: Vcs-* fields updated pointing to salsa * debian/control: Maintainer field updated * debian/rules: drop --parallel parameter * debian/: debhelper bump 10 -> 11 [dgit import unpatched fsm-el 0.2.1-2]
-rw-r--r--debian/changelog17
-rw-r--r--debian/compat1
-rw-r--r--debian/control50
-rw-r--r--debian/copyright28
-rw-r--r--debian/elpa1
-rw-r--r--debian/gbp.conf12
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/source/format1
8 files changed, 114 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..544abce
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,17 @@
+fsm-el (0.2.1-2) unstable; urgency=medium
+
+ * Rebuild with dh-elpa 1.13 to fix byte-compilation
+ with unversioned Emacs (Closes: #900720)
+ * debian/control: S-V bump 3.9.8 -> 4.1.4 (no changes needed)
+ * debian/control: Vcs-* fields updated pointing to salsa
+ * debian/control: Maintainer field updated
+ * debian/rules: drop --parallel parameter
+ * debian/: debhelper bump 10 -> 11
+
+ -- Matteo F. Vescovi <mfv@debian.org> Thu, 14 Jun 2018 14:56:14 +0200
+
+fsm-el (0.2.1-1) unstable; urgency=medium
+
+ * Initial release (Closes: #848127)
+
+ -- Matteo F. Vescovi <mfv@debian.org> Thu, 15 Dec 2016 21:44:53 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b4de394
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+11
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..f78414b
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,50 @@
+Source: fsm-el
+Section: lisp
+Priority: optional
+Maintainer: Debian Emacsen team <debian-emacsen@lists.debian.org>
+Uploaders: Matteo F. Vescovi <mfv@debian.org>
+Build-Depends: debhelper (>= 11~), dh-elpa
+Standards-Version: 4.1.4
+Vcs-Browser: https://salsa.debian.org/emacsen-team/fsm-el
+Vcs-Git: https://salsa.debian.org/emacsen-team/fsm-el.git
+Homepage: http://elpa.gnu.org/packages/fsm.html
+Testsuite: autopkgtest-pkg-elpa
+
+Package: elpa-fsm
+Architecture: all
+Depends: ${elpa:Depends}, ${misc:Depends}, emacs
+Recommends: emacs (>= 46.0)
+Enhances: emacs, emacs24, emacs25
+Built-Using: ${misc:Built-Using}
+Description: state machine library
+ fsm.el is an exercise in metaprogramming inspired by gen_fsm of
+ Erlang/OTP. It aims to make asynchronous programming in Emacs Lisp
+ easy and fun. By "asynchronous" I mean that long-lasting tasks
+ don't interfer with normal editing.
+ .
+ Some people say that it would be nice if Emacs Lisp had threads
+ and/or continuations. They are probably right, but there are few
+ things that can't be made to run in the background using facilities
+ already available: timers, filters and sentinels. As the code can
+ become a bit messy when using such means, with callbacks everywhere
+ and such things, it can be useful to structure the program as a
+ state machine.
+ .
+ In this model, a state machine passes between different "states",
+ which are actually only different event handler functions. The
+ state machine receives "events" (from timers, filters, user
+ requests, etc) and reacts to them, possibly entering another state,
+ possibly returning a value.
+ .
+ The essential macros/functions are:
+ ;;
+ define-state-machine - create start-FOO function
+ define-state - event handler for each state (required)
+ define-enter-state - called when entering a state (optional)
+ define-fsm - encapsulates the above three (more sugar!)
+ fsm-send - send an event to a state machine
+ fsm-call - send an event and wait for reply
+ .
+ fsm.el is similar to but different from Distel:
+ <URL:http://fresh.homeunix.net/~luke/distel/>
+ Emacs' tq library is a similar idea.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..b958f0d
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,28 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: fsm
+Upstream-Author: Thomas Fitzsimmons <fitzsim@fitzsim.org>
+
+Files: *
+Copyright: (C) 2006, 2007, 2008, 2015 Free Software Foundation, Inc.
+License: GPL-2+
+
+Files: debian/*
+Copyright: (C) 2016 Matteo F. Vescovi <mfv@debian.org>
+License: GPL-2+
+
+License: GPL-2+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, either version 2 of the License, or
+ (at your option) any later version.
+ .
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ .
+ On Debian systems, the complete text of the GNU General
+ Public License version 3 can be found in `/usr/share/common-licenses/GPL-2'
diff --git a/debian/elpa b/debian/elpa
new file mode 100644
index 0000000..abf136d
--- /dev/null
+++ b/debian/elpa
@@ -0,0 +1 @@
+*.el
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..5cc34d4
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,12 @@
+[DEFAULT]
+# upstream-branch = upstream
+debian-branch = master
+upstream-tag = %(version)s
+debian-tag = debian/%(version)s
+
+sign-tags = True
+pristine-tar = True
+pristine-tar-commit = True
+
+compression = xz
+compression-level = 9
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e8e22ba
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,4 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --with elpa
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)