summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerdinand Thiessen <f.thiessen@gmx.de>2022-01-31 16:06:19 +0000
committerJohannes Schauer Marin Rodrigues <josch@debian.org>2022-09-12 10:23:13 +0200
commit3d89c86891bd8986b09bdc4d2ad8def9bd9801bf (patch)
tree7c85bb4e0aa71d47ca688c04836b1fb63553c506
parentfc441e2920739ba95a236ce750e725638a7cbd85 (diff)
Replace Catch with Catch2 and require C++11 for tests
Origin: vendor, https://github.com/fuzzylite/fuzzylite/issues/94 Bug-Debian: http://bugs.debian.org/1017155 Gbp-Pq: Name fix-tests2.patch
-rw-r--r--fuzzylite/CMakeLists.txt2
-rw-r--r--fuzzylite/test/BenchmarkTest.cpp2
-rw-r--r--fuzzylite/test/MainTest.cpp2
-rw-r--r--fuzzylite/test/QuickTest.cpp2
-rw-r--r--fuzzylite/test/activation/ThresholdTest.cpp2
-rw-r--r--fuzzylite/test/hedge/HedgeFunctionTest.cpp2
-rw-r--r--fuzzylite/test/imex/FldExporterTest.cpp2
-rw-r--r--fuzzylite/test/imex/FllImporterTest.cpp2
-rw-r--r--fuzzylite/test/imex/RScriptExporterTest.cpp2
-rw-r--r--fuzzylite/test/norm/NormFunctionTest.cpp2
-rw-r--r--fuzzylite/test/term/AggregatedTest.cpp2
-rw-r--r--fuzzylite/test/term/DiscreteTest.cpp2
-rw-r--r--fuzzylite/test/term/FunctionTest.cpp2
-rw-r--r--fuzzylite/test/term/TrapezoidTest.cpp2
-rw-r--r--fuzzylite/test/term/TriangleTest.cpp2
-rw-r--r--fuzzylite/test/variable/VariableTest.cpp2
16 files changed, 17 insertions, 15 deletions
diff --git a/fuzzylite/CMakeLists.txt b/fuzzylite/CMakeLists.txt
index 28435e2..b6ca540 100644
--- a/fuzzylite/CMakeLists.txt
+++ b/fuzzylite/CMakeLists.txt
@@ -194,7 +194,9 @@ if(FL_BUILD_BINARY)
endif(FL_BUILD_BINARY)
if(FL_BUILD_TESTS)
+ find_package(Catch2)
add_executable(fl-test ${fl-headers} ${fl-tests})
+ target_link_libraries(fl-test Catch2::Catch2)
set_target_properties(fl-test PROPERTIES OUTPUT_NAME fuzzylite-tests)
set_target_properties(fl-test PROPERTIES OUTPUT_NAME fuzzylite-tests IMPORT_PREFIX tmp-) #To prevent LNK1149 in Windows
set_target_properties(fl-test PROPERTIES DEBUG_POSTFIX -debug)
diff --git a/fuzzylite/test/BenchmarkTest.cpp b/fuzzylite/test/BenchmarkTest.cpp
index 3fb270a..5514398 100644
--- a/fuzzylite/test/BenchmarkTest.cpp
+++ b/fuzzylite/test/BenchmarkTest.cpp
@@ -16,7 +16,7 @@
#include "fl/Benchmark.h"
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
#include <vector>
diff --git a/fuzzylite/test/MainTest.cpp b/fuzzylite/test/MainTest.cpp
index c18740a..18d29e9 100644
--- a/fuzzylite/test/MainTest.cpp
+++ b/fuzzylite/test/MainTest.cpp
@@ -16,7 +16,7 @@
#define CATCH_CONFIG_RUNNER
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
diff --git a/fuzzylite/test/QuickTest.cpp b/fuzzylite/test/QuickTest.cpp
index 9108fde..902d074 100644
--- a/fuzzylite/test/QuickTest.cpp
+++ b/fuzzylite/test/QuickTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
diff --git a/fuzzylite/test/activation/ThresholdTest.cpp b/fuzzylite/test/activation/ThresholdTest.cpp
index 9f6a9e6..c2163c8 100644
--- a/fuzzylite/test/activation/ThresholdTest.cpp
+++ b/fuzzylite/test/activation/ThresholdTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
diff --git a/fuzzylite/test/hedge/HedgeFunctionTest.cpp b/fuzzylite/test/hedge/HedgeFunctionTest.cpp
index dab70f5..606792d 100644
--- a/fuzzylite/test/hedge/HedgeFunctionTest.cpp
+++ b/fuzzylite/test/hedge/HedgeFunctionTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
diff --git a/fuzzylite/test/imex/FldExporterTest.cpp b/fuzzylite/test/imex/FldExporterTest.cpp
index e312f1d..8cf99a4 100644
--- a/fuzzylite/test/imex/FldExporterTest.cpp
+++ b/fuzzylite/test/imex/FldExporterTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
diff --git a/fuzzylite/test/imex/FllImporterTest.cpp b/fuzzylite/test/imex/FllImporterTest.cpp
index d31701a..f133d4b 100644
--- a/fuzzylite/test/imex/FllImporterTest.cpp
+++ b/fuzzylite/test/imex/FllImporterTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
diff --git a/fuzzylite/test/imex/RScriptExporterTest.cpp b/fuzzylite/test/imex/RScriptExporterTest.cpp
index b6d87d8..d1f409d 100644
--- a/fuzzylite/test/imex/RScriptExporterTest.cpp
+++ b/fuzzylite/test/imex/RScriptExporterTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
#include <fstream>
diff --git a/fuzzylite/test/norm/NormFunctionTest.cpp b/fuzzylite/test/norm/NormFunctionTest.cpp
index afce4c8..496d080 100644
--- a/fuzzylite/test/norm/NormFunctionTest.cpp
+++ b/fuzzylite/test/norm/NormFunctionTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
diff --git a/fuzzylite/test/term/AggregatedTest.cpp b/fuzzylite/test/term/AggregatedTest.cpp
index bb3f0e4..88978d3 100644
--- a/fuzzylite/test/term/AggregatedTest.cpp
+++ b/fuzzylite/test/term/AggregatedTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
diff --git a/fuzzylite/test/term/DiscreteTest.cpp b/fuzzylite/test/term/DiscreteTest.cpp
index 2fb32aa..f4856b6 100644
--- a/fuzzylite/test/term/DiscreteTest.cpp
+++ b/fuzzylite/test/term/DiscreteTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
diff --git a/fuzzylite/test/term/FunctionTest.cpp b/fuzzylite/test/term/FunctionTest.cpp
index a42e37b..c8425dd 100644
--- a/fuzzylite/test/term/FunctionTest.cpp
+++ b/fuzzylite/test/term/FunctionTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
diff --git a/fuzzylite/test/term/TrapezoidTest.cpp b/fuzzylite/test/term/TrapezoidTest.cpp
index 8581ac1..94ebadc 100644
--- a/fuzzylite/test/term/TrapezoidTest.cpp
+++ b/fuzzylite/test/term/TrapezoidTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
diff --git a/fuzzylite/test/term/TriangleTest.cpp b/fuzzylite/test/term/TriangleTest.cpp
index bd1459d..865c06f 100644
--- a/fuzzylite/test/term/TriangleTest.cpp
+++ b/fuzzylite/test/term/TriangleTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
namespace fl {
diff --git a/fuzzylite/test/variable/VariableTest.cpp b/fuzzylite/test/variable/VariableTest.cpp
index 6f77e94..11f3794 100644
--- a/fuzzylite/test/variable/VariableTest.cpp
+++ b/fuzzylite/test/variable/VariableTest.cpp
@@ -14,7 +14,7 @@
fuzzylite is a registered trademark of FuzzyLite Limited.
*/
-#include "test/catch.hpp"
+#include "catch2/catch.hpp"
#include "fl/Headers.h"
#include <algorithm> // std::random_shuffle