summaryrefslogtreecommitdiff
path: root/rules
diff options
context:
space:
mode:
authorMichal Čihař <nijel@debian.org>2017-10-18 10:36:37 +0200
committerMichal Čihař <nijel@debian.org>2017-10-18 10:36:37 +0200
commit8f48370bf63c73aa92e5fcefc70b84f7adad65f4 (patch)
tree9dbe2a446560de36e36003fc5a0c19098163d7c4 /rules
Import gammu_1.38.5-1.debian.tar.xz
[dgit import tarball gammu 1.38.5-1 gammu_1.38.5-1.debian.tar.xz]
Diffstat (limited to 'rules')
-rwxr-xr-xrules23
1 files changed, 23 insertions, 0 deletions
diff --git a/rules b/rules
new file mode 100755
index 0000000..3fb0b0b
--- /dev/null
+++ b/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
+%:
+ dh $@ --with systemd,sphinxdoc --buildsystem=cmake
+
+override_dh_auto_build:
+ dh_auto_build --parallel
+ dh_auto_build -- manual-html
+
+override_dh_strip:
+ dh_strip --ddeb-migration='libgammu-dbg (<< 1.37.0-1~)'
+
+override_dh_compress:
+ dh_compress -X.js -Xobjects.inv -X.txt -X.py
+
+override_dh_makeshlibs:
+ dh_makeshlibs -V