summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt4
-rw-r--r--ChangeLog6
-rw-r--r--cmake/FindGlib.cmake2
-rw-r--r--contrib/CMakeLists.txt2
-rw-r--r--description-pak2
-rw-r--r--docs/config/CMakeLists.txt2
-rw-r--r--docs/config/gammurc2
-rw-r--r--docs/man/gammu-backup.52
-rw-r--r--docs/man/gammu-config.12
-rw-r--r--docs/man/gammu-detect.12
-rw-r--r--docs/man/gammu-smsbackup.52
-rw-r--r--docs/man/gammu-smsd-dbi.72
-rw-r--r--docs/man/gammu-smsd-files.72
-rw-r--r--docs/man/gammu-smsd-inject.12
-rw-r--r--docs/man/gammu-smsd-monitor.12
-rw-r--r--docs/man/gammu-smsd-mysql.72
-rw-r--r--docs/man/gammu-smsd-null.72
-rw-r--r--docs/man/gammu-smsd-odbc.72
-rw-r--r--docs/man/gammu-smsd-pgsql.72
-rw-r--r--docs/man/gammu-smsd-run.72
-rw-r--r--docs/man/gammu-smsd-sql.72
-rw-r--r--docs/man/gammu-smsd-tables.72
-rw-r--r--docs/man/gammu-smsd.12
-rw-r--r--docs/man/gammu-smsdrc.55
-rw-r--r--docs/man/gammu.12
-rw-r--r--docs/man/gammurc.512
-rw-r--r--docs/man/jadmaker.12
-rw-r--r--docs/manual/CMakeLists.txt2
-rw-r--r--docs/manual/config/index.rst8
-rw-r--r--docs/manual/smsd/config.rst2
-rw-r--r--docs/sql/CMakeLists.txt2
-rw-r--r--gammu.spec2
-rw-r--r--gammu/CMakeLists.txt2
-rw-r--r--gammu/CMakeTests.txt2
-rw-r--r--gammu/gammu.c2
-rw-r--r--include/CMakeLists.txt2
-rw-r--r--libgammu/device/usb/usb.c6
-rw-r--r--libgammu/gsmphones.c1
-rw-r--r--libgammu/protocol/at/at.c2
-rw-r--r--libgammu/service/sms/gsmmulti.c6
-rw-r--r--locale/CMakeLists.txt2
-rw-r--r--smsd/CMakeTests.txt2
-rw-r--r--smsd/core.c2
-rw-r--r--smsd/core.h2
-rw-r--r--smsd/inject.c2
-rw-r--r--smsd/main.c4
-rw-r--r--smsd/monitor.c4
-rw-r--r--smsd/services/dbi.c2
-rw-r--r--smsd/services/files.c4
-rw-r--r--smsd/services/mysql.c2
-rw-r--r--smsd/services/null.c2
-rw-r--r--smsd/services/null.h2
-rw-r--r--smsd/services/odbc.c2
-rw-r--r--smsd/services/pgsql.c2
-rw-r--r--smsd/services/sql.c8
-rwxr-xr-xtests/gen_sms_tests.py2
-rw-r--r--utils/CMakeLists.txt2
57 files changed, 90 insertions, 68 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5194825..3bac08a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
# cmake <http://www.cmake.org> build file for Gammu
-# Copyright (c) 2007 - 2010 Michal Cihar
+# Copyright (c) 2007 - 2015 Michal Cihar
# vim: expandtab sw=4 ts=4 sts=4:
cmake_minimum_required (VERSION 2.8)
@@ -28,7 +28,7 @@ if (LARGE_FILES)
endif (LARGE_FILES)
# Set version
-set (GAMMU_VERSION "1.36.4" CACHE INTERNAL "")
+set (GAMMU_VERSION "1.36.5" CACHE INTERNAL "")
string (REGEX REPLACE "^([0-9]*)\\.([0-9]*)\\.([0-9]*)$" "\\1" "GAMMU_VERSION_MAJOR" "${GAMMU_VERSION}")
string (REGEX REPLACE "^([0-9]*)\\.([0-9]*)\\.([0-9]*)$" "\\2" "GAMMU_VERSION_MINOR" "${GAMMU_VERSION}")
string (REGEX REPLACE "^([0-9]*)\\.([0-9]*)\\.([0-9]*)$" "\\3" "GAMMU_VERSION_PATCH" "${GAMMU_VERSION}")
diff --git a/ChangeLog b/ChangeLog
index 0f25073..5fd463e 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -19,6 +19,12 @@ the issue.
ChangeLog
=========
+20150826 - 1.36.5
+
+[-] * Properly use timezones with SQLite in SMSD.
+[-] * Improve support for Huawei E1752.
+[-] * Fixed compilation on distros with old Glib.
+
20150814 - 1.36.4
[-] * Use advisory locking to prevent two Gammu instances share one device.
diff --git a/cmake/FindGlib.cmake b/cmake/FindGlib.cmake
index d3547d5..8b7be89 100644
--- a/cmake/FindGlib.cmake
+++ b/cmake/FindGlib.cmake
@@ -8,7 +8,7 @@
include(LibFindMacros)
# Use pkg-config to get hints about paths
-libfind_pkg_check_modules(Glib_PKGCONF glib-2.0)
+libfind_pkg_check_modules(Glib_PKGCONF glib-2.0>=2.16)
# Main include dir
find_path(Glib_INCLUDE_DIR
diff --git a/contrib/CMakeLists.txt b/contrib/CMakeLists.txt
index b87ab7d..39911dd 100644
--- a/contrib/CMakeLists.txt
+++ b/contrib/CMakeLists.txt
@@ -1,5 +1,5 @@
# cmake <http://www.cmake.org> build file for Gammu contrib files
-# Copyright (c) 2007 - 2010 Michal Cihar
+# Copyright (c) 2007 - 2015 Michal Cihar
# vim: expandtab sw=4 ts=4 sts=4:
project (Gammu-contrib C)
diff --git a/description-pak b/description-pak
index 89f4218..21c139d 100644
--- a/description-pak
+++ b/description-pak
@@ -1,4 +1,4 @@
-Gammu (Gammu All Mobile Management Utilities) 1.36.4
+Gammu (Gammu All Mobile Management Utilities) 1.36.5
Gammu is a command line utility and library to work with mobile phones
from many vendors. Support for different models differs, but basic
diff --git a/docs/config/CMakeLists.txt b/docs/config/CMakeLists.txt
index 4c90144..c384c34 100644
--- a/docs/config/CMakeLists.txt
+++ b/docs/config/CMakeLists.txt
@@ -1,5 +1,5 @@
# cmake <http://www.cmake.org> build file for Gammu docs
-# Copyright (c) 2007 - 2010 Michal Cihar
+# Copyright (c) 2007 - 2015 Michal Cihar
# vim: expandtab sw=4 ts=4 sts=4:
project (Gammu-doc-config C)
diff --git a/docs/config/gammurc b/docs/config/gammurc
index f2b9cb1..71e50d6 100644
--- a/docs/config/gammurc
+++ b/docs/config/gammurc
@@ -146,7 +146,7 @@ connection = fbusblue
; | when to reset phone during connection (in some phones need
; | to set time again after restart)
; GammuLoc | name of localisation file
-; StartInfo | this option allow to set, that you want (setting "yes")
+; StartInfo | this option allows one to set, that you want (setting "yes")
; | to see message on the phone screen or phone should enable
; | light for a moment during starting connection. Phone
; | WON'T beep during starting connection with this option.
diff --git a/docs/man/gammu-backup.5 b/docs/man/gammu-backup.5
index 91c9750..14ccd57 100644
--- a/docs/man/gammu-backup.5
+++ b/docs/man/gammu-backup.5
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-BACKUP" "5" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-BACKUP" "5" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-backup \- gammu(1) backup file format.
.
diff --git a/docs/man/gammu-config.1 b/docs/man/gammu-config.1
index 3041055..8a53837 100644
--- a/docs/man/gammu-config.1
+++ b/docs/man/gammu-config.1
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-CONFIG" "1" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-CONFIG" "1" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-config \- Gammu configurator
.
diff --git a/docs/man/gammu-detect.1 b/docs/man/gammu-detect.1
index 4def5e2..c2f71fb 100644
--- a/docs/man/gammu-detect.1
+++ b/docs/man/gammu-detect.1
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-DETECT" "1" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-DETECT" "1" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-detect \- Gammu device detection
.
diff --git a/docs/man/gammu-smsbackup.5 b/docs/man/gammu-smsbackup.5
index 3ef8084..02d731c 100644
--- a/docs/man/gammu-smsbackup.5
+++ b/docs/man/gammu-smsbackup.5
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSBACKUP" "5" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSBACKUP" "5" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsbackup \- gammu(1) SMS backup file format.
.
diff --git a/docs/man/gammu-smsd-dbi.7 b/docs/man/gammu-smsd-dbi.7
index 003088a..e8b094e 100644
--- a/docs/man/gammu-smsd-dbi.7
+++ b/docs/man/gammu-smsd-dbi.7
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD-DBI" "7" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD-DBI" "7" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd-dbi \- gammu-smsd(1) backend using DBI abstraction layer to use any supported database as a message storage
.
diff --git a/docs/man/gammu-smsd-files.7 b/docs/man/gammu-smsd-files.7
index d83f257..dab959b 100644
--- a/docs/man/gammu-smsd-files.7
+++ b/docs/man/gammu-smsd-files.7
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD-FILES" "7" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD-FILES" "7" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd-files \- gammu-smsd(1) backend using filesystem as a message storage
.
diff --git a/docs/man/gammu-smsd-inject.1 b/docs/man/gammu-smsd-inject.1
index 7cf755c..17b1d4c 100644
--- a/docs/man/gammu-smsd-inject.1
+++ b/docs/man/gammu-smsd-inject.1
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD-INJECT" "1" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD-INJECT" "1" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd-inject \- Inject messages into queue of SMS daemon for Gammu
.
diff --git a/docs/man/gammu-smsd-monitor.1 b/docs/man/gammu-smsd-monitor.1
index 78f10e0..4c23a94 100644
--- a/docs/man/gammu-smsd-monitor.1
+++ b/docs/man/gammu-smsd-monitor.1
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD-MONITOR" "1" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD-MONITOR" "1" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd-monitor \- Monitor state of SMS daemon for Gammu
.
diff --git a/docs/man/gammu-smsd-mysql.7 b/docs/man/gammu-smsd-mysql.7
index b4166a8..1ce2b43 100644
--- a/docs/man/gammu-smsd-mysql.7
+++ b/docs/man/gammu-smsd-mysql.7
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD-MYSQL" "7" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD-MYSQL" "7" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd-mysql \- gammu-smsd(1) backend using MySQL database server as a message storage
.
diff --git a/docs/man/gammu-smsd-null.7 b/docs/man/gammu-smsd-null.7
index 1e605a4..dc1dae8 100644
--- a/docs/man/gammu-smsd-null.7
+++ b/docs/man/gammu-smsd-null.7
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD-NULL" "7" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD-NULL" "7" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd-null \- gammu-smsd(1) backend not storing messages
.
diff --git a/docs/man/gammu-smsd-odbc.7 b/docs/man/gammu-smsd-odbc.7
index 6529338..da0a35a 100644
--- a/docs/man/gammu-smsd-odbc.7
+++ b/docs/man/gammu-smsd-odbc.7
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD-ODBC" "7" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD-ODBC" "7" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd-odbc \- gammu-smsd(1) backend using ODBC abstraction layer to use any supported database as a message storage
.
diff --git a/docs/man/gammu-smsd-pgsql.7 b/docs/man/gammu-smsd-pgsql.7
index 01137c5..0342791 100644
--- a/docs/man/gammu-smsd-pgsql.7
+++ b/docs/man/gammu-smsd-pgsql.7
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD-PGSQL" "7" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD-PGSQL" "7" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd-pgsql \- gammu-smsd(1) backend using PostgreSQL database server as a message storage
.
diff --git a/docs/man/gammu-smsd-run.7 b/docs/man/gammu-smsd-run.7
index 2a34283..1738f78 100644
--- a/docs/man/gammu-smsd-run.7
+++ b/docs/man/gammu-smsd-run.7
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD-RUN" "7" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD-RUN" "7" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd-run \- documentation for RunOnReceive directive
.
diff --git a/docs/man/gammu-smsd-sql.7 b/docs/man/gammu-smsd-sql.7
index ac96434..2e62e3b 100644
--- a/docs/man/gammu-smsd-sql.7
+++ b/docs/man/gammu-smsd-sql.7
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD-SQL" "7" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD-SQL" "7" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd-sql \- gammu-smsd(1) backend using SQL abstraction layer to use any supported database as a message storage
.
diff --git a/docs/man/gammu-smsd-tables.7 b/docs/man/gammu-smsd-tables.7
index 1128654..8fa77f3 100644
--- a/docs/man/gammu-smsd-tables.7
+++ b/docs/man/gammu-smsd-tables.7
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD-TABLES" "7" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD-TABLES" "7" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd-tables \- description of tables for database backends of gammu-smsd(1)
.
diff --git a/docs/man/gammu-smsd.1 b/docs/man/gammu-smsd.1
index 090a2a6..f76b2f3 100644
--- a/docs/man/gammu-smsd.1
+++ b/docs/man/gammu-smsd.1
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSD" "1" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSD" "1" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsd \- SMS daemon for Gammu
.
diff --git a/docs/man/gammu-smsdrc.5 b/docs/man/gammu-smsdrc.5
index 8f48e40..c3f013c 100644
--- a/docs/man/gammu-smsdrc.5
+++ b/docs/man/gammu-smsdrc.5
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU-SMSDRC" "5" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU-SMSDRC" "5" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu-smsdrc \- gammu-smsd(1) configuration file
.
@@ -302,6 +302,9 @@ Default is 1 (enabled).
.INDENT 0.0
.TP
.B HangupCalls
+New in version 1.34.0.
+
+.sp
Whether to automatically hangup any incoming calls.
.sp
Default is 0 (disabled).
diff --git a/docs/man/gammu.1 b/docs/man/gammu.1
index 3b479c0..56fd3ba 100644
--- a/docs/man/gammu.1
+++ b/docs/man/gammu.1
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMU" "1" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMU" "1" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammu \- Does some neat things with your cellular phone or modem.
.
diff --git a/docs/man/gammurc.5 b/docs/man/gammurc.5
index c588165..e74bf3c 100644
--- a/docs/man/gammurc.5
+++ b/docs/man/gammurc.5
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "GAMMURC" "5" "August 14, 2015" "1.36.4" "Gammu"
+.TH "GAMMURC" "5" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
gammurc \- gammu(1) configuration file
.
@@ -350,10 +350,10 @@ If you want to set time from computer to phone during starting connection.
.INDENT 0.0
.TP
.B StartInfo
-This option allow to set, that you want (setting \fByes\fP) to see message on the
-phone screen or phone should enable light for a moment during starting
-connection. Phone will not beep during starting connection with this
-option. This works only with some Nokia phones.
+This option allows one to set, that you want (setting \fByes\fP) to see
+message on the phone screen or phone should enable light for a moment
+during starting connection. Phone will not beep during starting connection
+with this option. This works only with some Nokia phones.
.UNINDENT
.SS Debugging options
.INDENT 0.0
@@ -677,7 +677,7 @@ connection = fbusblue
; | when to reset phone during connection (in some phones need
; | to set time again after restart)
; GammuLoc | name of localisation file
-; StartInfo | this option allow to set, that you want (setting "yes")
+; StartInfo | this option allows one to set, that you want (setting "yes")
; | to see message on the phone screen or phone should enable
; | light for a moment during starting connection. Phone
; | WON\(aqT beep during starting connection with this option.
diff --git a/docs/man/jadmaker.1 b/docs/man/jadmaker.1
index 124b2a3..55d23ba 100644
--- a/docs/man/jadmaker.1
+++ b/docs/man/jadmaker.1
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "JADMAKER" "1" "August 14, 2015" "1.36.4" "Gammu"
+.TH "JADMAKER" "1" "August 26, 2015" "1.36.5" "Gammu"
.SH NAME
jadmaker \- JAD File Generator
.
diff --git a/docs/manual/CMakeLists.txt b/docs/manual/CMakeLists.txt
index f8662d1..450bef7 100644
--- a/docs/manual/CMakeLists.txt
+++ b/docs/manual/CMakeLists.txt
@@ -1,5 +1,5 @@
# cmake <http://www.cmake.org> build file for Gammu docs
-# Copyright (c) 2007 - 2010 Michal Cihar
+# Copyright (c) 2007 - 2015 Michal Cihar
# vim: expandtab sw=4 ts=4 sts=4:
project (Gammu-doc-devel C)
diff --git a/docs/manual/config/index.rst b/docs/manual/config/index.rst
index e0a6666..74dd998 100644
--- a/docs/manual/config/index.rst
+++ b/docs/manual/config/index.rst
@@ -225,10 +225,10 @@ Connection options
.. config:option:: StartInfo
- This option allow to set, that you want (setting ``yes``) to see message on the
- phone screen or phone should enable light for a moment during starting
- connection. Phone will not beep during starting connection with this
- option. This works only with some Nokia phones.
+ This option allows one to set, that you want (setting ``yes``) to see
+ message on the phone screen or phone should enable light for a moment
+ during starting connection. Phone will not beep during starting connection
+ with this option. This works only with some Nokia phones.
Debugging options
diff --git a/docs/manual/smsd/config.rst b/docs/manual/smsd/config.rst
index b31c21b..b3055d3 100644
--- a/docs/manual/smsd/config.rst
+++ b/docs/manual/smsd/config.rst
@@ -219,6 +219,8 @@ General parameters of SMS daemon
.. config:option:: HangupCalls
+ .. versionadded:: 1.34.0
+
Whether to automatically hangup any incoming calls.
Default is 0 (disabled).
diff --git a/docs/sql/CMakeLists.txt b/docs/sql/CMakeLists.txt
index 5f87d7a..0518f11 100644
--- a/docs/sql/CMakeLists.txt
+++ b/docs/sql/CMakeLists.txt
@@ -1,5 +1,5 @@
# cmake <http://www.cmake.org> build file for Gammu docs
-# Copyright (c) 2007 - 2010 Michal Cihar
+# Copyright (c) 2007 - 2015 Michal Cihar
# vim: expandtab sw=4 ts=4 sts=4:
project (Gammu-doc-sql C)
diff --git a/gammu.spec b/gammu.spec
index 79d462f..7bf87d4 100644
--- a/gammu.spec
+++ b/gammu.spec
@@ -1,5 +1,5 @@
Name: gammu
-Version: 1.36.4
+Version: 1.36.5
Release: 1
# Set to 0 to disable bluetooth support
%if 0%{?opensuse_bs} && 0%{?sles_version} == 9
diff --git a/gammu/CMakeLists.txt b/gammu/CMakeLists.txt
index a02758c..adbe5f0 100644
--- a/gammu/CMakeLists.txt
+++ b/gammu/CMakeLists.txt
@@ -1,5 +1,5 @@
# cmake <http://www.cmake.org> build file for Gammu
-# Copyright (c) 2007 - 2010 Michal Cihar
+# Copyright (c) 2007 - 2015 Michal Cihar
# vim: expandtab sw=4 ts=4 sts=4:
project (gammu-binary C)
diff --git a/gammu/CMakeTests.txt b/gammu/CMakeTests.txt
index e7c2ce8..ae6ba23 100644
--- a/gammu/CMakeTests.txt
+++ b/gammu/CMakeTests.txt
@@ -1,5 +1,5 @@
# cmake <http://www.cmake.org> test file for Gammu
-# Copyright (c) 2007 - 2010 Michal Cihar
+# Copyright (c) 2007 - 2015 Michal Cihar
# vim: expandtab sw=4 ts=4 sts=4 ft=cmake:
include(SetupDummyPhone)
diff --git a/gammu/gammu.c b/gammu/gammu.c
index 2959a7f..d4f871b 100644
--- a/gammu/gammu.c
+++ b/gammu/gammu.c
@@ -326,7 +326,7 @@ static void Version(int argc UNUSED, char *argv[]UNUSED)
{
PrintVersion();
- printf("%s\n", _("Copyright (C) 2003 - 2012 Michal Cihar <michal@cihar.com> and other authors."));
+ printf("%s\n", _("Copyright (C) 2003 - 2015 Michal Cihar <michal@cihar.com> and other authors."));
printf("\n");
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
index 709ad0e..35e0db5 100644
--- a/include/CMakeLists.txt
+++ b/include/CMakeLists.txt
@@ -1,5 +1,5 @@
# cmake <http://www.cmake.org> build file for Gammu headers
-# Copyright (c) 2007 - 2010 Michal Cihar
+# Copyright (c) 2007 - 2015 Michal Cihar
# vim: expandtab sw=4 ts=4 sts=4:
project (Gammu-headers C)
diff --git a/libgammu/device/usb/usb.c b/libgammu/device/usb/usb.c
index 244677c..c58d3c9 100644
--- a/libgammu/device/usb/usb.c
+++ b/libgammu/device/usb/usb.c
@@ -313,7 +313,7 @@ GSM_Error GSM_USB_Probe(GSM_StateMachine *s, GSM_USB_Match_Function matcher)
smprintf(s, "Will change configuration, unhooking all interfaces!\n");
for (i = 0; i < config->bNumInterfaces; i++) {
if (libusb_kernel_driver_active(d->handle, i) == 1) {
- smprintf(s, "Detaching kernel driver from inteface %d\n", i);
+ smprintf(s, "Detaching kernel driver from interface %d\n", i);
rc = libusb_detach_kernel_driver(d->handle, i);
if (rc != 0) {
smprintf(s, "Failed to detach kernel driver!\n");
@@ -341,7 +341,7 @@ GSM_Error GSM_USB_Probe(GSM_StateMachine *s, GSM_USB_Match_Function matcher)
smprintf(s, "Configuration change not required, unhooking only required interfaces!\n");
if (libusb_kernel_driver_active(d->handle, d->control_iface) == 1) {
- smprintf(s, "Detaching kernel driver from inteface %d\n", d->control_iface);
+ smprintf(s, "Detaching kernel driver from interface %d\n", d->control_iface);
rc = libusb_detach_kernel_driver(d->handle, d->control_iface);
if (rc != 0) {
smprintf(s, "Failed to detach kernel driver!\n");
@@ -354,7 +354,7 @@ GSM_Error GSM_USB_Probe(GSM_StateMachine *s, GSM_USB_Match_Function matcher)
}
if (libusb_kernel_driver_active(d->handle, d->data_iface) == 1) {
- smprintf(s, "Detaching kernel driver from inteface %d\n", d->data_iface);
+ smprintf(s, "Detaching kernel driver from interface %d\n", d->data_iface);
rc = libusb_detach_kernel_driver(d->handle, d->data_iface);
if (rc != 0) {
smprintf(s, "Failed to detach kernel driver!\n");
diff --git a/libgammu/gsmphones.c b/libgammu/gsmphones.c
index ce781d6..108c1c8 100644
--- a/libgammu/gsmphones.c
+++ b/libgammu/gsmphones.c
@@ -955,6 +955,7 @@ GSM_PhoneModel allmodels[] = {
{"E1556", "E1556", "", {F_SMS_LOCATION_0, F_ENCODED_USSD, F_FOUR_DIGIT_YEAR, F_RESET_AFTER_TIMEOUT, 0}},
{"E1550", "E1550", "", {F_SMS_LOCATION_0, F_ENCODED_USSD, F_FOUR_DIGIT_YEAR, F_RESET_AFTER_TIMEOUT, 0}},
{"E1750", "E1750", "", {F_SMS_LOCATION_0, F_ENCODED_USSD, F_FOUR_DIGIT_YEAR, F_RESET_AFTER_TIMEOUT, 0}},
+ {"E1752", "E1752", "", {F_SMS_LOCATION_0, F_ENCODED_USSD, F_FOUR_DIGIT_YEAR, F_RESET_AFTER_TIMEOUT, 0}},
{"EM770W", "EM770W", "", {F_SMS_LOCATION_0, F_ENCODED_USSD, F_FOUR_DIGIT_YEAR, F_RESET_AFTER_TIMEOUT, 0}},
{"E3372", "E3372", "", {F_SMS_LOCATION_0, F_ENCODED_USSD, F_FOUR_DIGIT_YEAR, F_RESET_AFTER_TIMEOUT, 0}},
{"K3765", "K3765", "", {F_SMS_LOCATION_0, F_ENCODED_USSD, F_FOUR_DIGIT_YEAR, F_RESET_AFTER_TIMEOUT, 0}},
diff --git a/libgammu/protocol/at/at.c b/libgammu/protocol/at/at.c
index 3ec5187..3eb0e18 100644
--- a/libgammu/protocol/at/at.c
+++ b/libgammu/protocol/at/at.c
@@ -89,6 +89,7 @@ static GSM_Error AT_StateMachine(GSM_StateMachine *s, unsigned char rx_char)
{"+CMT:" ,2, ID_None},
{"+CMTI:" ,1, ID_None},
{"+CDS:" ,2, ID_None},
+ {"+CDSI:" ,1, ID_None},
{"+CREG:" ,1, ID_GetNetworkInfo},
{"+CUSD" ,1, ID_None},
{"+COLP" ,1, ID_None},
@@ -131,6 +132,7 @@ static GSM_Error AT_StateMachine(GSM_StateMachine *s, unsigned char rx_char)
{"^MODE:" ,1, ID_None}, /* ^MODE:3,3 */
{"^CSNR:" ,1, ID_None}, /* ^CSNR:-93,-23 */
{"^HCSQ:" ,1, ID_None}, /* ^HCSQ:"LTE",59,50,161,24 */
+ {"^SRVST:" ,1, ID_None}, /* ^SRVST:0 */
/* ONDA */
{"+ZUSIMR:" ,1, ID_None}, /* +ZUSIMR:2 */
diff --git a/libgammu/service/sms/gsmmulti.c b/libgammu/service/sms/gsmmulti.c
index 8c624c6..0ef1fbb 100644
--- a/libgammu/service/sms/gsmmulti.c
+++ b/libgammu/service/sms/gsmmulti.c
@@ -502,8 +502,12 @@ GSM_Error GSM_EncodeMultiPartSMS(GSM_Debug_Info *di,
if (Info->EntriesNum == 0) return ERR_EMPTY;
Buffer = malloc(buffer_size);
+ if (Buffer == NULL) {
+ return ERR_MOREMEMORY;
+ }
Buffer2 = malloc(buffer_size);
- if (Buffer == NULL || Buffer2 == NULL) {
+ if (Buffer2 == NULL) {
+ free(Buffer);
return ERR_MOREMEMORY;
}
diff --git a/locale/CMakeLists.txt b/locale/CMakeLists.txt
index 3c8144b..4e6ceef 100644
--- a/locale/CMakeLists.txt
+++ b/locale/CMakeLists.txt
@@ -1,5 +1,5 @@
# cmake <http://www.cmake.org> build file for Gammu
-# Copyright © 2007 - 2010 Michal Čihař
+# Copyright © 2007 - 2015 Michal Čihař
# vim: expandtab sw=4 ts=4 sts=4:
project(Gammu-Locales C)
diff --git a/smsd/CMakeTests.txt b/smsd/CMakeTests.txt
index 59e11ec..ccaac8f 100644
--- a/smsd/CMakeTests.txt
+++ b/smsd/CMakeTests.txt
@@ -1,5 +1,5 @@
# cmake <http://www.cmake.org> test file for SMSD
-# Copyright (c) 2007 - 2010 Michal Cihar
+# Copyright (c) 2007 - 2015 Michal Cihar
# vim: expandtab sw=4 ts=4 sts=4 ft=cmake:
if (WITH_BACKUP)
diff --git a/smsd/core.c b/smsd/core.c
index 6895503..cf3bc65 100644
--- a/smsd/core.c
+++ b/smsd/core.c
@@ -1,5 +1,5 @@
/* Copyright (c) 2002-2004 by Marcin Wiacek and Joergen Thomsen */
-/* Copyright (c) 2009 - 2012 Michal Cihar <michal@cihar.com> */
+/* Copyright (c) 2009 - 2015 Michal Cihar <michal@cihar.com> */
#include <string.h>
#include <signal.h>
diff --git a/smsd/core.h b/smsd/core.h
index 0ce499c..488dc80 100644
--- a/smsd/core.h
+++ b/smsd/core.h
@@ -1,5 +1,5 @@
/* (c) 2002-2004 by Marcin Wiacek and Joergen Thomsen */
-/* Copyright (c) 2009 - 2011 Michal Cihar <michal@cihar.com> */
+/* Copyright (c) 2009 - 2015 Michal Cihar <michal@cihar.com> */
#ifndef __core_h_
#define __core_h_
diff --git a/smsd/inject.c b/smsd/inject.c
index cf6cf65..5d99fd9 100644
--- a/smsd/inject.c
+++ b/smsd/inject.c
@@ -1,7 +1,7 @@
/**
* SMSD message inject program
*/
-/* Copyright (c) 2009 - 2011 Michal Cihar <michal@cihar.com> */
+/* Copyright (c) 2009 - 2015 Michal Cihar <michal@cihar.com> */
/* Licensend under GNU GPL 2 */
#include <gammu-smsd.h>
diff --git a/smsd/main.c b/smsd/main.c
index 0b51435..e5fe816 100644
--- a/smsd/main.c
+++ b/smsd/main.c
@@ -1,7 +1,7 @@
/**
* Main SMSD program
*/
-/* Copyright (c) 2009 - 2011 Michal Cihar <michal@cihar.com> */
+/* Copyright (c) 2009 - 2015 Michal Cihar <michal@cihar.com> */
/* Licensend under GNU GPL 2 */
#include <gammu-smsd.h>
@@ -115,7 +115,7 @@ NORETURN void version(void)
printf(" - %s\n", "ODBC");
#endif
printf("\n");
- printf("Copyright (C) 2003 - 2011 Michal Cihar <michal@cihar.com> and other authors.\n");
+ printf("Copyright (C) 2003 - 2015 Michal Cihar <michal@cihar.com> and other authors.\n");
printf("\n");
printf("License GPLv2: GNU GPL version 2 <https://spdx.org/licenses/GPL-2.0>.\n");
printf("This is free software: you are free to change and redistribute it.\n");
diff --git a/smsd/monitor.c b/smsd/monitor.c
index 14ef5ea..8854a13 100644
--- a/smsd/monitor.c
+++ b/smsd/monitor.c
@@ -1,7 +1,7 @@
/**
* SMSD message monitor program
*/
-/* Copyright (c) 2009 - 2011 Michal Cihar <michal@cihar.com> */
+/* Copyright (c) 2009 - 2015 Michal Cihar <michal@cihar.com> */
/* Licensend under GNU GPL 2 */
#include <gammu-smsd.h>
@@ -63,7 +63,7 @@ NORETURN void version(void)
printf(" - %s\n", "ODBC");
#endif
printf("\n");
- printf("Copyright (C) 2003 - 2011 Michal Cihar <michal@cihar.com> and other authors.\n");
+ printf("Copyright (C) 2003 - 2015 Michal Cihar <michal@cihar.com> and other authors.\n");
printf("\n");
printf("License GPLv2: GNU GPL version 2 <https://spdx.org/licenses/GPL-2.0>.\n");
printf("This is free software: you are free to change and redistribute it.\n");
diff --git a/smsd/services/dbi.c b/smsd/services/dbi.c
index 5c36a79..abd88eb 100644
--- a/smsd/services/dbi.c
+++ b/smsd/services/dbi.c
@@ -3,7 +3,7 @@
*
* Part of Gammu project
*
- * Copyright (c) 2009 - 2011 Michal Cihar <michal@cihar.com>
+ * Copyright (c) 2009 - 2015 Michal Cihar <michal@cihar.com>
*
* Licensed under GNU GPL version 2 or later
*/
diff --git a/smsd/services/files.c b/smsd/services/files.c
index e3f7d5e..380f835 100644
--- a/smsd/services/files.c
+++ b/smsd/services/files.c
@@ -614,6 +614,10 @@ static GSM_Error SMSDFiles_AddSentSMSInfo(GSM_MultiSMSMessage * sms UNUSED, GSM_
fseek(file, 0, SEEK_END);
filesize = ftell(file);
+ if (filesize < 0) {
+ fclose(file);
+ return ERR_CANTOPENFILE;
+ }
fseek(file, 0, SEEK_SET);
Buffer = malloc(filesize + 200);
diff --git a/smsd/services/mysql.c b/smsd/services/mysql.c
index 14e4f2e..99cd9d5 100644
--- a/smsd/services/mysql.c
+++ b/smsd/services/mysql.c
@@ -1,5 +1,5 @@
/* (c) 2004 by Marcin Wiacek */
-/* Copyright (c) 2009 - 2011 Michal Cihar <michal@cihar.com> */
+/* Copyright (c) 2009 - 2015 Michal Cihar <michal@cihar.com> */
#include <gammu.h>
diff --git a/smsd/services/null.c b/smsd/services/null.c
index 5e498f4..1955e88 100644
--- a/smsd/services/null.c
+++ b/smsd/services/null.c
@@ -3,7 +3,7 @@
*
* This service does not store anything anywhere.
*/
-/* Copyright (c) 2010 Michal Cihar <michal@cihar.com>. */
+/* Copyright (c) 2010 - 2015 Michal Cihar <michal@cihar.com>. */
#include "../core.h"
diff --git a/smsd/services/null.h b/smsd/services/null.h
index 817cf77..169a43c 100644
--- a/smsd/services/null.h
+++ b/smsd/services/null.h
@@ -3,7 +3,7 @@
*
* This service does not store anything anywhere.
*/
-/* Copyright (c) 2010 Michal Cihar <michal@cihar.com>. */
+/* Copyright (c) 2010 - 2015 Michal Cihar <michal@cihar.com>. */
extern GSM_SMSDService SMSDNull;
diff --git a/smsd/services/odbc.c b/smsd/services/odbc.c
index f3b7174..a6a79cc 100644
--- a/smsd/services/odbc.c
+++ b/smsd/services/odbc.c
@@ -3,7 +3,7 @@
*
* Part of Gammu project
*
- * Copyright (C) 2011 Michal Čihař
+ * Copyright (C) 2011 - 2015 Michal Čihař
*
* Licensed under GNU GPL version 2 or later
*/
diff --git a/smsd/services/pgsql.c b/smsd/services/pgsql.c
index 749a9dd..26f917b 100644
--- a/smsd/services/pgsql.c
+++ b/smsd/services/pgsql.c
@@ -1,5 +1,5 @@
/* (c) 2006 by Andrea Riciputi */
-/* Copyright (c) 2009 - 2011 Michal Cihar <michal@cihar.com> */
+/* Copyright (c) 2009 - 2015 Michal Cihar <michal@cihar.com> */
#define _XOPEN_SOURCE
#define _BSD_SOURCE
diff --git a/smsd/services/sql.c b/smsd/services/sql.c
index a111f47..826c92f 100644
--- a/smsd/services/sql.c
+++ b/smsd/services/sql.c
@@ -3,7 +3,7 @@
*
* Part of Gammu project
*
- * Copyright (C) 2009-2011 Michal Čihař
+ * Copyright (C) 2009 - 2015 Michal Čihař
* (c) 2010 Miloslav Semler
*
* Licensed under GNU GPL version 2 or later
@@ -46,7 +46,7 @@ const char *SMSDSQL_SQLName(GSM_SMSDConfig * Config)
const char now_plus_odbc[] = "{fn CURRENT_TIMESTAMP()} + INTERVAL %d SECOND";
const char now_plus_mysql[] = "(NOW() + INTERVAL %d SECOND) + 0";
const char now_plus_pgsql[] = "now() + interval '%d seconds'";
-const char now_plus_sqlite[] = "datetime('now', '+%d seconds')";
+const char now_plus_sqlite[] = "datetime('now', '+%d seconds', 'localtime')";
const char now_plus_freetds[] = "DATEADD('second', %d, CURRENT_TIMESTAMP)";
const char now_plus_access[] = "now()+#00:00:%d#";
const char now_plus_fallback[] = "NOW() + INTERVAL %d SECOND";
@@ -149,7 +149,7 @@ static const char *SMSDSQL_LimitClause(GSM_SMSDConfig * Config, const char *coun
const char now_odbc[] = "{fn CURRENT_TIMESTAMP()}";
const char now_mysql[] = "NOW()";
const char now_pgsql[] = "now()";
-const char now_sqlite[] = "datetime('now')";
+const char now_sqlite[] = "datetime('now', 'localtime')";
const char now_freetds[] = "CURRENT_TIMESTAMP";
const char now_access[] = "now()";
const char now_fallback[] = "NOW()";
@@ -157,7 +157,7 @@ const char now_fallback[] = "NOW()";
const char currtime_odbc[] = "{fn CURTIME()}";
const char currtime_mysql[] = "CURTIME()";
const char currtime_pgsql[] = "localtime";
-const char currtime_sqlite[] = "time('now')";
+const char currtime_sqlite[] = "time('now', 'localtime')";
const char currtime_freetds[] = "CURRENT_TIME";
const char currtime_fallback[] = "CURTIME()";
diff --git a/tests/gen_sms_tests.py b/tests/gen_sms_tests.py
index 2e74513..909bd97 100755
--- a/tests/gen_sms_tests.py
+++ b/tests/gen_sms_tests.py
@@ -7,7 +7,7 @@ Gammu SMS backup generator.
__author__ = 'Michal Čihař'
__email__ = 'michal@cihar.com'
__license__ = '''
-Copyright © 2003 - 2010 Michal Čihař
+Copyright © 2003 - 2015 Michal Čihař
This program is free software; you can redistribute it and/or modify it
under the terms of the GNU General Public License version 2 as published by
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index f585f5e..f7803ef 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -1,5 +1,5 @@
# cmake <http://www.cmake.org> build file for Gammu utils
-# Copyright (c) 2007 - 2010 Michal Cihar
+# Copyright (c) 2007 - 2015 Michal Cihar
# vim: expandtab sw=4 ts=4 sts=4:
project (Gammu-utils C)