summaryrefslogtreecommitdiff
path: root/admin/po4a
diff options
context:
space:
mode:
Diffstat (limited to 'admin/po4a')
-rwxr-xr-xadmin/po4a19
1 files changed, 19 insertions, 0 deletions
diff --git a/admin/po4a b/admin/po4a
new file mode 100755
index 0000000..be8473b
--- /dev/null
+++ b/admin/po4a
@@ -0,0 +1,19 @@
+#!/bin/sh
+# vim: expandtab sw=4 ts=4 sts=4:
+
+LOCS=`ls locale/*/gammu.po | sed 's@.*/\(.*\)/[^/]*@\1@'`
+ver=`sed -n 's/set (VERSION "\([^"]*\)".*)/\1/p' CMakeLists.txt`
+
+po4a \
+ --msgid-bugs-address michal@cihar.com \
+ --copyright-holder "Michal Čihař <michal@cihar.com>" \
+ --package-name Gammu-docs \
+ --package-version $ver \
+ admin/po4a.config
+sed -i '
+ s/SOME DESCRIPTIVE TITLE/Gammu documentation translation/;
+ s/PACKAGE/Gammu-docs/;
+ s/(C) YEAR/(C) 2003 - '`date +%Y`'/;
+ s/VERSION/'$ver'/;
+ ' locale/docs.pot
+