summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2019-08-06 13:39:37 +0200
committerStephane Glondu <steph@glondu.net>2019-08-06 13:49:36 +0200
commit99fa58798e35a00aca0b17a6ddab6001329c14e8 (patch)
treebee34c827a43a5419fc2a1a22dcb964fb51298cf
parent7aad7fbb34af49bfaf5e52517b51108a7ad8c4d2 (diff)
Switch to dh and bump debhelper compat level to 12
-rw-r--r--debian/compat2
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules14
3 files changed, 11 insertions, 8 deletions
diff --git a/debian/compat b/debian/compat
index 7f8f011..48082f7 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-7
+12
diff --git a/debian/control b/debian/control
index b0f56af..f239e25 100644
--- a/debian/control
+++ b/debian/control
@@ -4,8 +4,7 @@ Priority: optional
Maintainer: Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
Uploaders: Samuel Mimram <smimram@debian.org>, Romain Beauxis <toots@rastageeks.org>
Build-Depends:
- cdbs (>= 0.4.72~),
- debhelper,
+ debhelper (>= 12),
dh-buildinfo,
ocaml-nox,
dh-ocaml (>= 0.9),
diff --git a/debian/rules b/debian/rules
index e4c27ae..333e924 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,17 +1,21 @@
#!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/makefile.mk
-include /usr/share/cdbs/1/rules/ocaml.mk
+include /usr/share/ocaml/ocamlvars.mk
DESTDIR = $(CURDIR)/debian/tmp/$(OCAML_STDLIB_DIR)
# Do not compile dynlink files for now..
DEB_MAKE_BUILD_TARGET := OCAML_DYNLINK="" all
-DEB_MAKE_INSTALL_TARGET := install OCAMLFIND_DESTDIR=$(DESTDIR) OCAMLFIND_LDCONF=ignore
ifeq ($(OCAML_HAVE_OCAMLOPT),yes)
DEB_MAKE_BUILD_TARGET += opt
endif
-makebuilddir::
+%:
+ dh $@ --with ocaml
+
+override_dh_auto_build:
+ $(MAKE) $(DEB_MAKE_BUILD_TARGET)
+
+override_dh_auto_install:
mkdir -p $(DESTDIR)
+ $(MAKE) install OCAMLFIND_DESTDIR=$(DESTDIR) OCAMLFIND_LDCONF=ignore