summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2019-10-18 21:17:13 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2019-10-18 21:17:43 +0200
commit687f6e847687c5e7758dceb414de6fb59064a670 (patch)
tree848df37e230e11ea2aacab266b0e94a3d4323d7e
parent2d02ff32e7093ad0cf9dfce75422fb30c3e1df91 (diff)
Refresh patches and start on changelog entry
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/0001-Replace-donation-button.patch4
-rw-r--r--debian/patches/0002-Spelling.patch72
3 files changed, 25 insertions, 58 deletions
diff --git a/debian/changelog b/debian/changelog
index 6058396..e171698 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+gdspy (1.4.2-1) UNRELEASED; urgency=medium
+
+ * New upstream release
+ - Refresh patches
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Fri, 18 Oct 2019 21:17:27 +0200
+
gdspy (1.3.1-3) unstable; urgency=medium
* debian/control:
diff --git a/debian/patches/0001-Replace-donation-button.patch b/debian/patches/0001-Replace-donation-button.patch
index 39d77a2..a22dea7 100644
--- a/debian/patches/0001-Replace-donation-button.patch
+++ b/debian/patches/0001-Replace-donation-button.patch
@@ -7,10 +7,10 @@ Subject: Replace donation button
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/docs/index.rst b/docs/index.rst
-index 9701645..2f9af2f 100644
+index 9e41842..fa23cc0 100644
--- a/docs/index.rst
+++ b/docs/index.rst
-@@ -18,8 +18,5 @@ Support
+@@ -20,8 +20,5 @@ Support
Help support the development of gdspy by donating:
diff --git a/debian/patches/0002-Spelling.patch b/debian/patches/0002-Spelling.patch
index 0112aa3..86ad2a8 100644
--- a/debian/patches/0002-Spelling.patch
+++ b/debian/patches/0002-Spelling.patch
@@ -3,77 +3,37 @@ Date: Sun, 30 Sep 2018 23:34:31 +0200
Subject: Spelling
---
- examples/tutorial.py | 2 +-
- gdspy/__init__.py | 16 ++++++++--------
- 2 files changed, 9 insertions(+), 9 deletions(-)
+ gdspy/__init__.py | 10 +-
+ 2 files changed, 363 insertions(+), 5 deletions(-)
+ create mode 100644 examples/tutorial.py
-diff --git a/examples/tutorial.py b/examples/tutorial.py
-index e29cd39..93f7362 100644
---- a/examples/tutorial.py
-+++ b/examples/tutorial.py
-@@ -237,7 +237,7 @@ original = gdspy.Round((0, 0), 10, inner_radius=5)
- result = gdspy.slice(original, [-7, 7], 0, layer=1)
-
- # The result is a tuple of polygon sets, one for each slice. To keep
--# add the region betwen our 2 cuts, we chose result[1].
-+# add the region between our 2 cuts, we chose result[1].
- slice_cell.add(result[1])
-
- # If the cut needs to be at an angle we can rotate the geometry, slice
diff --git a/gdspy/__init__.py b/gdspy/__init__.py
-index cfd7426..ecddf81 100644
+index ca16f5c..44de47f 100644
--- a/gdspy/__init__.py
+++ b/gdspy/__init__.py
-@@ -2559,13 +2559,13 @@ class Cell(object):
+@@ -6532,13 +6532,13 @@ class Cell(object):
Parameters
----------
single_layer : integer or None
-- If not ``None``, all polygons will be transfered to the
-+ If not ``None``, all polygons will be transferred to the
+- If not None, all polygons will be transfered to the
++ If not None, all polygons will be transferred to the
layer indicated by this number.
single_datatype : integer or None
-- If not ``None``, all polygons will be transfered to the
-+ If not ``None``, all polygons will be transferred to the
+- If not None, all polygons will be transfered to the
++ If not None, all polygons will be transferred to the
datatype indicated by this number.
single_datatype : integer or None
-- If not ``None``, all labels will be transfered to the
-+ If not ``None``, all labels will be transferred to the
+- If not None, all labels will be transfered to the
++ If not None, all labels will be transferred to the
texttype indicated by this number.
Returns
-@@ -3448,7 +3448,7 @@ class GdsLibrary(object):
- Notes
- -----
- Not all features from the GDSII specification are currently
-- supported. A warning will be produced if any unsuported
-+ supported. A warning will be produced if any unsupported
- features are found in the imported file.
- """
- self._references = []
-@@ -3929,14 +3929,14 @@ def offset(polygons,
- Type of join used to create the offset polygon.
- tolerance : number
- For miter joints, this number must be at least 2 and it
-- represents the maximun distance in multiples of offset betwen
-+ represents the maximun distance in multiples of offset between
- new vertices and their original position before beveling to
- avoid spikes at acute joints. For round joints, it indicates
- the curvature resolution in number of points per full circle.
- precision : float
- Desired precision for rounding vertice coordinates.
- join_first : bool
-- Join all paths before offseting to avoid unecessary joins in
-+ Join all paths before offseting to avoid unnecessary joins in
- adjacent polygon sides.
- max_points : integer
- If greater than 4, fracture the resulting polygons to ensure
-@@ -4180,13 +4180,13 @@ def gdsii_hash(filename, engine=None):
+@@ -8584,12 +8584,12 @@ def gdsii_hash(filename, engine=None):
engine : hashlib-like engine
The engine that executes the hashing algorithm. It must provide
- the methods ``update`` and ``hexdigest`` as defined in the
-- hashlib module. If ``None``, the dafault ``hashlib.sha1()`` is
-+ hashlib module. If ``None``, the default ``hashlib.sha1()`` is
- used.
+ the methods `update` and `hexdigest` as defined in the hashlib
+- module. If None, the dafault `hashlib.sha1()` is used.
++ module. If None, the default `hashlib.sha1()` is used.
Returns
-------
@@ -81,5 +41,5 @@ index cfd7426..ecddf81 100644
- The hash correponding to the library contents in hex format.
+ The hash corresponding to the library contents in hex format.
"""
- with open(filename, 'rb') as fin:
+ with open(filename, "rb") as fin:
data = fin.read()