summaryrefslogtreecommitdiff
path: root/themes/openSUSE/help-install/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'themes/openSUSE/help-install/Makefile')
-rw-r--r--themes/openSUSE/help-install/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/themes/openSUSE/help-install/Makefile b/themes/openSUSE/help-install/Makefile
new file mode 100644
index 0000000..617e707
--- /dev/null
+++ b/themes/openSUSE/help-install/Makefile
@@ -0,0 +1,19 @@
+BINDIR := $(shell [ -x ../../../mkbootmsg ] && echo ../../../ )
+
+PRODUCT = $(shell perl -ne 'print if s/^product=//' ../config)
+
+HELP2TXT = $(BINDIR)help2txt
+
+HELPFILES = $(addsuffix .hlp,$(basename $(wildcard *.html)))
+
+%.hlp: %.html
+ $(HELP2TXT) --product='$(PRODUCT)' $< >$@
+
+all: .ready
+
+.ready: $(HELPFILES)
+ @touch .ready
+
+clean:
+ rm -f .ready *.hlp *~
+