summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJoey Hess <joeyh@joeyh.name>2018-02-27 11:59:45 -0400
committerJoey Hess <joeyh@joeyh.name>2018-02-27 12:02:38 -0400
commit8f71b316c9063d58cf020689003646667a5c6785 (patch)
treed82195c79322cc8df90f79fdba4619be03480110 /Makefile
parentb1c0e44c330a8516e827be7353574d4b02ad7abb (diff)
remove chrpath hack
Makefile: Remove chrpath workaround for bug in cabal, which is no longer needed. https://github.com/haskell/cabal/issues/2717 says it uses RUNPATH instead of RPATH now, but I don't even see that for statically linked libraries; the bug with that appears to be fixed. cabal-install version 1.24.0.2 compiled using version 1.24.2.0 of the Cabal library I left the rpath removal using otool on OSX because those straight up broke the linker, and I don't know if the OSX autobuilder is updated to a new enough cabal to not need it. This commit was sponsored by Ewen McNeill on Patreon.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 0 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 74e00a14e4..5844278a64 100644
--- a/Makefile
+++ b/Makefile
@@ -35,11 +35,6 @@ git-annex: tmp/configure-stamp
else \
ln -sf dist/build/git-annex/git-annex git-annex; \
fi
-# Work around https://github.com/haskell/cabal/issues/3524
-# when not linked dynamically to haskell libs
- @if ! ldd git-annex | grep -q libHS; then \
- chrpath -d git-annex || echo "** warning: unable to chrpath git-annex; it will be a little bit slower than necessary"; \
- fi
git-annex-shell: git-annex
ln -sf git-annex git-annex-shell