summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJoey Hess <joeyh@joeyh.name>2015-03-23 15:36:10 -0400
committerJoey Hess <joeyh@joeyh.name>2015-03-23 15:36:10 -0400
commitdaec4b007abcf4f354af2dd245077a25f10ec576 (patch)
treec74c9cbe240ed0e0fd34d9ba47aeb0214e0395f0 /Makefile
parent5c2ad84d2872346029b9348fc584e5228ca6fd56 (diff)
splitting up the man page
Common command man pages all split out and often expanded. A few sections split out into their own pages. Still need to do all the other commands..
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 98b052cd9a..d9100c49e9 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-mans=git-annex.1 git-annex-shell.1
+mans=git-annex.1 $(shell find doc -maxdepth 1 -name git-annex-*.mdwn | sed -e 's/doc\///' -e 's/\.mdwn/\.1/')
all=git-annex $(mans) docs
CABAL?=cabal # set to "./Setup" if you lack a cabal program
@@ -67,7 +67,9 @@ else
IKIWIKI=ikiwiki
endif
-docs: $(mans)
+mans: $(mans)
+
+docs: mans
$(IKIWIKI) doc html -v --wikiname git-annex --plugin=goodstuff \
--no-usedirs --disable-plugin=openid --plugin=sidebar \
--underlaydir=/dev/null --disable-plugin=shortcut \