summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJoey Hess <joeyh@joeyh.name>2016-05-24 01:00:06 -0400
committerJoey Hess <joeyh@joeyh.name>2016-05-24 01:28:07 -0400
commitf79875ef3bb4157cd7a246fcd9cd411fc1047bdb (patch)
treef64d3e15a3d4cbc5e8e9a960926f3adc6540f366 /Makefile
parentcbb1dbdafcf83113810ccf1918573825cd062a0f (diff)
Updated cabal file explictly lists source files.
The tarball on hackage will include only the files needed for cabal install; it is NOT the full git-annex source tree. While it's totally obnoxious that cabal files need every file listed out when basic wildcard support could avoid hundreds of lines, and have to be maintained when files are added, this does get the tarball size back down to 1 mb. This also stops stack from complaining that it found modules not listed in the cabal file. debian/changelog, debian/NEWS, debian/copyright: Converted to symlinks to CHANGELOG, NEWS, and COPYRIGHT, which used to symlink to these instead. This avoids needing to include debian/ in the hackage tarball. Setup.hs: Build man pages at install time using make and mdwn2man. If it fails, which it probably will on windows, just skip installing them.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile32
1 files changed, 17 insertions, 15 deletions
diff --git a/Makefile b/Makefile
index cee4ee02ef..0904f6a005 100644
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@ endif
build: $(all)
-Build/SysConfig.hs: configure.hs Build/TestConfig.hs Build/Configure.hs
+Build/SysConfig.hs: Build/TestConfig.hs Build/Configure.hs
if [ "$(BUILDER)" = ./Setup ]; then ghc --make Setup; fi
if [ "$(BUILDER)" = stack ]; then \
$(BUILDER) build $(BUILDEROPTIONS); \
@@ -86,15 +86,19 @@ man:
mkdir -p man
docs: mans
- LC_ALL=C TZ=UTC $(IKIWIKI) doc html -v --wikiname git-annex \
- --plugin=goodstuff \
- --no-usedirs --disable-plugin=openid --plugin=sidebar \
- --underlaydir=/dev/null --set deterministic=1 \
- --disable-plugin=shortcut --disable-plugin=smiley \
- --plugin=comments --set comments_pagespec="*" \
- --exclude='news/.*' --exclude='design/assistant/blog/*' \
- --exclude='bugs/*' --exclude='todo/*' --exclude='forum/*' \
- --exclude='users/*' --exclude='devblog/*' --exclude='thanks'
+ @if [ ! -e doc/index.mdwn ]; then \
+ echo "** doc/index.mdwn does not exist, skipping building docs (clone git-annex source to enable full docs build)" >&2; \
+ else \
+ LC_ALL=C TZ=UTC $(IKIWIKI) doc html -v --wikiname git-annex \
+ --plugin=goodstuff \
+ --no-usedirs --disable-plugin=openid --plugin=sidebar \
+ --underlaydir=/dev/null --set deterministic=1 \
+ --disable-plugin=shortcut --disable-plugin=smiley \
+ --plugin=comments --set comments_pagespec="*" \
+ --exclude='news/.*' --exclude='design/assistant/blog/*' \
+ --exclude='bugs/*' --exclude='todo/*' --exclude='forum/*' \
+ --exclude='users/*' --exclude='devblog/*' --exclude='thanks'; \
+ fi
clean:
if [ "$(BUILDER)" != ./Setup ] && [ "$(BUILDER)" != cabal ]; then $(BUILDER) clean; fi
@@ -118,11 +122,9 @@ Build/OSXMkLibs: Build/OSXMkLibs.hs
Build/LinuxMkLibs: Build/LinuxMkLibs.hs
$(GHC) --make $@ -Wall -fno-warn-tabs
-sdist: clean mans
- ./Build/make-sdist.sh
-
# Upload to hackage.
-hackage: sdist
+hackage:
+ @cabal sdist
@cabal upload dist/*.tar.gz
LINUXSTANDALONE_DEST=tmp/git-annex.linux
@@ -170,7 +172,7 @@ prep-standalone:
undo-standalone:
test -e .git
- git checkout debian/changelog
+ git checkout debian/changelog CHANGELOG
quilt pop -a || true
commit-standalone: