summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2019-02-17 11:07:48 +0100
committerAndrej Shadura <andrewsh@debian.org>2019-02-17 11:26:52 +0100
commit38201006a0c4045b28095b0aa2f031048e552eff (patch)
treeda5cdcda7b80cdbfec4b12c2d7acac5ad937fb92
parent9d2380484f818513ec5654d08b3adccfac9f2d8f (diff)
Python 3
-rw-r--r--debian/control8
-rwxr-xr-xdebian/rules2
2 files changed, 5 insertions, 5 deletions
diff --git a/debian/control b/debian/control
index f1039c1..fe06973 100644
--- a/debian/control
+++ b/debian/control
@@ -4,15 +4,15 @@ Section: vcs
Priority: optional
Build-Depends: debhelper-compat (= 12),
dh-python,
- python-all (>= 2.7),
- python-setuptools (>= 0.6b3),
- python-docutils (>= 0.12)
+ python3-all (>= 3.6),
+ python3-setuptools (>= 0.6b3),
+ python3-docutils (>= 0.12)
Standards-Version: 4.3.0
Homepage: https://github.com/andrewshadura/git-crecord
Package: git-crecord
Architecture: all
-Depends: ${misc:Depends}, ${python:Depends}
+Depends: ${misc:Depends}, ${python3:Depends}
Description: interactively select chunks to commit with Git
git-crecord is a Git subcommand which allows users to interactively
select changes to commit or stage using a ncurses-based text user
diff --git a/debian/rules b/debian/rules
index 4222811..a4a7548 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
PACKAGE := $(shell dpkg-parsechangelog -S Source)
%:
- dh $@ --with python2 --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild
override_dh_auto_install:
dh_auto_install