summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2022-08-31 11:01:23 +0100
committerSimon McVittie <smcv@debian.org>2022-08-31 11:01:23 +0100
commita7b08fcc3132e488c36eabe45c14e60ff304b274 (patch)
tree101f7398abbf26c3a6a3474cff95842ea2bad1d9
parent7df652c47480eeccd5fe78d3af89ab6b5789b3aa (diff)
Disable gjs plugin on big-endian powerpc/ppc64
mozjs102 fails tests on these non-release architectures, so gjs will soon stop being available there.
-rw-r--r--debian/control2
-rw-r--r--debian/control.in2
-rwxr-xr-xdebian/rules4
3 files changed, 4 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index 2b7648c1..a8128d3b 100644
--- a/debian/control
+++ b/debian/control
@@ -14,7 +14,7 @@ Build-Depends: at-spi2-core <!nocheck>,
dh-sequence-gnome,
itstool,
libxml2-dev (>= 2.4.0),
- libgjs-dev (>= 1.64.0) [amd64 arm64 armhf i386 mips64el mipsel ppc64el s390x powerpc ppc64 riscv64],
+ libgjs-dev (>= 1.64.0) [amd64 arm64 armhf i386 mips64el mipsel ppc64el s390x riscv64],
libglib2.0-dev (>= 2.64.0),
libgtk-3-dev (>= 3.24.0),
libwebkit2gtk-4.0-dev (>= 2.28.0) [!ia64 !kfreebsd-any],
diff --git a/debian/control.in b/debian/control.in
index 96dc5e7b..9aefcadc 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -10,7 +10,7 @@ Build-Depends: at-spi2-core <!nocheck>,
dh-sequence-gnome,
itstool,
libxml2-dev (>= 2.4.0),
- libgjs-dev (>= 1.64.0) [amd64 arm64 armhf i386 mips64el mipsel ppc64el s390x powerpc ppc64 riscv64],
+ libgjs-dev (>= 1.64.0) [amd64 arm64 armhf i386 mips64el mipsel ppc64el s390x riscv64],
libglib2.0-dev (>= 2.64.0),
libgtk-3-dev (>= 3.24.0),
libwebkit2gtk-4.0-dev (>= 2.28.0) [!ia64 !kfreebsd-any],
diff --git a/debian/rules b/debian/rules
index c179dbeb..2e1a24f9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,7 @@ endif
ifneq (,$(filter $(DEB_HOST_ARCH), ia64 kfreebsd-amd64 kfreebsd-i386))
ENABLE_WEBKIT = -Dwebkit2gtk=disabled
endif
-ifeq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 armhf i386 mips64el mipsel ppc64el s390x powerpc ppc64 riscv64))
+ifeq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 armhf i386 mips64el mipsel ppc64el s390x riscv64))
ENABLE_GJS = -Dgjs=disabled
endif
@@ -31,7 +31,7 @@ TEST_COMMAND = dh_auto_test -- --wrap="dbus-run-session -- xvfb-run -a" \
override_dh_auto_test:
# Tests are failing without gjs support, see https://gitlab.gnome.org/GNOME/glade/-/issues/495
-ifeq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 armhf i386 mips64el mipsel ppc64el s390x powerpc ppc64 riscv64))
+ifeq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 armhf i386 mips64el mipsel ppc64el s390x riscv64))
$(TEST_COMMAND) || true
else
$(TEST_COMMAND)