summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig) <jan.steffens@gmail.com>2020-11-09 17:35:04 +0000
committerJan Alexander Steffens (heftig) <jan.steffens@gmail.com>2020-11-09 17:38:55 +0000
commitba3bc86d54524af38f3ff6790f198633a5821fb9 (patch)
tree656a4acf7984e61ee48b2c585195ef526e08654b /meson.build
parent7ff26ad6bfa22b9b0737e3beda09a291006658f4 (diff)
Python plugin: Fix build against Python 3.9
This basically reverts 6f4fb5672f41201a20e0f879a7d7d7b96f045425, returning to Meson's `python` module, since the `python-3.8-embed` dependency obviously only works with Python 3.8. We're using the `embed` kwarg which was added in Meson 0.53.0, so we need to bump the minimum `meson_version`.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 90d8ffc8..3b6b9a01 100644
--- a/meson.build
+++ b/meson.build
@@ -11,7 +11,7 @@ project(
version: '3.39.0',
license: 'GPL2',
default_options: 'buildtype=debugoptimized',
- meson_version: '>= 0.49.0',
+ meson_version: '>= 0.53.0',
)
glade_name = meson.project_name()
@@ -153,7 +153,7 @@ pygobject_version = '3.8.0'
pygobject_dep = dependency('pygobject-3.0', version: '>= ' + pygobject_version, required: get_option('python'))
have_python = pygobject_dep.found()
if have_python
- python_dep = dependency('python-3.8-embed', version: '>= 3.8')
+ python_dep = import('python').find_installation().dependency(embed: true)
version_array = pygobject_version.split('.')
config_h.set('PYGOBJECT_REQUIRED_MAJOR', version_array[0].to_int())