summaryrefslogtreecommitdiff
path: root/plugins/gtk+
diff options
context:
space:
mode:
authorTristan Van Berkom <tvb@gnome.org>2009-01-27 21:15:59 +0000
committerTristan Van Berkom <tvb@src.gnome.org>2009-01-27 21:15:59 +0000
commitf8dc325b555700536f99d06292360b96c0c647dd (patch)
tree62eeae49f0ea90155bd4057c97f9b3bd65988786 /plugins/gtk+
parentbd39a1e0781be66de4d2fca2d102bbc4dc67d4c3 (diff)
Bumping version for Anjuta dependancy
2009-01-27 Tristan Van Berkom <tvb@gnome.org> * configure.ac: Bumping version for Anjuta dependancy * plugins/gtk+/gtk+.xml.in: Added some metadata about GtkAction 2009-01-23 Tristan Van Berkom <tvb@gnome.org> * plugins/gtk+/glade-entry-editor.c, plugins/gtk+/glade-gtk.c, plugins/gtk+/gtk+.xml.in: updated for new GtkEntry property name changes. svn path=/trunk/; revision=2100
Diffstat (limited to 'plugins/gtk+')
-rw-r--r--plugins/gtk+/glade-entry-editor.c28
-rw-r--r--plugins/gtk+/glade-gtk.c44
-rw-r--r--plugins/gtk+/gtk+.xml.in34
3 files changed, 57 insertions, 49 deletions
diff --git a/plugins/gtk+/glade-entry-editor.c b/plugins/gtk+/glade-entry-editor.c
index b115d68b..e9bb1f98 100644
--- a/plugins/gtk+/glade-entry-editor.c
+++ b/plugins/gtk+/glade-entry-editor.c
@@ -206,10 +206,10 @@ glade_entry_editor_grab_focus (GtkWidget *widget)
}
-#define ICON_MODE_NAME(primary) ((primary) ? "primary-icon-mode" : "secondary-icon-mode")
-#define PIXBUF_NAME(primary) ((primary) ? "pixbuf-primary" : "pixbuf-secondary")
-#define ICON_NAME_NAME(primary) ((primary) ? "icon-name-primary" : "icon-name-secondary")
-#define STOCK_NAME(primary) ((primary) ? "stock-primary" : "stock-secondary")
+#define ICON_MODE_NAME(primary) ((primary) ? "primary-icon-mode" : "secondary-icon-mode")
+#define PIXBUF_NAME(primary) ((primary) ? "primary-icon-pixbuf" : "secondary-icon-pixbuf")
+#define ICON_NAME_NAME(primary) ((primary) ? "primary-icon-name" : "secondary-icon-name")
+#define STOCK_NAME(primary) ((primary) ? "primary-icon-stock" : "secondary-icon-stock")
static void
set_stock_mode (GladeEntryEditor *entry_editor, gboolean primary)
@@ -491,7 +491,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
group = gtk_size_group_new (GTK_SIZE_GROUP_HORIZONTAL);
/* Pixbuf */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "pixbuf-primary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, PIXBUF_NAME(TRUE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->primary_pixbuf_radio = gtk_radio_button_new (NULL);
gtk_box_pack_start (GTK_BOX (hbox), entry_editor->primary_pixbuf_radio, FALSE, FALSE, 2);
@@ -501,7 +501,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
/* Stock */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "stock-primary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, STOCK_NAME(TRUE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->primary_stock_radio = gtk_radio_button_new_from_widget
(GTK_RADIO_BUTTON (entry_editor->primary_pixbuf_radio));
@@ -512,7 +512,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
/* Icon name */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "icon-name-primary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, ICON_NAME_NAME(TRUE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->primary_icon_name_radio = gtk_radio_button_new_from_widget
(GTK_RADIO_BUTTON (entry_editor->primary_pixbuf_radio));
@@ -522,12 +522,12 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
table_attach (table, GTK_WIDGET (eprop), 1, 2, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "activatable-primary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "primary-icon-activatable", FALSE, TRUE);
table_attach (table, eprop->item_label, 0, 3, group);
table_attach (table, GTK_WIDGET (eprop), 1, 3, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "sensitive-primary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "primary-icon-sensitive", FALSE, TRUE);
table_attach (table, eprop->item_label, 0, 4, group);
table_attach (table, GTK_WIDGET (eprop), 1, 4, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
@@ -554,7 +554,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
group = gtk_size_group_new (GTK_SIZE_GROUP_HORIZONTAL);
/* Pixbuf */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "pixbuf-secondary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, PIXBUF_NAME(FALSE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->secondary_pixbuf_radio = gtk_radio_button_new (NULL);
gtk_box_pack_start (GTK_BOX (hbox), entry_editor->secondary_pixbuf_radio, FALSE, FALSE, 2);
@@ -564,7 +564,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
/* Stock */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "stock-secondary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, STOCK_NAME(FALSE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->secondary_stock_radio = gtk_radio_button_new_from_widget
(GTK_RADIO_BUTTON (entry_editor->secondary_pixbuf_radio));
@@ -575,7 +575,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
/* Icon name */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "icon-name-secondary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, ICON_NAME_NAME(FALSE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->secondary_icon_name_radio = gtk_radio_button_new_from_widget
(GTK_RADIO_BUTTON (entry_editor->secondary_pixbuf_radio));
@@ -585,12 +585,12 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
table_attach (table, GTK_WIDGET (eprop), 1, 2, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "activatable-secondary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "secondary-icon-activatable", FALSE, TRUE);
table_attach (table, eprop->item_label, 0, 3, group);
table_attach (table, GTK_WIDGET (eprop), 1, 3, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "sensitive-secondary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "secondary-icon-sensitive", FALSE, TRUE);
table_attach (table, eprop->item_label, 0, 4, group);
table_attach (table, GTK_WIDGET (eprop), 1, 4, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
diff --git a/plugins/gtk+/glade-gtk.c b/plugins/gtk+/glade-gtk.c
index 2dc92abf..7e3a003f 100644
--- a/plugins/gtk+/glade-gtk.c
+++ b/plugins/gtk+/glade-gtk.c
@@ -4748,19 +4748,19 @@ glade_gtk_entry_set_property (GladeWidgetAdaptor *adaptor,
{
mode = g_value_get_int (value);
- glade_widget_property_set_sensitive (gwidget, "stock-primary", FALSE, NOT_SELECTED_MSG);
- glade_widget_property_set_sensitive (gwidget, "icon-name-primary", FALSE, NOT_SELECTED_MSG);
- glade_widget_property_set_sensitive (gwidget, "pixbuf-primary", FALSE, NOT_SELECTED_MSG);
+ glade_widget_property_set_sensitive (gwidget, "primary-icon-stock", FALSE, NOT_SELECTED_MSG);
+ glade_widget_property_set_sensitive (gwidget, "primary-icon-name", FALSE, NOT_SELECTED_MSG);
+ glade_widget_property_set_sensitive (gwidget, "primary-icon-pixbuf", FALSE, NOT_SELECTED_MSG);
switch (mode) {
case GLADE_IMAGE_MODE_STOCK:
- glade_widget_property_set_sensitive (gwidget, "stock-primary", TRUE, NULL);
+ glade_widget_property_set_sensitive (gwidget, "primary-icon-stock", TRUE, NULL);
break;
case GLADE_IMAGE_MODE_ICON:
- glade_widget_property_set_sensitive (gwidget, "icon-name-primary", TRUE, NULL);
+ glade_widget_property_set_sensitive (gwidget, "primary-icon-name", TRUE, NULL);
break;
case GLADE_IMAGE_MODE_FILENAME:
- glade_widget_property_set_sensitive (gwidget, "pixbuf-primary", TRUE, NULL);
+ glade_widget_property_set_sensitive (gwidget, "primary-icon-pixbuf", TRUE, NULL);
break;
}
}
@@ -4768,19 +4768,19 @@ glade_gtk_entry_set_property (GladeWidgetAdaptor *adaptor,
{
mode = g_value_get_int (value);
- glade_widget_property_set_sensitive (gwidget, "stock-secondary", FALSE, NOT_SELECTED_MSG);
- glade_widget_property_set_sensitive (gwidget, "icon-name-secondary", FALSE, NOT_SELECTED_MSG);
- glade_widget_property_set_sensitive (gwidget, "pixbuf-secondary", FALSE, NOT_SELECTED_MSG);
+ glade_widget_property_set_sensitive (gwidget, "secondary-icon-stock", FALSE, NOT_SELECTED_MSG);
+ glade_widget_property_set_sensitive (gwidget, "secondary-icon-name", FALSE, NOT_SELECTED_MSG);
+ glade_widget_property_set_sensitive (gwidget, "secondary-icon-pixbuf", FALSE, NOT_SELECTED_MSG);
switch (mode) {
case GLADE_IMAGE_MODE_STOCK:
- glade_widget_property_set_sensitive (gwidget, "stock-secondary", TRUE, NULL);
+ glade_widget_property_set_sensitive (gwidget, "secondary-icon-stock", TRUE, NULL);
break;
case GLADE_IMAGE_MODE_ICON:
- glade_widget_property_set_sensitive (gwidget, "icon-name-secondary", TRUE, NULL);
+ glade_widget_property_set_sensitive (gwidget, "secondary-icon-name", TRUE, NULL);
break;
case GLADE_IMAGE_MODE_FILENAME:
- glade_widget_property_set_sensitive (gwidget, "pixbuf-secondary", TRUE, NULL);
+ glade_widget_property_set_sensitive (gwidget, "secondary-icon-pixbuf", TRUE, NULL);
break;
}
}
@@ -4802,37 +4802,37 @@ glade_gtk_entry_read_widget (GladeWidgetAdaptor *adaptor,
/* First chain up and read in all the normal properties.. */
GWA_GET_CLASS (GTK_TYPE_WIDGET)->read_widget (adaptor, widget, node);
- if (glade_widget_property_original_default (widget, "icon-name-primary") == FALSE)
+ if (glade_widget_property_original_default (widget, "primary-icon-name") == FALSE)
{
- property = glade_widget_get_property (widget, "icon-name-primary");
+ property = glade_widget_get_property (widget, "primary-icon-name");
glade_widget_property_set (widget, "primary-icon-mode", GLADE_IMAGE_MODE_ICON);
}
- else if (glade_widget_property_original_default (widget, "pixbuf-primary") == FALSE)
+ else if (glade_widget_property_original_default (widget, "primary-icon-pixbuf") == FALSE)
{
- property = glade_widget_get_property (widget, "pixbuf-primary");
+ property = glade_widget_get_property (widget, "primary-icon-pixbuf");
glade_widget_property_set (widget, "primary-icon-mode", GLADE_IMAGE_MODE_FILENAME);
}
else/* if (glade_widget_property_original_default (widget, "stock") == FALSE) */
{
- property = glade_widget_get_property (widget, "stock-primary");
+ property = glade_widget_get_property (widget, "primary-icon-stock");
glade_widget_property_set (widget, "primary-icon-mode", GLADE_IMAGE_MODE_STOCK);
}
glade_property_sync (property);
- if (glade_widget_property_original_default (widget, "icon-name-secondary") == FALSE)
+ if (glade_widget_property_original_default (widget, "secondary-icon-name") == FALSE)
{
- property = glade_widget_get_property (widget, "icon-name-secondary");
+ property = glade_widget_get_property (widget, "secondary-icon-name");
glade_widget_property_set (widget, "secondary-icon-mode", GLADE_IMAGE_MODE_ICON);
}
- else if (glade_widget_property_original_default (widget, "pixbuf-secondary") == FALSE)
+ else if (glade_widget_property_original_default (widget, "secondary-icon-pixbuf") == FALSE)
{
- property = glade_widget_get_property (widget, "pixbuf-secondary");
+ property = glade_widget_get_property (widget, "secondary-icon-pixbuf");
glade_widget_property_set (widget, "secondary-icon-mode", GLADE_IMAGE_MODE_FILENAME);
}
else/* if (glade_widget_property_original_default (widget, "stock") == FALSE) */
{
- property = glade_widget_get_property (widget, "stock-secondary");
+ property = glade_widget_get_property (widget, "secondary-icon-stock");
glade_widget_property_set (widget, "secondary-icon-mode", GLADE_IMAGE_MODE_STOCK);
}
diff --git a/plugins/gtk+/gtk+.xml.in b/plugins/gtk+/gtk+.xml.in
index d0df68cf..550a4b93 100644
--- a/plugins/gtk+/gtk+.xml.in
+++ b/plugins/gtk+/gtk+.xml.in
@@ -792,18 +792,18 @@ embedded in another object</_tooltip>
<property id="inner-border" since="2.10"/>
<property id="truncate-multiline" since="2.10"/>
<property id="shadow-type" since="2.12"/>
- <property id="gicon-primary" disabled="True"/>
- <property id="gicon-secondary" disabled="True"/>
- <property id="stock-primary" since="2.16" custom-layout="True" stock-icon="True"/>
- <property id="stock-secondary" since="2.16" custom-layout="True" stock-icon="True"/>
- <property id="pixbuf-primary" since="2.16" custom-layout="True"/>
- <property id="pixbuf-secondary" since="2.16" custom-layout="True"/>
- <property id="icon-name-primary" since="2.16" custom-layout="True" themed-icon="True"/>
- <property id="icon-name-secondary" since="2.16" custom-layout="True" themed-icon="True"/>
- <property id="activatable-primary" since="2.16" custom-layout="True"/>
- <property id="activatable-secondary" since="2.16" custom-layout="True"/>
- <property id="sensitive-primary" since="2.16" custom-layout="True"/>
- <property id="sensitive-secondary" since="2.16" custom-layout="True"/>
+ <property id="primary-icon-gicon" disabled="True"/>
+ <property id="secondary-icon-gicon" disabled="True"/>
+ <property id="primary-icon-stock" since="2.16" custom-layout="True" stock-icon="True"/>
+ <property id="secondary-icon-stock" since="2.16" custom-layout="True" stock-icon="True"/>
+ <property id="primary-icon-pixbuf" since="2.16" custom-layout="True"/>
+ <property id="secondary-icon-pixbuf" since="2.16" custom-layout="True"/>
+ <property id="primary-icon-name" since="2.16" custom-layout="True" themed-icon="True"/>
+ <property id="secondary-icon-name" since="2.16" custom-layout="True" themed-icon="True"/>
+ <property id="primary-icon-activatable" since="2.16" custom-layout="True"/>
+ <property id="secondary-icon-activatable" since="2.16" custom-layout="True"/>
+ <property id="primary-icon-sensitive" since="2.16" custom-layout="True"/>
+ <property id="secondary-icon-sensitive" since="2.16" custom-layout="True"/>
<property id="progress-fraction" since="2.16" custom-layout="True"/>
<property id="progress-pulse-step" since="2.16" custom-layout="True"/>
@@ -1831,7 +1831,15 @@ embedded in another object</_tooltip>
</glade-widget-class>
<glade-widget-class name="GtkAction" generic-name="action" _title="Action"
- libglade-unsupported="True" toplevel="True"/>
+ libglade-unsupported="True" toplevel="True">
+ <properties>
+ <property id="stock-id" stock-icon="True"/>
+ <property id="icon-name" themed-icon="True"/>
+ <property id="gicon" disabled="True"/>
+ <property id="action-group" disabled="True"/>
+ </properties>
+ </glade-widget-class>
+
<glade-widget-class name="GtkToggleAction" generic-name="toggleaction" _title="Toggle Action"
libglade-unsupported="True"/>
<glade-widget-class name="GtkRadioAction" generic-name="radioaction" _title="Radio Action"