summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Cowgill <jcowgill@debian.org>2019-07-15 11:45:30 +0100
committerJames Cowgill <jcowgill@debian.org>2019-07-15 11:45:30 +0100
commit5bf45d243f2e32389b4f012e182165a85d445279 (patch)
tree60f693ba097ebea970b25253262d67e4997e2bd0
parent51deed992995f0482b1122627280bd6093aa9100 (diff)
d/control: Add new runtime dependencies
In 3.3, GLFW has moved primarily to a model of dynamically loading the libraries it needs at runtime with the aim of supporting multiple window systems / graphics backends / etc in the same library. Unfortunately this doesn't fit well with Debian's dependency system, so manual dependencies need to be added. As a compromise, add the dependencies required to use the default configuration to the Depends field, and add all the other potential dependencies to the Suggests field. This means that 99% of applications will work correctly without bloating the distribution too much. Any applications which use an alternative configuration (such as GLES or Vulkan) need to make sure they depend on these extra libraries.
-rw-r--r--debian/control22
1 files changed, 18 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index b97e526..d670fe6 100644
--- a/debian/control
+++ b/debian/control
@@ -33,11 +33,14 @@ Architecture: any
Multi-Arch: same
Pre-Depends: ${misc:Pre-Depends}
Depends:
- libgl1-mesa-glx | libgl1,
+ libgl1,
${shlibs:Depends},
${misc:Depends},
Suggests:
- libegl1-mesa | libegl1-x11,
+ libegl1,
+ libgles1,
+ libgles2,
+ libosmesa6,
libvulkan1,
Description: portable library for OpenGL, window and input (x11 libraries)
GLFW is an Open Source, multi-platform library for creating
@@ -51,8 +54,19 @@ Package: libglfw3-wayland
Architecture: linux-any
Multi-Arch: same
Pre-Depends: ${misc:Pre-Depends}
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: libvulkan1
+Depends:
+ libegl1,
+ libgl1,
+ libwayland-cursor0,
+ libwayland-egl1,
+ libxkbcommon0 (>= 0.5.0),
+ ${shlibs:Depends},
+ ${misc:Depends}
+Suggests:
+ libgles1,
+ libgles2,
+ libosmesa6,
+ libvulkan1,
Conflicts: libglfw3
Description: portable library for OpenGL, window and input (wayland libraries)
GLFW is an Open Source, multi-platform library for creating