summaryrefslogtreecommitdiff
path: root/subprojects/shared-modules/linux-audio
diff options
context:
space:
mode:
Diffstat (limited to 'subprojects/shared-modules/linux-audio')
-rw-r--r--subprojects/shared-modules/linux-audio/dssi.json29
-rw-r--r--subprojects/shared-modules/linux-audio/fftw3f-static.json44
-rw-r--r--subprojects/shared-modules/linux-audio/fftw3f.json41
-rw-r--r--subprojects/shared-modules/linux-audio/fluidsynth2-static.json27
-rw-r--r--subprojects/shared-modules/linux-audio/fluidsynth2.json21
-rw-r--r--subprojects/shared-modules/linux-audio/jack2.json23
-rw-r--r--subprojects/shared-modules/linux-audio/ladspa.json17
-rw-r--r--subprojects/shared-modules/linux-audio/lash.json41
-rw-r--r--subprojects/shared-modules/linux-audio/libinstpatch.json17
-rw-r--r--subprojects/shared-modules/linux-audio/liblo-static.json25
-rw-r--r--subprojects/shared-modules/linux-audio/liblo.json17
-rw-r--r--subprojects/shared-modules/linux-audio/lilv.json100
-rw-r--r--subprojects/shared-modules/linux-audio/lrdf.json50
-rw-r--r--subprojects/shared-modules/linux-audio/lv2.json26
-rw-r--r--subprojects/shared-modules/linux-audio/patches/lash-0.5.3-no-static-lib.patch10
-rw-r--r--subprojects/shared-modules/linux-audio/patches/lash-configure.patch11
-rw-r--r--subprojects/shared-modules/linux-audio/patches/lash-gcc47.patch11
-rw-r--r--subprojects/shared-modules/linux-audio/patches/lash-linking.patch90
-rw-r--r--subprojects/shared-modules/linux-audio/patches/stk-install.sh54
-rw-r--r--subprojects/shared-modules/linux-audio/stk.json28
20 files changed, 682 insertions, 0 deletions
diff --git a/subprojects/shared-modules/linux-audio/dssi.json b/subprojects/shared-modules/linux-audio/dssi.json
new file mode 100644
index 00000000..ec33fd37
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/dssi.json
@@ -0,0 +1,29 @@
+{
+ "name": "dssi",
+ "rm-configure": true,
+ "config-opts": [
+ "--disable-static"
+ ],
+ "cleanup": [
+ "/bin",
+ "/include",
+ "/lib/dssi",
+ "/lib/pkgconfig",
+ "/share/man",
+ "*.la"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "http://download.sf.net/sourceforge/dssi/dssi-1.1.1.tar.gz",
+ "sha256": "f2c82b073a947c8255284249097667f9b14e660bf86186f3fcd3b3b3e087814e"
+ },
+ {
+ "type": "script",
+ "commands": [
+ "autoreconf -fiv"
+ ],
+ "dest-filename": "autogen.sh"
+ }
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/fftw3f-static.json b/subprojects/shared-modules/linux-audio/fftw3f-static.json
new file mode 100644
index 00000000..66757499
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/fftw3f-static.json
@@ -0,0 +1,44 @@
+{
+ "name": "fftw3f",
+ "config-opts": [
+ "--enable-threads",
+ "--enable-static",
+ "--disable-shared",
+ "--enable-float"
+ ],
+ "build-options": {
+ "cflags": "-fPIC",
+ "arch": {
+ "x86_64": {
+ "config-opts": [
+ "--enable-sse2",
+ "--enable-avx",
+ "--enable-avx-128-fma"
+ ]
+ },
+ "aarch64": {
+ "config-opts": [
+ "--enable-neon"
+ ]
+ }
+ }
+ },
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://www.fftw.org/fftw-3.3.10.tar.gz",
+ "sha256": "56c932549852cddcfafdab3820b0200c7742675be92179e59e6215b340e26467"
+ }
+ ],
+ "cleanup": [
+ "/bin",
+ "/include",
+ "/lib/cmake",
+ "/lib/pkgconfig",
+ "/share/info",
+ "/share/man",
+ "*.a",
+ "*.la",
+ "*.so"
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/fftw3f.json b/subprojects/shared-modules/linux-audio/fftw3f.json
new file mode 100644
index 00000000..ee10c757
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/fftw3f.json
@@ -0,0 +1,41 @@
+{
+ "name": "fftw3f",
+ "config-opts": [
+ "--enable-threads",
+ "--enable-shared",
+ "--disable-static",
+ "--enable-float"
+ ],
+ "build-options": {
+ "arch": {
+ "x86_64": {
+ "config-opts": [
+ "--enable-sse2",
+ "--enable-avx",
+ "--enable-avx-128-fma"
+ ]
+ },
+ "aarch64": {
+ "config-opts": [
+ "--enable-neon"
+ ]
+ }
+ }
+ },
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://www.fftw.org/fftw-3.3.10.tar.gz",
+ "sha256": "56c932549852cddcfafdab3820b0200c7742675be92179e59e6215b340e26467"
+ }
+ ],
+ "cleanup": [
+ "/bin",
+ "/include",
+ "/lib/cmake",
+ "/lib/pkgconfig",
+ "/share/man",
+ "*.la",
+ "*.so"
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/fluidsynth2-static.json b/subprojects/shared-modules/linux-audio/fluidsynth2-static.json
new file mode 100644
index 00000000..67cea185
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/fluidsynth2-static.json
@@ -0,0 +1,27 @@
+{
+ "name": "fluidsynth",
+ "buildsystem": "cmake-ninja",
+ "build-options": {
+ "cflags": "-fPIC",
+ "cxxflags": "-fPIC"
+ },
+ "config-opts": [
+ "-DLIB_SUFFIX=",
+ "-DBUILD_SHARED_LIBS=OFF"
+ ],
+ "cleanup": [
+ "/bin",
+ "/include",
+ "/lib/pkgconfig",
+ "/share/man",
+ "*.so",
+ "*.a"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://github.com/FluidSynth/fluidsynth/archive/v2.2.8.tar.gz",
+ "sha256": "7c29a5cb7a2755c8012d941d1335da7bda957bbb0a86b7c59215d26773bb51fe"
+ }
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/fluidsynth2.json b/subprojects/shared-modules/linux-audio/fluidsynth2.json
new file mode 100644
index 00000000..a22a060b
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/fluidsynth2.json
@@ -0,0 +1,21 @@
+{
+ "name": "fluidsynth",
+ "buildsystem": "cmake-ninja",
+ "config-opts": [
+ "-DLIB_SUFFIX="
+ ],
+ "cleanup": [
+ "/bin",
+ "/include",
+ "/lib/pkgconfig",
+ "/share/man",
+ "*.so"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://github.com/FluidSynth/fluidsynth/archive/v2.2.8.tar.gz",
+ "sha256": "7c29a5cb7a2755c8012d941d1335da7bda957bbb0a86b7c59215d26773bb51fe"
+ }
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/jack2.json b/subprojects/shared-modules/linux-audio/jack2.json
new file mode 100644
index 00000000..9077fea3
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/jack2.json
@@ -0,0 +1,23 @@
+{
+ "name": "jack2",
+ "buildsystem": "simple",
+ "build-commands": [
+ "./waf configure --prefix=$FLATPAK_DEST --htmldir=$FLATPAK_DEST/share/doc/jack/ --classic",
+ "./waf build -j $FLATPAK_BUILDER_N_JOBS",
+ "./waf install"
+ ],
+ "cleanup": [
+ "/include",
+ "/lib/jack",
+ "/lib/libjack*",
+ "/lib/pkgconfig",
+ "/share/man"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://github.com/jackaudio/jack2/archive/v1.9.17.tar.gz",
+ "sha256": "38f674bbc57852a8eb3d9faa1f96a0912d26f7d5df14c11005ad499c8ae352f2"
+ }
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/ladspa.json b/subprojects/shared-modules/linux-audio/ladspa.json
new file mode 100644
index 00000000..d3637fff
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/ladspa.json
@@ -0,0 +1,17 @@
+{
+ "name": "ladspa",
+ "no-autogen": true,
+ "subdir": "src",
+ "make-install-args": [
+ "INSTALL_PLUGINS_DIR=/app/lib/ladspa",
+ "INSTALL_INCLUDE_DIR=/app/include",
+ "INSTALL_BINARY_DIR=/app/bin"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "http://www.ladspa.org/download/ladspa_sdk_1.17.tgz",
+ "sha256": "27d24f279e4b81bd17ecbdcc38e4c42991bb388826c0b200067ce0eb59d3da5b"
+ }
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/lash.json b/subprojects/shared-modules/linux-audio/lash.json
new file mode 100644
index 00000000..4d0ccb28
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/lash.json
@@ -0,0 +1,41 @@
+{
+ "name": "lash",
+ "rm-configure": true,
+ "config-opts": [
+ "--disable-static",
+ "--disable-serv-inst",
+ "CFLAGS=-D_GNU_SOURCE"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://download.savannah.gnu.org/releases/lash/lash-0.5.4.tar.gz",
+ "sha256": "105a7da84415c4725c6bcad28e70f23aeb4534f94fc80ca262b6a2cef2226c16"
+ },
+ {
+ "type": "patch",
+ "strip-components": 0,
+ "path": "patches/lash-0.5.3-no-static-lib.patch"
+ },
+ {
+ "type": "patch",
+ "path": "patches/lash-gcc47.patch"
+ },
+ {
+ "type": "patch",
+ "path": "patches/lash-linking.patch"
+ },
+ {
+ "type": "patch",
+ "strip-components": 0,
+ "path": "patches/lash-configure.patch"
+ },
+ {
+ "type": "script",
+ "commands": [
+ "autoreconf -fiv"
+ ],
+ "dest-filename": "autogen.sh"
+ }
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/libinstpatch.json b/subprojects/shared-modules/linux-audio/libinstpatch.json
new file mode 100644
index 00000000..fb00c206
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/libinstpatch.json
@@ -0,0 +1,17 @@
+{
+ "name": "libinstpatch",
+ "buildsystem": "cmake-ninja",
+ "config-opts": [
+ "-DLIB_SUFFIX="
+ ],
+ "cleanup": [
+ "/share/doc"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://github.com/swami/libinstpatch/archive/v1.1.6.tar.gz",
+ "sha256": "8e9861b04ede275d712242664dab6ffa9166c7940fea3b017638681d25e10299"
+ }
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/liblo-static.json b/subprojects/shared-modules/linux-audio/liblo-static.json
new file mode 100644
index 00000000..4ca2eb77
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/liblo-static.json
@@ -0,0 +1,25 @@
+{
+ "name": "liblo",
+ "cleanup": [
+ "/bin",
+ "/include",
+ "/lib/pkgconfig",
+ "*.la",
+ "*.a",
+ "*.so"
+ ],
+ "build-options": {
+ "cflags": "-fPIC"
+ },
+ "config-opts": [
+ "--enable-static",
+ "--disable-shared"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "http://download.sf.net/sourceforge/liblo/liblo-0.31.tar.gz",
+ "sha256": "2b4f446e1220dcd624ecd8405248b08b7601e9a0d87a0b94730c2907dbccc750"
+ }
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/liblo.json b/subprojects/shared-modules/linux-audio/liblo.json
new file mode 100644
index 00000000..17de750e
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/liblo.json
@@ -0,0 +1,17 @@
+{
+ "name": "liblo",
+ "cleanup": [
+ "/bin",
+ "/include",
+ "/lib/pkgconfig",
+ "*.la",
+ "*.so"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "http://download.sf.net/sourceforge/liblo/liblo-0.31.tar.gz",
+ "sha256": "2b4f446e1220dcd624ecd8405248b08b7601e9a0d87a0b94730c2907dbccc750"
+ }
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/lilv.json b/subprojects/shared-modules/linux-audio/lilv.json
new file mode 100644
index 00000000..2c080535
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/lilv.json
@@ -0,0 +1,100 @@
+{
+ "name": "lilv",
+ "buildsystem": "simple",
+ "build-commands": [
+ "python3 ./waf configure --prefix=$FLATPAK_DEST",
+ "python3 ./waf build -j $FLATPAK_BUILDER_N_JOBS",
+ "python3 ./waf install"
+ ],
+ "modules": [
+ {
+ "name": "serd",
+ "buildsystem": "simple",
+ "build-commands": [
+ "python3 ./waf configure --prefix=$FLATPAK_DEST",
+ "python3 ./waf build -j $FLATPAK_BUILDER_N_JOBS",
+ "python3 ./waf install"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://download.drobilla.net/serd-0.30.10.tar.bz2",
+ "sha256": "affa80deec78921f86335e6fc3f18b80aefecf424f6a5755e9f2fa0eb0710edf"
+ }
+ ],
+ "post-install": [
+ "install -Dm644 -t /app/share/licenses/serd COPYING"
+ ],
+ "cleanup": [
+ "/bin",
+ "/include",
+ "/lib/pkgconfig",
+ "/share/man"
+ ]
+ },
+ {
+ "name": "sord",
+ "buildsystem": "simple",
+ "build-commands": [
+ "python3 ./waf configure --prefix=$FLATPAK_DEST",
+ "python3 ./waf build -j $FLATPAK_BUILDER_N_JOBS",
+ "python3 ./waf install"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://download.drobilla.net/sord-0.16.8.tar.bz2",
+ "sha256": "7c289d2eaabf82fa6ac219107ce632d704672dcfb966e1a7ff0bbc4ce93f5e14"
+ }
+ ],
+ "post-install": [
+ "install -Dm644 -t /app/share/licenses/sord COPYING"
+ ],
+ "cleanup": [
+ "/bin",
+ "/include",
+ "/lib/pkgconfig",
+ "/share/man"
+ ]
+ },
+ {
+ "name": "sratom",
+ "buildsystem": "simple",
+ "build-commands": [
+ "python3 ./waf configure --prefix=$FLATPAK_DEST",
+ "python3 ./waf build -j $FLATPAK_BUILDER_N_JOBS",
+ "python3 ./waf install"
+ ],
+ "cleanup": [
+ "/include",
+ "/lib/pkgconfig"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://download.drobilla.net/sratom-0.6.8.tar.bz2",
+ "sha256": "3acb32b1adc5a2b7facdade2e0818bcd6c71f23f84a1ebc17815bb7a0d2d02df"
+ }
+ ],
+ "post-install": [
+ "install -Dm644 -t /app/share/licenses/sratom COPYING"
+ ]
+ }
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://download.drobilla.net/lilv-0.24.12.tar.bz2",
+ "sha256": "26a37790890c9c1f838203b47f5b2320334fe92c02a4d26ebbe2669dbd769061"
+ }
+ ],
+ "post-install": [
+ "install -Dm644 -t /app/share/licenses/lilv COPYING"
+ ],
+ "cleanup": [
+ "/bin",
+ "/etc",
+ "/lib/pkgconfig",
+ "/share/man"
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/lrdf.json b/subprojects/shared-modules/linux-audio/lrdf.json
new file mode 100644
index 00000000..29d19dd5
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/lrdf.json
@@ -0,0 +1,50 @@
+{
+ "name": "lrdf",
+ "rm-configure": true,
+ "cleanup": [
+ "/include",
+ "/lib/pkgconfig",
+ "*.so"
+ ],
+ "config-opts": [
+ "--disable-static"
+ ],
+ "modules": [
+ "ladspa.json",
+ {
+ "name": "raptor2",
+ "cleanup": [
+ "/include",
+ "/lib/pkgconfig",
+ "/share/gtk-doc",
+ "*.so"
+ ],
+ "config-opts": [
+ "--disable-documentation",
+ "--disable-static"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "http://download.librdf.org/source/raptor2-2.0.15.tar.gz",
+ "sha256": "ada7f0ba54787b33485d090d3d2680533520cd4426d2f7fb4782dd4a6a1480ed"
+ }
+ ]
+ }
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://github.com/swh/LRDF/tarball/0.5.0",
+ "dest-filename": "swh-LRDF-0.5.0-0-g7ebc032.tar.gz",
+ "sha256": "013002b91ef209827fe99552b8c7f0b569cddb3d6f1439bedbd8bafe1956a93c"
+ },
+ {
+ "type": "script",
+ "commands": [
+ "autoreconf -fiv"
+ ],
+ "dest-filename": "autogen.sh"
+ }
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/lv2.json b/subprojects/shared-modules/linux-audio/lv2.json
new file mode 100644
index 00000000..5cf5a67c
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/lv2.json
@@ -0,0 +1,26 @@
+{
+ "name": "lv2",
+ "buildsystem": "simple",
+ "build-commands": [
+ "python3 ./waf configure --prefix=$FLATPAK_DEST --lv2dir=$FLATPAK_DEST/lib/lv2 --copy-headers",
+ "python3 ./waf build -j $FLATPAK_BUILDER_N_JOBS",
+ "python3 ./waf install"
+ ],
+ "cleanup": [
+ "/bin",
+ "/include",
+ "/lib/pkgconfig",
+ "/share"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "https://lv2plug.in/spec/lv2-1.18.2.tar.bz2",
+ "sha256": "4e891fbc744c05855beb5dfa82e822b14917dd66e98f82b8230dbd1c7ab2e05e"
+ }
+ ],
+ "post-install": [
+ "install -Dm644 -t $FLATPAK_DEST/share/licenses/lv2 COPYING",
+ "ln -sf lv2.pc $FLATPAK_DEST/lib/pkgconfig/lv2core.pc"
+ ]
+}
diff --git a/subprojects/shared-modules/linux-audio/patches/lash-0.5.3-no-static-lib.patch b/subprojects/shared-modules/linux-audio/patches/lash-0.5.3-no-static-lib.patch
new file mode 100644
index 00000000..54d1cd7b
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/patches/lash-0.5.3-no-static-lib.patch
@@ -0,0 +1,10 @@
+--- lash-1.0.pc.in~ 2007-10-07 06:33:27.000000000 -0700
++++ lash-1.0.pc.in 2007-10-07 06:35:00.000000000 -0700
+@@ -7,6 +7,5 @@
+ Description: Audio session management
+ Requires: @PC_REQUIRES@
+ Version: @PACKAGE_VERSION@
+-Libs: -llash
+-Libs.static: -lpthread -luuid
++Libs: -llash -lpthread -luuid
+ Cflags: -I${includedir}/lash-1.0
diff --git a/subprojects/shared-modules/linux-audio/patches/lash-configure.patch b/subprojects/shared-modules/linux-audio/patches/lash-configure.patch
new file mode 100644
index 00000000..ba9bb8ba
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/patches/lash-configure.patch
@@ -0,0 +1,11 @@
+--- configure.ac 2007-11-14 16:58:51.000000000 -0500
++++ configure.ac.new 2019-01-24 13:48:46.284377086 -0500
+@@ -2,7 +2,7 @@
+ AC_CONFIG_SRCDIR([lash/types.h])
+ AC_CONFIG_HEADER([config.h])
+ AM_INIT_AUTOMAKE
+-AM_ACLOCAL_INCLUDE([m4])
++dnl AM_ACLOCAL_INCLUDE([m4])
+
+ ### Check for programs ###
+ AC_LANG([C])
diff --git a/subprojects/shared-modules/linux-audio/patches/lash-gcc47.patch b/subprojects/shared-modules/linux-audio/patches/lash-gcc47.patch
new file mode 100644
index 00000000..41710ca5
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/patches/lash-gcc47.patch
@@ -0,0 +1,11 @@
+diff -rupN lash-0.5.4.old/liblash/lash.c lash-0.5.4/liblash/lash.c
+--- lash-0.5.4.old/liblash/lash.c 2007-03-09 10:34:40.000000000 -0500
++++ lash-0.5.4/liblash/lash.c 2012-07-22 18:17:46.003963521 -0400
+@@ -22,6 +22,7 @@
+ #include <string.h>
+ #include <strings.h>
+ #include <pthread.h>
++#include <sys/resource.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <sys/socket.h>
diff --git a/subprojects/shared-modules/linux-audio/patches/lash-linking.patch b/subprojects/shared-modules/linux-audio/patches/lash-linking.patch
new file mode 100644
index 00000000..e46d1647
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/patches/lash-linking.patch
@@ -0,0 +1,90 @@
+diff -rupN lash-0.5.4.old/clients/control/Makefile.am lash-0.5.4/clients/control/Makefile.am
+--- lash-0.5.4.old/clients/control/Makefile.am 2007-01-13 13:20:03.000000000 -0500
++++ lash-0.5.4/clients/control/Makefile.am 2010-02-10 03:08:04.000000000 -0500
+@@ -18,6 +18,6 @@ lash_control_CFLAGS = $(LASH_CFLAGS)
+
+ lash_control_LDADD = \
+ $(top_builddir)/liblash/liblash.la \
+- $(LASH_LIBS) @READLINE_LIBS@
++ $(LASH_LIBS) @READLINE_LIBS@ -luuid
+
+ endif
+diff -rupN lash-0.5.4.old/clients/control/Makefile.in lash-0.5.4/clients/control/Makefile.in
+--- lash-0.5.4.old/clients/control/Makefile.in 2007-11-14 17:00:09.000000000 -0500
++++ lash-0.5.4/clients/control/Makefile.in 2010-02-10 03:09:26.000000000 -0500
+@@ -236,7 +236,7 @@ AM_CPPFLAGS = -I$(top_srcdir)
+ @HAVE_READLINE_TRUE@lash_control_CFLAGS = $(LASH_CFLAGS)
+ @HAVE_READLINE_TRUE@lash_control_LDADD = \
+ @HAVE_READLINE_TRUE@ $(top_builddir)/liblash/liblash.la \
+-@HAVE_READLINE_TRUE@ $(LASH_LIBS) @READLINE_LIBS@
++@HAVE_READLINE_TRUE@ $(LASH_LIBS) @READLINE_LIBS@ -luuid
+
+ all: all-am
+
+diff -rupN lash-0.5.4.old/clients/panel/Makefile.am lash-0.5.4/clients/panel/Makefile.am
+--- lash-0.5.4.old/clients/panel/Makefile.am 2005-09-13 01:22:59.000000000 -0400
++++ lash-0.5.4/clients/panel/Makefile.am 2010-02-10 03:17:10.000000000 -0500
+@@ -13,7 +13,7 @@ lash_panel_CFLAGS = \
+
+ lash_panel_LDADD = \
+ $(top_builddir)/liblash/liblash.la \
+- $(GTK2_LIBS)
++ $(GTK2_LIBS) -luuid
+
+ if HAVE_GTK2
+ bin_PROGRAMS = lash_panel
+diff -rupN lash-0.5.4.old/clients/panel/Makefile.in lash-0.5.4/clients/panel/Makefile.in
+--- lash-0.5.4.old/clients/panel/Makefile.in 2007-11-14 17:00:09.000000000 -0500
++++ lash-0.5.4/clients/panel/Makefile.in 2010-02-10 03:17:23.000000000 -0500
+@@ -230,7 +230,7 @@ lash_panel_CFLAGS = \
+
+ lash_panel_LDADD = \
+ $(top_builddir)/liblash/liblash.la \
+- $(GTK2_LIBS)
++ $(GTK2_LIBS) -luuid
+
+ all: all-am
+
+diff -rupN lash-0.5.4.old/clients/synth/Makefile.am lash-0.5.4/clients/synth/Makefile.am
+--- lash-0.5.4.old/clients/synth/Makefile.am 2005-09-13 01:22:59.000000000 -0400
++++ lash-0.5.4/clients/synth/Makefile.am 2010-02-10 03:22:39.000000000 -0500
+@@ -20,4 +20,4 @@ lash_synth_LDADD = \
+ $(JACK_LIBS) \
+ $(ALSA_LIBS) \
+ $(GTK2_LIBS) \
+- -lpthread
++ -lpthread -lm
+diff -rupN lash-0.5.4.old/clients/synth/Makefile.in lash-0.5.4/clients/synth/Makefile.in
+--- lash-0.5.4.old/clients/synth/Makefile.in 2007-11-14 17:00:10.000000000 -0500
++++ lash-0.5.4/clients/synth/Makefile.in 2010-02-10 03:22:51.000000000 -0500
+@@ -238,7 +238,7 @@ lash_synth_LDADD = \
+ $(JACK_LIBS) \
+ $(ALSA_LIBS) \
+ $(GTK2_LIBS) \
+- -lpthread
++ -lpthread -lm
+
+ all: all-am
+
+diff -rupN lash-0.5.4.old/lashd/Makefile.am lash-0.5.4/lashd/Makefile.am
+--- lash-0.5.4.old/lashd/Makefile.am 2006-09-16 16:27:46.000000000 -0400
++++ lash-0.5.4/lashd/Makefile.am 2010-07-23 15:13:59.000000000 -0400
+@@ -32,6 +32,7 @@ lashd_LDADD = \
+ $(ALSA_LIBS) \
+ $(XML2_LIBS) \
+ $(UUID_LIBS) \
++ -lpthread \
+ $(top_builddir)/liblash/liblash.la
+
+ lashd_CFLAGS = \
+diff -rupN lash-0.5.4.old/lashd/Makefile.in lash-0.5.4/lashd/Makefile.in
+--- lash-0.5.4.old/lashd/Makefile.in 2007-11-14 17:00:10.000000000 -0500
++++ lash-0.5.4/lashd/Makefile.in 2010-07-23 15:14:29.000000000 -0400
+@@ -262,6 +262,7 @@ lashd_LDADD = \
+ $(ALSA_LIBS) \
+ $(XML2_LIBS) \
+ $(UUID_LIBS) \
++ -lpthread \
+ $(top_builddir)/liblash/liblash.la
+
+ lashd_CFLAGS = \
diff --git a/subprojects/shared-modules/linux-audio/patches/stk-install.sh b/subprojects/shared-modules/linux-audio/patches/stk-install.sh
new file mode 100644
index 00000000..e2d9c9b7
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/patches/stk-install.sh
@@ -0,0 +1,54 @@
+
+INCLUDE_DIR=/app/include
+DATA_DIR=/app/share
+LIB_DIR=/app/lib
+BIN_DIR=/app/bin
+
+
+
+
+install -Dm644 -t $INCLUDE_DIR/stk include/*
+install -Dm644 -t $LIB_DIR src/libstk.*
+install -Dm644 -t $DATA_DIR/stk/rawwaves rawwaves/*.raw
+
+#cp -pr projects/demo/tcl $DATA_DIR/stk/demo
+#cp -pr projects/demo/scores $DATA_DIR/stk/demo
+#cp -p projects/demo/demo $BIN_DIR/stk-demo
+#cp -p projects/demo/Md2Skini $BIN_DIR/Md2Skini
+#for f in Banded Drums Modal Physical Shakers StkDemo Voice ; do
+# chmod +x projects/demo/$f
+# sed -e 's,\./demo,$BIN_DIR/stk-demo,' -e '1i#! /bin/sh' \
+# -i projects/demo/$f
+# cp -p projects/demo/$f $DATA_DIR/stk/demo
+#done
+
+#cp -pr projects/examples/midifiles $DATA_DIR/stk/examples
+#cp -pr projects/examples/rawwaves $DATA_DIR/stk/examples
+#cp -pr projects/examples/scores $DATA_DIR/stk/examples
+#for f in sine sineosc foursine audioprobe midiprobe duplex play \
+# record inetIn inetOut rtsine crtsine bethree controlbee \
+# threebees playsmf grains ; do
+# cp -p projects/examples/$f $BIN_DIR/stk-$f
+# # absolute links, will be shortened later
+# ln -s $BIN_DIR/stk-$f $DATA_DIR/stk/examples/$f
+#done
+
+install -Dm644 -t $DATA_DIR/stk/effects projects/effects/tcl
+install -Dm644 -t $BIN_DIR/stk-effects projects/effects/effects
+sed -e 's,\./effects,$BIN_DIR/stk-effects,' -e '1i#! /bin/sh' \
+ -i projects/effects/StkEffects
+install -Dm644 -t $DATA_DIR/stk/effects projects/effects/StkEffects
+
+install -Dm644 -t $DATA_DIR/stk/ragamatic projects/ragamatic/tcl
+install -Dm644 -t $DATA_DIR/stk/ragamatic projects/ragamatic/rawwaves
+install -Dm644 -t $BIN_DIR/stk-ragamat projects/ragamatic/ragamat
+sed -e 's,\./ragamat,$BIN_DIR/stk-ragamat,' -e '1i#! /bin/sh' \
+ -i projects/ragamatic/Raga
+install -Dm644 -t $DATA_DIR/stk/ragamatic projects/ragamatic/Raga
+
+install -Dm644 -t $DATA_DIR/stk/eguitar projects/eguitar/tcl
+install -Dm644 -t $DATA_DIR/stk/eguitar projects/eguitar/scores
+install -Dm644 -t $BIN_DIR/stk-eguitar projects/eguitar/eguitar
+sed -e 's,\./eguitar,$BIN_DIR/stk-eguitar,' -e '1i#! /bin/sh' \
+ -i projects/eguitar/ElectricGuitar
+install -Dm644 -t $DATA_DIR/stk/eguitar projects/eguitar/ElectricGuitar
diff --git a/subprojects/shared-modules/linux-audio/stk.json b/subprojects/shared-modules/linux-audio/stk.json
new file mode 100644
index 00000000..cf4d8f93
--- /dev/null
+++ b/subprojects/shared-modules/linux-audio/stk.json
@@ -0,0 +1,28 @@
+{
+ "name": "stk",
+ "build-commands": [
+ "make -j $FLATPAK_BUILDER_N_JOBS -C src",
+ "make -j $FLATPAK_BUILDER_N_JOBS -C projects/effects libeffects",
+ "make -j $FLATPAK_BUILDER_N_JOBS -C projects/ragamatic libragamat",
+ "make -j $FLATPAK_BUILDER_N_JOBS -C projects/eguitar libeguitar"
+ ],
+ "post-install": [
+ "sh ./stk-install.sh"
+ ],
+ "cleanup": [
+ "/bin/*",
+ "/include",
+ "*.a"
+ ],
+ "sources": [
+ {
+ "type": "archive",
+ "url": "http://ccrma.stanford.edu/software/stk/release/stk-4.6.1.tar.gz",
+ "sha256": "e77ba3c80cdd93ca02c34098b9b7f918df3d648c87f1ed5d94fe854debd6d101"
+ },
+ {
+ "type": "file",
+ "path": "patches/stk-install.sh"
+ }
+ ]
+}