summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2019-02-25 15:16:09 +0000
committerSimon McVittie <smcv@debian.org>2019-07-15 09:59:47 +0100
commit3604aefeb87a06f0bec880384492f7c18b5626bf (patch)
tree9803b1564b918cd0009e435eda2003987ec644ea /Makefile
parent355180f14ed94eef80aa10e716e01df2df2c084b (diff)
Add a build system for gschemas.compiled
Instead of including it in the git repository, build it from its source code (the XML) as needed. This commit also adds brief installation instructions, and a convenience target to generate new release zip files. Signed-off-by: Simon McVittie <smcv@debian.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..b34acee
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+# Copyright 2019 Simon McVittie
+# SPDX-License-Identifier: GPL-2.0-or-later
+# (see extension.js for details)
+
+all:
+ glib-compile-schemas --strict --targetdir=schemas schemas
+
+dist: all
+ zip gnome-bluetooth-quick-connect.zip -9r *
+
+clean:
+ rm -fr gnome-bluetooth-quick-connect.zip schemas/gschemas.compiled
+
+.PHONY: all clean dist