summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <rra@debian.org>2013-09-14 13:32:35 -0700
committerRuss Allbery <rra@debian.org>2013-09-14 13:32:35 -0700
commit19a4a81badf6373c7259ca4c229a529be6e9a93f (patch)
tree9216fe5d7a1e88fbca6f376aa4bc38953df33a23 /configure.ac
parent02afa49ca106bbd29895a61ce16c110d3d819b3d (diff)
Imported Upstream version 1.02.000
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac51
1 files changed, 43 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 3e9d828..76cb001 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,12 +18,12 @@ dnl You should have received a copy of the GNU General Public License
dnl along with this program; if not, write to the Free Software
dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-AC_REVISION($Revision: 1.22 $)
-AC_INIT([GNU Backgammon],m4_esyscmd(echo 1.01.0$VERSION_EXT | tr -d '\n'),[bug-gnubg@gnu.org],[gnubg])
+AC_REVISION($Revision: 1.28 $)
+AC_INIT([GNU Backgammon],m4_esyscmd(echo 1.02.000$VERSION_EXT | tr -d '\n'),[bug-gnubg@gnu.org],[gnubg])
AC_CANONICAL_BUILD
AC_CANONICAL_HOST
AC_CONFIG_SRCDIR(gnubg.c)
-AM_INIT_AUTOMAKE
+AM_INIT_AUTOMAKE([subdir-objects])
AC_CONFIG_HEADERS([config.h])
dnl
@@ -353,12 +353,12 @@ AX_EXT()
AC_MSG_CHECKING([for SIMD CPU instructions])
AC_ARG_ENABLE( simd, [ --enable-simd=TYPE enable SIMD usage for newer cpus(TYPE=yes,avx,sse2,no)], simdcpu=$enableval, simdcpu="undef")
if test "x$simdcpu" = "xundef" || test "x$simdcpu" = "xyes"; then
- if test "x$ax_cv_have_sse2_ext" = "xyes"; then
+ if test "x$ax_cv_have_avx_ext" = "xyes"; then
+ simdcpu="avx"
+ elif test "x$ax_cv_have_sse2_ext" = "xyes"; then
simdcpu="sse2"
elif test "x$ax_cv_have_sse_ext" = "xyes"; then
simdcpu="sse"
- elif test "x$ax_cv_have_avx_ext" = "xyes"; then
- simdcpu="avx"
else
simdcpu="no"
fi
@@ -456,11 +456,46 @@ if test "x$simdcpu" = "xavx" && test "x$win32" = "xyes" ; then
AM_CFLAGS="$AM_CFLAGS"
fi
-AC_SUBST(AM_CFLAGS)
+dnl
+dnl Check for program to open browser
+dnl
+
+if test x"$win32" == x"no"; then
+ AC_CHECK_PROGS([DEFAULT_WWW_PROG], [sensible-browser xdg-open firefox], [xdg-open])
+ AC_MSG_CHECKING([for program to open URLs])
+ AC_ARG_WITH([default_browser],
+ AC_HELP_STRING([--with-default-browser=program],
+ [specify the program to open URLs: (default=xdg-open, or default=sensible-browser on Debian distros)]),
+ [
+ if [test x"$with_default_browser" == x"no"]; then
+ OPENWWW_PROG="xdg-open"
+ elif [test x"$with_default_browser" == x"yes"]; then
+ OPENWWW_PROG="$DEFAULT_WWW_PROG"
+ else
+ OPENWWW_PROG="$with_default_browser"
+ fi
+ ],
+ [
+ OPENWWW_PROG="$DEFAULT_WWW_PROG"
+ ])
+ AC_DEFINE_UNQUOTED(OPEN_URL_PROG, "$OPENWWW_PROG", [program to open URLs])
+ AC_MSG_RESULT($OPENWWW_PROG)
+else
+ AC_DEFINE_UNQUOTED(OPEN_URL_PROG, "", [program to open URLs])
+fi
+AC_MSG_CHECKING([whether g_asserts are enabled])
+AC_ARG_ENABLE([gasserts],
+ AC_HELP_STRING([--enable-gasserts], [enable g_assert debugging macros (Default disabled)]), [gasserts="yes"], [gasserts="no"])
+if test x"$enable_gasserts" != x"yes"; then
+ AM_CFLAGS="$AM_CFLAGS -DG_DISABLE_ASSERT"
+fi
+AS_IF( [test x"$enable_gasserts" != x"yes"], [AC_MSG_RESULT($gasserts)], [AC_MSG_RESULT(yes)] )
+
+AC_SUBST(AM_CFLAGS)
dnl *************
-dnl Misc. setings
+dnl Misc. settings
dnl *************
dnl internationalization macros