summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <rra@debian.org>2018-08-26 13:54:38 -0700
committerRuss Allbery <rra@debian.org>2018-08-26 13:54:38 -0700
commit2fe573a289fdde28261ad714cfed7e2e10c7817d (patch)
tree5117718710b779300e8d3741936a1f7b5740c3f4 /configure.ac
parent89adbd59353dd3a0944de2c86288976329f2b1dc (diff)
New upstream version 1.06.002
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac52
1 files changed, 22 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index b17209c..ae9e981 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,8 +17,8 @@ dnl You should have received a copy of the GNU General Public License
dnl along with this program; if not, write to the Free Software
dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-AC_REVISION($Revision: 1.78 $)
-AC_INIT([GNU Backgammon],m4_esyscmd(echo 1.06.001$VERSION_EXT | tr -d '\n'),[bug-gnubg@gnu.org],[gnubg])
+AC_REVISION($Revision: 1.86 $)
+AC_INIT([GNU Backgammon],m4_esyscmd(echo 1.06.002$VERSION_EXT | tr -d '\n'),[bug-gnubg@gnu.org],[gnubg])
AC_CANONICAL_BUILD
AC_CANONICAL_HOST
AC_CONFIG_SRCDIR(gnubg.c)
@@ -37,6 +37,11 @@ dnl
dnl host specifics
dnl
+dnl Only relevant for win32 but the macro has to be executed unconditionally
+dnl -Wl since libtool uses gcc as linker
+dnl
+AX_APPEND_LINK_FLAGS([-Wl,--large-address-aware],,,)
+
win32=no
AC_MSG_CHECKING([for host])
@@ -44,7 +49,7 @@ case "$host" in
*-*-mingw*)
win32=yes
CFLAGS="$CFLAGS -mms-bitfields"
- LDFLAGS="$LDFLAGS -lws2_32 -lwinmm"
+ LDFLAGS="$LDFLAGS -lws2_32 -lwinmm"
;;
*-*-darwin*)
darwin=yes
@@ -220,7 +225,9 @@ dnl have_gthread, have_gtk and have_gtk are handled later, not having glib is fa
AX_C___ATTRIBUTE__()
if test "x$ax_cv___attribute__" = "xyes"; then
+AX_GCC_FUNC_ATTRIBUTE(fallthrough)
AX_GCC_FUNC_ATTRIBUTE(format)
+AX_GCC_FUNC_ATTRIBUTE(returns_nonnull)
AX_GCC_FUNC_ATTRIBUTE(unused)
fi
@@ -340,7 +347,7 @@ fi
AC_CHECK_HEADERS(GL/glx.h)
if test "$with_board3d" != "no" && test "$with_gtk" != "no" && test "x$have_gtk" = "xyes" && test "x$have_gtkglext" = "xyes" -a "x$have_glu" = "xyes"; then
- AC_DEFINE(USE_BOARD3D,1, [Define if you want to use the 3d boards])
+ AC_DEFINE(USE_BOARD3D,1, [Define if you want to use the 3D boards])
no_board3d="no"
fi
@@ -400,7 +407,7 @@ dnl
AX_EXT()
AC_MSG_CHECKING([for SIMD CPU instructions])
-AC_ARG_ENABLE( simd, [ --enable-simd=TYPE enable SIMD usage for newer cpus(TYPE=yes,fma,avx,sse2,no)], simdcpu=$enableval, simdcpu="undef")
+AC_ARG_ENABLE( simd, [ --enable-simd=TYPE enable SIMD usage for newer cpus(TYPE=yes,fma,avx,sse2,neon,no)], simdcpu=$enableval, simdcpu="undef")
if test "x$simdcpu" = "xundef" || test "x$simdcpu" = "xyes"; then
if test "x$ax_cv_have_fma_ext" = "xyes"; then
simdcpu="fma"
@@ -410,6 +417,9 @@ if test "x$simdcpu" = "xundef" || test "x$simdcpu" = "xyes"; then
simdcpu="sse2"
elif test "x$ax_cv_have_sse_ext" = "xyes"; then
simdcpu="sse"
+# not yet
+# elif test "x$ax_cv_have_neon_ext" = "xyes"; then
+# simdcpu="neon"
else
simdcpu="no"
fi
@@ -427,6 +437,9 @@ if test "x$simdcpu" != "xno"; then
if test "x$simdcpu" = "xsse2"; then
AC_DEFINE(USE_SSE2, 1, Define if you want to compile with SSE2 support)
fi
+ if test "x$simdcpu" = "xneon"; then
+ AC_DEFINE(USE_NEON, 1, Define if you want to compile with NEON support)
+ fi
if test x"$GCC" = "xyes"; then
if test "x$SIMD_CFLAGS" = x; then
if test "x$simdcpu" = "xfma"; then
@@ -435,6 +448,8 @@ if test "x$simdcpu" != "xno"; then
SIMD_CFLAGS="-mavx"
elif test "x$simdcpu" = "xsse2"; then
SIMD_CFLAGS="-msse -msse2"
+ elif test "x$simdcpu" = "xneon"; then
+ SIMD_CFLAGS="-mfpu=neon"
else
SIMD_CFLAGS="-msse"
fi
@@ -465,34 +480,11 @@ dnl
dnl Threads
dnl
-AC_MSG_CHECKING([for threading])
-AC_ARG_ENABLE( threads, [ --enable-threads=TYPE enable multithread support (TYPE=yes,glib,win32,no) (Default glib)], threads=$enableval, threads="glib")
+AC_MSG_CHECKING([for multithread support])
+AC_ARG_ENABLE(threads, [ --enable-threads enable multithread support (Default yes)], threads=$enableval, threads="yes")
AM_CONDITIONAL(USE_MULTITHREAD, test "x$enable_threads" != "xno" )
-if test "x$enable_threads" = "xyes"; then
- threads=glib
-fi
if test "x$enable_threads" != "xno"; then
- if test "x$have_gthread" != "xyes" && test "x$win32" != "xno" ; then
- threads=win32
- fi
- if test "x$have_gthread" != "xyes" && test "x$win32" != "xyes"; then
- AC_MSG_ERROR([Threads enabled but glib doesn't seem to have gthread support])
- fi
- if test "x$enable_threads" = "xwin32" && test "x$win32" != "xyes" ; then
- AC_MSG_ERROR([Win32 Threads only available on Win32 platforms])
- fi
-
AC_DEFINE(USE_MULTITHREAD, 1, Define if you want to have multithread support)
- case "$threads" in
- glib )
- AC_DEFINE(GLIB_THREADS, 1, Define if you wish to use glib threads)
- ;;
- win32 )
- ;;
- *)
- AC_MSG_ERROR([Thread type $threads unsupported])
- ;;
- esac
fi
AS_IF( [test "x$enable_threads" != "xno"], [AC_MSG_RESULT($threads)], [AC_MSG_RESULT(no)] )