summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <rra@debian.org>2014-10-26 13:53:29 -0700
committerRuss Allbery <rra@debian.org>2014-10-26 13:53:29 -0700
commit4fc50f48fa6f878421fed91d30f54520edfb384f (patch)
treee952be4793061ac23c2eb98395e806829d2bfb36 /configure.ac
parent89685066474290e1fae4a78c268c8f68f1f4fba3 (diff)
Imported Upstream version 1.04.000
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 6 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index f7948e1..a0473ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,8 +18,8 @@ dnl You should have received a copy of the GNU General Public License
dnl along with this program; if not, write to the Free Software
dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-AC_REVISION($Revision: 1.39 $)
-AC_INIT([GNU Backgammon],m4_esyscmd(echo 1.03.001$VERSION_EXT | tr -d '\n'),[bug-gnubg@gnu.org],[gnubg])
+AC_REVISION($Revision: 1.44 $)
+AC_INIT([GNU Backgammon],m4_esyscmd(echo 1.04.000$VERSION_EXT | tr -d '\n'),[bug-gnubg@gnu.org],[gnubg])
AC_CANONICAL_BUILD
AC_CANONICAL_HOST
AC_CONFIG_SRCDIR(gnubg.c)
@@ -257,14 +257,6 @@ dnl
AC_C_INLINE
AC_TYPE_SIZE_T
-# Check for __builtin_expect()
-AC_MSG_CHECKING([for __builtin_expect()])
-AC_LINK_IFELSE([AC_LANG_PROGRAM(, return __builtin_expect(main != 0, 1))],
- [AC_DEFINE(HAVE_BUILTIN_EXPECT, 1,
- Define to 1 if compiler supports __builtin_expect)
- AC_MSG_RESULT([yes])],
- [AC_MSG_RESULT([no])])
-
dnl
dnl Checks for library functions.
dnl
@@ -273,11 +265,12 @@ AC_CHECK_FUNCS(sigaction sigvec,break)
AC_CHECK_FUNCS(strptime random setpriority)
AC_CHECK_FUNCS(mtrace)
-dnl
-dnl Checks for declarations
+dnl
+dnl Checks for compiler builtins
dnl
-AC_CHECK_DECLS([signbit], , , [#include <math.h>])
+AX_GCC_BUILTIN(__builtin_clz)
+AX_GCC_BUILTIN(__builtin_expect)
dnl *******************
dnl optional components