summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRuss Allbery <rra@debian.org>2010-01-18 00:06:22 -0800
committerRuss Allbery <rra@debian.org>2010-01-18 12:10:57 -0800
commit32b754136270bbf3d8149f0ce58ea137b0bd6272 (patch)
tree0fd73130401dcfa4df8f2c93873a35620741f23e /debian/rules
parent16148b2b2045e4f0e2463f78619032d16be81db9 (diff)
Disable SSE on ia64
* Disable SSE on ia64. Although the upstream configure script thinks it should work, gcc on ia64 does not appear to support the -msse or -msse2 options.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 12 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 54f3aac..b2c339f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,6 +10,16 @@ DATE = $(shell echo "$(VERSION)" | cut -d+ -f2)
URL = http://www.gnubg.org/media/sources/
FILE = gnubg-source-SNAPSHOT-$(DATE).tar.gz
+# Only build with SSE on amd64. We can't assume that processor for i386,
+# and it fails to build on ia64 since GCC there doesn't support -msse or
+# -msse2 (as of 2010-01-17).
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+ifeq ($(DEB_HOST_ARCH),amd64)
+ SSE = --enable-sse
+else
+ SSE = --disable-sse
+endif
+
# Download the upstream source and clean out the CVS subdirectories and
# corecount.c, which is not under a free license.
get-orig-source:
@@ -29,7 +39,8 @@ get-orig-source:
override_dh_auto_configure:
autoreconf -i --force
env LDFLAGS=-Wl,--as-needed dh_auto_configure -- --with-gtk \
- --with-board3d --with-sqlite --with-python --enable-threads
+ --with-board3d --with-sqlite --with-python --enable-threads \
+ $(SSE)
# Disable building the two-sided rollout database during the build. It
# takes too long and is too large. We'll instead build it during