summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHilko Bengen <bengen@debian.org>2017-08-02 22:03:56 +0200
committerHilko Bengen <bengen@debian.org>2017-08-02 22:23:10 +0200
commit4f860a7c2660a9861324dac3d195982c926c59f9 (patch)
treed6223cdfb1d810a2b064dbe89e2d7e723abbbbd4
parentbf9ce4c27346c921b8b70b9650bc74e77a9ff00e (diff)
Modernize package, switch to elpa
-rw-r--r--debian/compat2
-rw-r--r--debian/control28
-rw-r--r--debian/elpa-go-mode.elpa1
-rw-r--r--debian/emacsen-compat1
-rwxr-xr-xdebian/emacsen-install52
-rwxr-xr-xdebian/emacsen-remove21
-rw-r--r--debian/emacsen-startup25
-rw-r--r--debian/install1
-rwxr-xr-xdebian/rules30
-rw-r--r--debian/watch2
10 files changed, 24 insertions, 139 deletions
diff --git a/debian/compat b/debian/compat
index ec63514..f599e28 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/debian/control b/debian/control
index b12109a..467569a 100644
--- a/debian/control
+++ b/debian/control
@@ -1,17 +1,29 @@
Source: go-mode.el
-Section: editors
+Section: lisp
Priority: optional
Maintainer: Hilko Bengen <bengen@debian.org>
-Build-Depends: debhelper (>= 9)
-Standards-Version: 3.9.8
+Build-Depends: debhelper (>= 10), dh-elpa,
+Standards-Version: 4.0.0
Homepage: https://github.com/dominikh/go-mode.el
Vcs-Git: git://anonscm.debian.org/collab-maint/go-mode.el.git
Vcs-Browser: http://anonscm.debian.org/?p=collab-maint/go-mode.el.git;a=summary
-Package: golang-mode
+Package: elpa-go-mode
Architecture: all
-Depends: emacs | emacsen, emacsen-common (>= 2.0.8),
- ${shlibs:Depends}, ${misc:Depends},
-Description: Go programming language - mode for GNU Emacs
+Depends: ${elpa:Depends}, ${misc:Depends},
+Built-Using: ${misc:Built-Using}
+Replaces: golang-mode (<< 1.5.0)
+Breaks: golang-mode (<< 1.5.0)
+Recommends: golang-golang-x-tools
+Description: Emacs mode for editing Go code
This package provides a GNU Emacs major mode for editing code in
- Google's Go programming language.
+ the Go programming language.
+
+Package: golang-mode
+Architecture: all
+Section: oldlibs
+Priority: extra
+Depends: ${misc:Depends}, elpa-go-mode
+Description: Emacs mode for editing Go code -- transitional package
+ This is a transitional package for elpa-go-mode and can be safely
+ removed after installation.
diff --git a/debian/elpa-go-mode.elpa b/debian/elpa-go-mode.elpa
new file mode 100644
index 0000000..abf136d
--- /dev/null
+++ b/debian/elpa-go-mode.elpa
@@ -0,0 +1 @@
+*.el
diff --git a/debian/emacsen-compat b/debian/emacsen-compat
deleted file mode 100644
index 573541a..0000000
--- a/debian/emacsen-compat
+++ /dev/null
@@ -1 +0,0 @@
-0
diff --git a/debian/emacsen-install b/debian/emacsen-install
deleted file mode 100755
index d529abf..0000000
--- a/debian/emacsen-install
+++ /dev/null
@@ -1,52 +0,0 @@
-#! /bin/sh -e
-# /usr/lib/emacsen-common/packages/install/golang-mode
-
-# Written by Jim Van Zandt <jrv@debian.org>, borrowing heavily
-# from the install scripts for gettext by Santiago Vila
-# <sanvila@ctv.es> and octave by Dirk Eddelbuettel <edd@debian.org>.
-
-FLAVOR=$1
-PACKAGE=golang-mode
-
-# A number of old emacs versions are not supported by upstream:
-case $FLAVOR in
- emacs|emacs19|emacs20|emacs21|emacs22|emacs23|xemacs21)
- exit 0
- ;;
-esac
-
-echo install/${PACKAGE}: Handling install for emacsen flavor ${FLAVOR}
-
-#FLAVORTEST=`echo $FLAVOR | cut -c-6`
-#if [ ${FLAVORTEST} = xemacs ] ; then
-# SITEFLAG="-no-site-file"
-#else
-# SITEFLAG="--no-site-file"
-#fi
-FLAGS="${SITEFLAG} -q -batch -l path.el -f batch-byte-compile"
-
-ELDIR=/usr/share/emacs/site-lisp/${PACKAGE}
-ELCDIR=/usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-ELRELDIR=../../../emacs/site-lisp/${PACKAGE}
-
-# Install-info-altdir does not actually exist.
-# Maybe somebody will write it.
-if test -x /usr/sbin/install-info-altdir; then
- echo install/${PACKAGE}: install Info links for ${FLAVOR}
- install-info-altdir --quiet --section "" "" --dirname=${FLAVOR} /usr/share/info/${PACKAGE}.info.gz
-fi
-
-install -m 755 -d ${ELCDIR}
-cd ${ELDIR}
-FILES=`echo *.el`
-cd ${ELCDIR}
-ln -sf ${ELRELDIR}/*.el .
-
-cat << EOF > path.el
-(debian-pkg-add-load-path-item ".")
-(setq byte-compile-warnings nil)
-EOF
-${FLAVOR} ${FLAGS} ${FILES}
-rm -f path.el
-
-exit 0
diff --git a/debian/emacsen-remove b/debian/emacsen-remove
deleted file mode 100755
index 7a3dce4..0000000
--- a/debian/emacsen-remove
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh -e
-# /usr/lib/emacsen-common/packages/remove/golang-mode
-
-FLAVOR=$1
-PACKAGE=golang-mode
-
-# A number of old emacs versions are not supported by upstream:
-case $FLAVOR in
- emacs|emacs19|emacs20|emacs21|emacs22|emacs23|xemacs21)
- exit 0
- ;;
- *)
- if test -x /usr/sbin/install-info-altdir; then
- echo remove/${PACKAGE}: removing Info links for ${FLAVOR}
- install-info-altdir --quiet --remove --dirname=${FLAVOR} /usr/share/info/golang-mode.info.gz
- fi
-
- echo remove/${PACKAGE}: purging byte-compiled files for ${FLAVOR}
- rm -rf /usr/share/${FLAVOR}/site-lisp/${PACKAGE}
- ;;
-esac
diff --git a/debian/emacsen-startup b/debian/emacsen-startup
deleted file mode 100644
index eda21dd..0000000
--- a/debian/emacsen-startup
+++ /dev/null
@@ -1,25 +0,0 @@
-;; -*-emacs-lisp-*-
-;;
-;; Emacs startup file, e.g. /etc/emacs/site-start.d/50golang-mode.el
-;; for the Debian golang-mode package
-;;
-;; Originally contributed by Nils Naumann <naumann@unileoben.ac.at>
-;; Modified by Dirk Eddelbuettel <edd@debian.org>
-;; Adapted for dh-make by Jim Van Zandt <jrv@debian.org>
-
-;; The golang-mode package follows the Debian/GNU Linux 'emacsen' policy and
-;; byte-compiles its elisp files for each 'emacs flavor' (emacs19,
-;; xemacs19, emacs20, xemacs20...). The compiled code is then
-;; installed in a subdirectory of the respective site-lisp directory.
-;; We have to add this to the load-path:
-(let ((package-dir (concat "/usr/share/"
- (symbol-name debian-emacs-flavor)
- "/site-lisp/golang-mode")))
-;; If package-dir does not exist, the golang-mode package must have
-;; removed but not purged, and we should skip the setup.
- (when (file-directory-p package-dir)
- (if (fboundp 'debian-pkg-add-load-path-item)
- (debian-pkg-add-load-path-item package-dir)
- (setq load-path (cons package-dir load-path)))
- (require 'go-mode-autoloads nil)))
-
diff --git a/debian/install b/debian/install
deleted file mode 100644
index 0333295..0000000
--- a/debian/install
+++ /dev/null
@@ -1 +0,0 @@
-*.el /usr/share/emacs/site-lisp/golang-mode
diff --git a/debian/rules b/debian/rules
index ce15cce..e8e22ba 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,32 +1,4 @@
#!/usr/bin/make -f
-# See debhelper(7) (uncomment to enable)
-# output every command that modifies files on the build system.
-#DH_VERBOSE = 1
-# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
-DPKG_EXPORT_BUILDFLAGS = 1
-include /usr/share/dpkg/default.mk
-
-# see FEATURE AREAS in dpkg-buildflags(1)
-#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-
-# see ENVIRONMENT in dpkg-buildflags(1)
-# package maintainers to append CFLAGS
-#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
-# package maintainers to append LDFLAGS
-#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
-
-
-# main packaging script based on dh7 syntax
%:
- dh $@
-
-# debmake generated override targets
-# This is example for Cmake (See http://bugs.debian.org/641051 )
-#override_dh_auto_configure:
-# dh_auto_configure -- \
-# -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)
-
-
-
-
+ dh $@ --with elpa
diff --git a/debian/watch b/debian/watch
index bf0c5e2..c7c7f16 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,2 +1,2 @@
version=3
-https://github.com/dominikh/go-mode.el/releases .*/archive/v(\d\..*)\.tar\.gz \ No newline at end of file
+https://github.com/dominikh/go-mode.el/releases .*/archive/v(\d\..*)\.tar\.gz