summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAlessio Treglia <alessio@debian.org>2012-05-27 11:22:52 +0200
committerAlessio Treglia <alessio@debian.org>2012-05-27 11:22:52 +0200
commit18c758e5c75b25c9c159e9247820375b5178783a (patch)
treec8acd392b4176793d3eef811735d9bb87fa3d85d /Makefile
parent09c1eee91febf291c5b8dec11978d1ac25ac22ee (diff)
Imported Upstream version 0.5.0~dfsg0
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 0d13ebb..13b2533 100644
--- a/Makefile
+++ b/Makefile
@@ -11,7 +11,7 @@ all: version
$(MAKE) -C modules all
version:
- @if which svnversion >/dev/null; then echo "#define GPAC_SVN_REVISION \"$(shell svnversion $(SRC_PATH) )\"" > $(SRC_PATH)/include/gpac/version.h ; else echo "No SVN Version found"; fi
+ @if [ -d ".svn" ]; then if which svnversion >/dev/null; then echo "#define GPAC_SVN_REVISION \"$(shell svnversion $(SRC_PATH) )\"" > $(SRC_PATH)/include/gpac/version.h ; else echo "No SVN Version found"; fi; fi
lib: version
$(MAKE) -C src all
@@ -60,7 +60,9 @@ install:
ifeq ($(DISABLE_ISOFF), no)
$(INSTALL) $(INSTFLAGS) -m 755 bin/gcc/MP4Box "$(DESTDIR)$(prefix)/bin"
endif
+ifeq ($(DISABLE_PLAYER), no)
$(INSTALL) $(INSTFLAGS) -m 755 bin/gcc/MP4Client "$(DESTDIR)$(prefix)/bin"
+endif
if [ -d $(DESTDIR)$(prefix)/$(libdir)/pkgconfig ] ; then \
$(INSTALL) $(INSTFLAGS) -m 644 gpac.pc "$(DESTDIR)$(prefix)/$(libdir)/pkgconfig" ; \
fi