summaryrefslogtreecommitdiff
path: root/DSL
diff options
context:
space:
mode:
authorChristian Perrier <bubulle@debian.org>2012-10-07 13:27:36 +0100
committerChristian Perrier <bubulle@debian.org>2012-10-07 13:27:36 +0100
commit99f5c8bf63a674faf8c507aea7425b935814548a (patch)
treeb3202c295c4bb71ec09e3748d49b43a9fec6b4cd /DSL
gpsdrive (2.10~pre4-6.dfsg-5.2) unstable; urgency=low
* Non-maintainer upload [ Allison Randal ] * Disable optional mapnik libraries, gpsdrive is incompatible with APIs of mapnik version 2.0.0. * debian/patches/107-fix-disable-mapnik.dpatch: Fix known bug with gpsdrive-2.10pre4 when disabling Mapnik library. # imported from the archive
Diffstat (limited to 'DSL')
-rw-r--r--DSL/Gpsdrive.gifbin0 -> 289 bytes
-rw-r--r--DSL/Gpsdrive.lnk9
-rw-r--r--DSL/Makefile.am10
-rw-r--r--DSL/Makefile.in414
-rw-r--r--DSL/README104
-rwxr-xr-xDSL/build-gpsdriveDB.sh76
-rwxr-xr-xDSL/build-mysql.sh197
-rwxr-xr-xDSL/build.sh68
-rwxr-xr-xDSL/package.sh176
9 files changed, 1054 insertions, 0 deletions
diff --git a/DSL/Gpsdrive.gif b/DSL/Gpsdrive.gif
new file mode 100644
index 0000000..0f190f1
--- /dev/null
+++ b/DSL/Gpsdrive.gif
Binary files differ
diff --git a/DSL/Gpsdrive.lnk b/DSL/Gpsdrive.lnk
new file mode 100644
index 0000000..40b23c5
--- /dev/null
+++ b/DSL/Gpsdrive.lnk
@@ -0,0 +1,9 @@
+table Icon
+ Type: Program
+ Caption: Gps Drive
+ Command: LD_LIBRARY_PATH=/opt/gpsdrive/lib /opt/gpsdrive/bin/gpsdrive
+ Icon: .xtdesktop/Gpsdrive.gif
+ X: 200
+ Y: 82
+ Status: anchor
+end
diff --git a/DSL/Makefile.am b/DSL/Makefile.am
new file mode 100644
index 0000000..c4fc29a
--- /dev/null
+++ b/DSL/Makefile.am
@@ -0,0 +1,10 @@
+# Makefile.am for DSL
+
+dsldir = $(datadir)/gpsdrive/DSL
+dsl_DATA= build.sh Gpsdrive.gif Gpsdrive.lnk Makefile.am package.sh README \
+ build-mysql.sh build-gpsdriveDB.sh
+
+
+
+EXTRA_DIST = $(dsl_DATA)
+
diff --git a/DSL/Makefile.in b/DSL/Makefile.in
new file mode 100644
index 0000000..1804d62
--- /dev/null
+++ b/DSL/Makefile.in
@@ -0,0 +1,414 @@
+# Makefile.in generated by automake 1.9.6 from Makefile.am.
+# @configure_input@
+
+# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
+# 2003, 2004, 2005 Free Software Foundation, Inc.
+# This Makefile.in is free software; the Free Software Foundation
+# gives unlimited permission to copy and/or distribute it,
+# with or without modifications, as long as this notice is preserved.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
+# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
+# PARTICULAR PURPOSE.
+
+@SET_MAKE@
+
+# Makefile.am for DSL
+
+srcdir = @srcdir@
+top_srcdir = @top_srcdir@
+VPATH = @srcdir@
+pkglibdir = $(libdir)/@PACKAGE@
+pkgincludedir = $(includedir)/@PACKAGE@
+top_builddir = ..
+am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
+INSTALL = @INSTALL@
+install_sh_DATA = $(install_sh) -c -m 644
+install_sh_PROGRAM = $(install_sh) -c
+install_sh_SCRIPT = $(install_sh) -c
+INSTALL_HEADER = $(INSTALL_DATA)
+transform = $(program_transform_name)
+NORMAL_INSTALL = :
+PRE_INSTALL = :
+POST_INSTALL = :
+NORMAL_UNINSTALL = :
+PRE_UNINSTALL = :
+POST_UNINSTALL = :
+build_triplet = @build@
+host_triplet = @host@
+subdir = DSL
+DIST_COMMON = README $(srcdir)/Makefile.am $(srcdir)/Makefile.in
+ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+am__aclocal_m4_deps = $(top_srcdir)/m4/ac_check_perl_modules.m4 \
+ $(top_srcdir)/m4/ac_check_socketlen_t.m4 \
+ $(top_srcdir)/m4/aq_check_gdal.m4 $(top_srcdir)/m4/gettext.m4 \
+ $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/lib-ld.m4 \
+ $(top_srcdir)/m4/lib-link.m4 $(top_srcdir)/m4/lib-prefix.m4 \
+ $(top_srcdir)/m4/nls.m4 $(top_srcdir)/m4/po.m4 \
+ $(top_srcdir)/m4/progtest.m4 $(top_srcdir)/configure.ac
+am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
+ $(ACLOCAL_M4)
+mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+CONFIG_HEADER = $(top_builddir)/config.h
+CONFIG_CLEAN_FILES =
+SOURCES =
+DIST_SOURCES =
+am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
+am__vpath_adj = case $$p in \
+ $(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
+ *) f=$$p;; \
+ esac;
+am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
+am__installdirs = "$(DESTDIR)$(dsldir)"
+dslDATA_INSTALL = $(INSTALL_DATA)
+DATA = $(dsl_DATA)
+DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+pkgdatadir = @pkgdatadir@
+ACLOCAL = @ACLOCAL@
+AMAPNIK = @AMAPNIK@
+AMDEP_FALSE = @AMDEP_FALSE@
+AMDEP_TRUE = @AMDEP_TRUE@
+AMTAR = @AMTAR@
+AR = @AR@
+AUTOCONF = @AUTOCONF@
+AUTOHEADER = @AUTOHEADER@
+AUTOMAKE = @AUTOMAKE@
+AWK = @AWK@
+CC = @CC@
+CCDEPMODE = @CCDEPMODE@
+CFLAGS = @CFLAGS@
+CPP = @CPP@
+CPPFLAGS = @CPPFLAGS@
+CXX = @CXX@
+CXXCPP = @CXXCPP@
+CXXDEPMODE = @CXXDEPMODE@
+CXXFLAGS = @CXXFLAGS@
+CYGPATH_W = @CYGPATH_W@
+DBUS_CFLAGS = @DBUS_CFLAGS@
+DBUS_GLIB_LIBS = @DBUS_GLIB_LIBS@
+DBUS_LIBS = @DBUS_LIBS@
+DEFS = @DEFS@
+DEPDIR = @DEPDIR@
+DISABLEGARMIN_FALSE = @DISABLEGARMIN_FALSE@
+DISABLEGARMIN_TRUE = @DISABLEGARMIN_TRUE@
+DISABLEPLUGINS_FALSE = @DISABLEPLUGINS_FALSE@
+DISABLEPLUGINS_TRUE = @DISABLEPLUGINS_TRUE@
+ECHO = @ECHO@
+ECHO_C = @ECHO_C@
+ECHO_N = @ECHO_N@
+ECHO_T = @ECHO_T@
+EGREP = @EGREP@
+EXEEXT = @EXEEXT@
+F77 = @F77@
+FFLAGS = @FFLAGS@
+FRIENDSSERVERVERSION = @FRIENDSSERVERVERSION@
+GDAL_CFLAGS = @GDAL_CFLAGS@
+GDAL_CONFIG = @GDAL_CONFIG@
+GDAL_LDADD = @GDAL_LDADD@
+GETTEXT_PACKAGE = @GETTEXT_PACKAGE@
+GLIB_CFLAGS = @GLIB_CFLAGS@
+GLIB_GENMARSHAL = @GLIB_GENMARSHAL@
+GLIB_LIBS = @GLIB_LIBS@
+GLIB_MKENUMS = @GLIB_MKENUMS@
+GMSGFMT = @GMSGFMT@
+GMSGFMT_015 = @GMSGFMT_015@
+GOBJECT_QUERY = @GOBJECT_QUERY@
+GREP = @GREP@
+GTK_CFLAGS = @GTK_CFLAGS@
+GTK_LIBS = @GTK_LIBS@
+HAVE_DBUS_FALSE = @HAVE_DBUS_FALSE@
+HAVE_DBUS_TRUE = @HAVE_DBUS_TRUE@
+HAVE_GDAL_FALSE = @HAVE_GDAL_FALSE@
+HAVE_GDAL_TRUE = @HAVE_GDAL_TRUE@
+HAVE_GTK_FALSE = @HAVE_GTK_FALSE@
+HAVE_GTK_TRUE = @HAVE_GTK_TRUE@
+INSTALL_DATA = @INSTALL_DATA@
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
+INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+INTLLIBS = @INTLLIBS@
+INTL_MACOSX_LIBS = @INTL_MACOSX_LIBS@
+LDFLAGS = @LDFLAGS@
+LIBADD_DL = @LIBADD_DL@
+LIBICONV = @LIBICONV@
+LIBINTL = @LIBINTL@
+LIBOBJS = @LIBOBJS@
+LIBS = @LIBS@
+LIBTOOL = @LIBTOOL@
+LN_S = @LN_S@
+LTLIBICONV = @LTLIBICONV@
+LTLIBINTL = @LTLIBINTL@
+LTLIBOBJS = @LTLIBOBJS@
+MAKEINFO = @MAKEINFO@
+MSGFMT = @MSGFMT@
+MSGFMT_015 = @MSGFMT_015@
+MSGMERGE = @MSGMERGE@
+NOGARMIN = @NOGARMIN@
+NOPLUGINS = @NOPLUGINS@
+OBJEXT = @OBJEXT@
+PACKAGE = @PACKAGE@
+PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
+PACKAGE_NAME = @PACKAGE_NAME@
+PACKAGE_STRING = @PACKAGE_STRING@
+PACKAGE_TARNAME = @PACKAGE_TARNAME@
+PACKAGE_VERSION = @PACKAGE_VERSION@
+PATH_SEPARATOR = @PATH_SEPARATOR@
+PCRE_CONFIG = @PCRE_CONFIG@
+PERL = @PERL@
+PERL_PACKAGE_DIR = @PERL_PACKAGE_DIR@
+PKGCONFIG_CFLAGS = @PKGCONFIG_CFLAGS@
+PKGCONFIG_LIBS = @PKGCONFIG_LIBS@
+PKG_CONFIG = @PKG_CONFIG@
+POSUB = @POSUB@
+POW_LIB = @POW_LIB@
+RANLIB = @RANLIB@
+SED = @SED@
+SET_MAKE = @SET_MAKE@
+SHELL = @SHELL@
+STRIP = @STRIP@
+USE_NLS = @USE_NLS@
+VERSION = @VERSION@
+WITH_MAPNIK_FALSE = @WITH_MAPNIK_FALSE@
+WITH_MAPNIK_TRUE = @WITH_MAPNIK_TRUE@
+XGETTEXT = @XGETTEXT@
+XGETTEXT_015 = @XGETTEXT_015@
+XML_CFLAGS = @XML_CFLAGS@
+XML_LIBS = @XML_LIBS@
+YACC = @YACC@
+YFLAGS = @YFLAGS@
+ac_ct_CC = @ac_ct_CC@
+ac_ct_CXX = @ac_ct_CXX@
+ac_ct_F77 = @ac_ct_F77@
+am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
+am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
+am__fastdepCXX_FALSE = @am__fastdepCXX_FALSE@
+am__fastdepCXX_TRUE = @am__fastdepCXX_TRUE@
+am__include = @am__include@
+am__leading_dot = @am__leading_dot@
+am__quote = @am__quote@
+am__tar = @am__tar@
+am__untar = @am__untar@
+bindir = @bindir@
+build = @build@
+build_alias = @build_alias@
+build_cpu = @build_cpu@
+build_os = @build_os@
+build_vendor = @build_vendor@
+datadir = @datadir@
+datarootdir = @datarootdir@
+docdir = @docdir@
+dvidir = @dvidir@
+exec_prefix = @exec_prefix@
+host = @host@
+host_alias = @host_alias@
+host_cpu = @host_cpu@
+host_os = @host_os@
+host_vendor = @host_vendor@
+htmldir = @htmldir@
+includedir = @includedir@
+infodir = @infodir@
+install_sh = @install_sh@
+libdir = @libdir@
+libexecdir = @libexecdir@
+localedir = @localedir@
+localstatedir = @localstatedir@
+mandir = @mandir@
+mkdir_p = @mkdir_p@
+oldincludedir = @oldincludedir@
+pdfdir = @pdfdir@
+prefix = @prefix@
+program_transform_name = @program_transform_name@
+psdir = @psdir@
+sbindir = @sbindir@
+sharedstatedir = @sharedstatedir@
+sysconfdir = @sysconfdir@
+target_alias = @target_alias@
+dsldir = $(datadir)/gpsdrive/DSL
+dsl_DATA = build.sh Gpsdrive.gif Gpsdrive.lnk Makefile.am package.sh README \
+ build-mysql.sh build-gpsdriveDB.sh
+
+EXTRA_DIST = $(dsl_DATA)
+all: all-am
+
+.SUFFIXES:
+$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
+ @for dep in $?; do \
+ case '$(am__configure_deps)' in \
+ *$$dep*) \
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh \
+ && exit 0; \
+ exit 1;; \
+ esac; \
+ done; \
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu DSL/Makefile'; \
+ cd $(top_srcdir) && \
+ $(AUTOMAKE) --gnu DSL/Makefile
+.PRECIOUS: Makefile
+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ @case '$?' in \
+ *config.status*) \
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh;; \
+ *) \
+ echo ' cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)'; \
+ cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe);; \
+ esac;
+
+$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+
+$(top_srcdir)/configure: $(am__configure_deps)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+$(ACLOCAL_M4): $(am__aclocal_m4_deps)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+
+mostlyclean-libtool:
+ -rm -f *.lo
+
+clean-libtool:
+ -rm -rf .libs _libs
+
+distclean-libtool:
+ -rm -f libtool
+uninstall-info-am:
+install-dslDATA: $(dsl_DATA)
+ @$(NORMAL_INSTALL)
+ test -z "$(dsldir)" || $(mkdir_p) "$(DESTDIR)$(dsldir)"
+ @list='$(dsl_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f=$(am__strip_dir) \
+ echo " $(dslDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(dsldir)/$$f'"; \
+ $(dslDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(dsldir)/$$f"; \
+ done
+
+uninstall-dslDATA:
+ @$(NORMAL_UNINSTALL)
+ @list='$(dsl_DATA)'; for p in $$list; do \
+ f=$(am__strip_dir) \
+ echo " rm -f '$(DESTDIR)$(dsldir)/$$f'"; \
+ rm -f "$(DESTDIR)$(dsldir)/$$f"; \
+ done
+tags: TAGS
+TAGS:
+
+ctags: CTAGS
+CTAGS:
+
+
+distdir: $(DISTFILES)
+ @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
+ topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
+ list='$(DISTFILES)'; for file in $$list; do \
+ case $$file in \
+ $(srcdir)/*) file=`echo "$$file" | sed "s|^$$srcdirstrip/||"`;; \
+ $(top_srcdir)/*) file=`echo "$$file" | sed "s|^$$topsrcdirstrip/|$(top_builddir)/|"`;; \
+ esac; \
+ if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
+ dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
+ if test "$$dir" != "$$file" && test "$$dir" != "."; then \
+ dir="/$$dir"; \
+ $(mkdir_p) "$(distdir)$$dir"; \
+ else \
+ dir=''; \
+ fi; \
+ if test -d $$d/$$file; then \
+ if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
+ cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
+ fi; \
+ cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
+ else \
+ test -f $(distdir)/$$file \
+ || cp -p $$d/$$file $(distdir)/$$file \
+ || exit 1; \
+ fi; \
+ done
+check-am: all-am
+check: check-am
+all-am: Makefile $(DATA)
+installdirs:
+ for dir in "$(DESTDIR)$(dsldir)"; do \
+ test -z "$$dir" || $(mkdir_p) "$$dir"; \
+ done
+install: install-am
+install-exec: install-exec-am
+install-data: install-data-am
+uninstall: uninstall-am
+
+install-am: all-am
+ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
+
+installcheck: installcheck-am
+install-strip:
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+ `test -z '$(STRIP)' || \
+ echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
+mostlyclean-generic:
+
+clean-generic:
+
+distclean-generic:
+ -test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
+
+maintainer-clean-generic:
+ @echo "This command is intended for maintainers to use"
+ @echo "it deletes files that may require special tools to rebuild."
+clean: clean-am
+
+clean-am: clean-generic clean-libtool mostlyclean-am
+
+distclean: distclean-am
+ -rm -f Makefile
+distclean-am: clean-am distclean-generic distclean-libtool
+
+dvi: dvi-am
+
+dvi-am:
+
+html: html-am
+
+info: info-am
+
+info-am:
+
+install-data-am: install-dslDATA
+
+install-exec-am:
+
+install-info: install-info-am
+
+install-man:
+
+installcheck-am:
+
+maintainer-clean: maintainer-clean-am
+ -rm -f Makefile
+maintainer-clean-am: distclean-am maintainer-clean-generic
+
+mostlyclean: mostlyclean-am
+
+mostlyclean-am: mostlyclean-generic mostlyclean-libtool
+
+pdf: pdf-am
+
+pdf-am:
+
+ps: ps-am
+
+ps-am:
+
+uninstall-am: uninstall-dslDATA uninstall-info-am
+
+.PHONY: all all-am check check-am clean clean-generic clean-libtool \
+ distclean distclean-generic distclean-libtool distdir dvi \
+ dvi-am html html-am info info-am install install-am \
+ install-data install-data-am install-dslDATA install-exec \
+ install-exec-am install-info install-info-am install-man \
+ install-strip installcheck installcheck-am installdirs \
+ maintainer-clean maintainer-clean-generic mostlyclean \
+ mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
+ uninstall uninstall-am uninstall-dslDATA uninstall-info-am
+
+# Tell versions [3.59,3.63) of GNU make to not export all variables.
+# Otherwise a system limit (for SysV at least) may be exceeded.
+.NOEXPORT:
diff --git a/DSL/README b/DSL/README
new file mode 100644
index 0000000..dd43aa9
--- /dev/null
+++ b/DSL/README
@@ -0,0 +1,104 @@
+GPSDrive for DSL (Damn Small Linux)
+===================================
+
+Contents
+-----------
+ * Introduction
+ * Compile
+ * Package
+ * Install
+ * Gpsd
+ * MySQL
+ * Current Status
+
+Introduction
+------------
+These instructions will help you to create a package that can be installed on DSL.
+It has been tested on Debian and gpsdrive appears to compile and be binary compatible
+with DSL. DSL grew out of Knoppix which grew out of Debian.
+
+Compile
+--------
+Have a look through the DEVPACKAGES file and install ALL of the required packages.
+Change to the DSL directory and run the build.sh file. If this completes with a
+"success" message you should have a runable gpsdrive program that you can execute
+happily on debian. It is installed to /opt/gpsdrive.
+
+Package
+--------
+Next you need to turn gpsdrive into an installable package for DSL.
+Create a folder named "package" two levels up from the DSL source folder.
+cd to the DSL folder and run the package.sh script. This will build
+all the required files in to an archive file named gpsdrive.tar.gz and
+stick it in a folder named ../../package/gpsdrive. This is what the DSL
+installer uses. You don't need to unpack it manually
+
+Install
+-------
+To install on DSL First download and install the package named gtk2-0705.dsl
+using the mydsl package installer normally found on the desktop.
+
+Then install gpsdrive.tar.gz using the mydsl button in the Emelfm file manager.
+Check out the DSL home page for all the different install options.
+
+Note:
+I have noticed that sometimes after installing Gpsdrive the desktop icon doesn't
+start the application. Installing it again seems to solve the problem.
+I have no idea why and the files don't appear any different. It is something
+to do with the Desktop link file /home/dsl/.xtdesktop/Gpsdrive.lnk
+
+All of the program files are installed into /opt/gpsdrive with the following
+exceptions. If these files already exist on your copy of DSL you may have
+problems with other software already installed on your system.
+None of them exist in a default build of DSL.
+
+/etc/gtk-2.0/gdk-pixbuf.loaders
+/etc/gtk-2.0/gtk.immodules
+/etc/pango/pango.modules
+/etc/pango/pangox.aliases
+
+Use the desktop icon to start the program.
+(I know the icon is lame, feel free to build a better one)
+If you prefer to use the command line then the following should work.
+
+LD_LIBRARY_PATH=/opt/gpsdrive/lib /opt/gpsdrive/bin/gpsdrive
+
+I haven't done extensive testing but the program seems to be fully operational.
+If you find problems please post details on the GPSDrive Mailing list.
+
+GPSD
+-----
+As it appears that direct serial support is soon to be no longer supported in gpsdrive
+gpsd will be needed to make the connection to your gps. I'm currently working on creating
+package scripts for gpsd. They are working but arn't in the gpsdrive source tree yet.
+
+MYSQL
+-----
+I'm also working on getting Mysql into DSL and it is looking like being bigger
+than getting gpsdrive in there. At the moment it is a work in progress.
+i.e. Not working
+
+STATUS
+------
+21/11/2006
+I have run into problems and decided to change my aproach a bit. I have not been
+able to successfully create a DSL package since I moved my development environment to
+to Debian Etch (Testing). This is because the GTK libs currently available on DSL are
+now to old and don't match the libs used when compiling. There are a few ways
+to go from here and none of them appear easy.
+
+1) Create a full build environment on DSL.
+2) Compile all of the required run time libs on DSL. (Still build on Debian)
+3) Wait until newer libs become available either on DSL or DSL-n
+
+I have decided to give this a rest for now, I may come back to it later.
+Feel free to pick up where I have left off if you like and also feel free to let
+me know you are workng on it if you want.
+
+I have decided to install Debian on my Car computer as well as my development machine.
+It has swallowed about 3 gig of my CF card instead of about 60mb for DSL :(
+I will also need to make sure that it doesn't burn a hole on my CF by swapping or
+writing temp files. Oh well like a chalenge :)
+
+David P
+
diff --git a/DSL/build-gpsdriveDB.sh b/DSL/build-gpsdriveDB.sh
new file mode 100755
index 0000000..f4a0459
--- /dev/null
+++ b/DSL/build-gpsdriveDB.sh
@@ -0,0 +1,76 @@
+# Create the initial Mysql DB for Gpsdive
+# Update Log
+# ===========
+# Date Init Description
+#----------------------------------------------------------------------------
+# 07/08/2006 DP Initial file creation
+# 19/08/2006 DP Added database backup (so it can be restored on DSL
+#----------------------------------------------------------------------------
+# Note:
+# This should be run on debian
+# Gpsdrive should already be installed
+#
+# You may need to create a dir named /var/mysql and grant write
+# permission to the user that starts mysql. (the user running this script)
+# This is where mysql stores it's process information.
+#
+# Once this script finishes without error see the notes in the package script
+# ---------------------------------------------------------------
+#
+#Change these as required.
+
+# Installed Location of Mysql
+DEST=/opt/mysql
+
+# User to create the geoinfo database
+USER=root
+PASSWORD=your-mysql-root-password
+
+# Installed Location of gpsdrive
+GPSDRIVEHOME=/opt/gpsdrive
+
+######################################################################
+
+# Initialise the Database for gpsdrive
+# ------------------------------------
+
+echo "Initialising the database for gpsdrive "
+PERL5LIB=$GPSDRIVEHOME/share/perl5
+cd $GPSDRIVEHOME/bin
+if [ "$?" != "0" ]
+then
+ echo "Couldnt cd to the gpsdrive bin dir"
+ exit 10
+fi
+./geoinfo.pl --create-db --fill-defaults --db-user=$USER --db-password=$PASSWORD
+if [ "$?" != "0" ]
+then
+ echo "error from geoinfo.pl initialising the DB "
+ exit 11
+fi
+# Add the open street map data
+# ./geoinfo.pl --create-db --osm --db-user=$USER --db-password=$PASSWORD
+if [ "$?" != "0" ]
+then
+ echo "error adding the Open Street Map data"
+ exit 12
+fi
+
+# This creates a backup that can be restored onto DSL
+echo Backup the database so it can be restored on DSL
+echo ************************************************
+echo File is saved to ~/.gpsdrive dir with file name sqldump.yy.mm.dd_hh:mm.gz
+echo Use this file to restore the database on DSL
+
+PATH=$PATH:$DEST/bin
+
+./gpssql_backup.sh
+if [ "$?" != "0" ]
+then
+ echo error the backup command failed
+ exit 13
+fi
+
+echo "Script Completed Successfully"
+exit 0
+
diff --git a/DSL/build-mysql.sh b/DSL/build-mysql.sh
new file mode 100755
index 0000000..a213e20
--- /dev/null
+++ b/DSL/build-mysql.sh
@@ -0,0 +1,197 @@
+# Compile MYSQL ready to be packaged for Damn Small Linxu (DSL)
+# Update Log
+# ===========
+# Date Init Description
+#----------------------------------------------------------------
+# 07/08/2006 DP Initial file creation
+#----------------------------------------------------------------
+# Note:
+# This build will probably succede on debian but the package won't be
+# runnable on DSL (will run ok on debian).
+# This is Something to do with libc.so.6 versions
+# I did a DSL(3.01) hard disk install and build it on there.
+# You might be able to build it from a livecd but I haven't tried it.
+# In short you will need to build on the platform you intend to run on.
+#
+# Run the command using a normal user but you will need permission
+# to use the sudo command.
+# (I have been having trouble getting sudo to work on debian. You may just
+# neet to run the commands individually from the command line)
+
+# You will need the following DSL packages from the SYSTEM group
+# libcurses5.dsl
+# libcurses5-dev.dsl
+# gcc1.dsl
+#
+# On Debian probably just the folloiwng if you also managed to compiled gpsdrive
+# libcurses5-dev
+#
+# I used the mysql-5.0.22.tar.gz source tar ball
+# (5.0.24 was released but the built in test scripts failed)
+#
+# Once you have unpacked the tar file, create a sub directory
+# named DSL and put this script in there along with the package
+# script and cd to the new DSL folder. As stated before if you are
+# builing for debian you won't be able to package for DSL, you will
+# need to compile on DSL to package for DSL.
+#
+# You will need to initialise the database by following the instructions here
+# (or it won't work)
+# http://dev.mysql.com/doc/refman/5.0/en/unix-post-installation.html
+#
+#
+# This script creates an empty data base. You will need to create
+# the gpsdrive specific data on debin. I couldn't get the perl
+# script (gpsinfo.pl) to run on DSL. It looked like there were
+# version problems.
+#
+# I couldn't get geoinfo.pl to run on DSL. The build-gpdriveDB.sh
+# script will create a database and back it up for you so you can
+# restore that on DSL. Read the notes in the top of that script too.
+# ---------------------------------------------------------------
+#
+# *** Change these *****
+#
+DEST=/opt/mysql
+SOURCE=..
+USER=mysql
+GROUP=mysql
+GPSDRIVEHOME=/opt/gpsdrive
+
+######################################################################
+# Compile Notes:
+# This is stuff I changed from the default build script I found.
+#
+# configure: error: Could not find system readline or libedit libraries
+# Use --with-readline or --with-libedit to use the bundled
+# versions of libedit or readline
+#
+# Removed --without-readline
+#
+# Other things removed/changed from suggested configure command
+#
+# --sysconfdir=/etc \
+# --libexecdir=/usr/sbin \
+# --localstatedir=/srv/mysql \
+# --with-extra-charsets=all (Changed to =complex)
+#
+# Added
+# --without-yassl (caused error during "make test")
+# I don't think we need SSL encryption
+#
+######################################################################
+echo " Configure"
+cd $SOURCE
+
+CFLAGS="-O3 -DPIC -fPIC -DUNDEF_HAVE_INITGROUPS -fno-strict-aliasing" \
+CXXFLAGS="-O3 -fno-strict-aliasing -felide-constructors -fno-exceptions -fno-rtti -fPIC -DPIC -DUNDEF_HAVE_INITGROUPS" \
+ ./configure --prefix=$DEST \
+ --enable-thread-safe-client \
+ --enable-assembler \
+ --enable-local-infile \
+ --without-debug \
+ --without-yassl \
+ --without-bench \
+ --with-unix-socket-path=/var/run/mysqld/mysqld.sock \
+ --with-extra-charsets=complex
+
+if [ "$?" != "0" ]
+then
+ echo "error during configure :("
+ exit 1
+fi
+
+echo "Running make clean"
+make clean
+if [ "$?" != "0" ]
+then
+ echo "error during make clean :("
+ exit 1
+fi
+echo "Running Make"
+make
+
+if [ "$?" != "0" ]
+then
+ echo "error during Make :("
+ exit 2
+fi
+
+echo "Running Make Test"
+echo "!!! This fails if run as root !!!!!"
+make test
+if [ "$?" != "0" ]
+then
+ echo "error during Make Test :("
+ exit 3
+fi
+
+echo "Running Make Install"
+
+sudo make install
+if [ "$?" != "0" ]
+then
+ echo "error during make install :("
+ exit 4
+fi
+
+echo "Setting up"
+
+if [ ! -d $DEST/var ]
+then
+ sudo mkdir $DEST/var
+ if [ "$?" != "0" ]
+ then
+ echo "error during makedir :("
+ exit 8
+ fi
+fi
+
+# fix the permissions
+sudo chmod -R 774 $DEST/*
+if [ "$?" != "0" ]
+then
+ echo "error during chmod :("
+ exit 5
+fi
+
+sudo chgrp -R $GROUP $DEST/*
+if [ "$?" != "0" ]
+then
+ echo "error during chgrp :("
+ exit 6
+fi
+
+sudo chown -R $USER $DEST/*
+if [ "$?" != "0" ]
+then
+ echo "error during chown :("
+ exit 7
+fi
+
+#
+# Create the default database
+# ---------------------------
+#
+cd $DEST/bin
+./mysql_install_db --user=$USER
+if [ "$?" != "0" ]
+then
+ echo "error creating the default database"
+ exit 9
+fi
+
+echo Now follow the steps detailed in....
+echo http://dev.mysql.com/doc/refman/5.0/en/unix-post-installation.html
+
+# Initialise the database
+# -----------------------
+
+# start the database
+./mysqld_safe --user=$user &
+
+echo The database should have also just started
+
+
+exit 0
+
diff --git a/DSL/build.sh b/DSL/build.sh
new file mode 100755
index 0000000..827dae1
--- /dev/null
+++ b/DSL/build.sh
@@ -0,0 +1,68 @@
+##############################################################
+DEST=/opt/gpsdrive
+SOURCE=..
+##############################################################
+ cd $SOURCE
+ ######################################################
+ echo "aclcoal"
+ aclocal
+ if [ "$?" != "0" ]
+ then
+ echo " Error During Aclocal"
+ exit 1
+ fi
+ echo "automake"
+ automake
+ if [ "$?" != "0" ]
+ then
+ echo "Error During Automake"
+ exit 1
+ fi
+ echo "autoconf"
+ autoconf
+ if [ "$?" != "0" ]
+ then
+ echo "Error During Autoconf"
+ exit 1
+ fi
+ ##########################################
+ echo " Configure"
+ ./configure --prefix=$DEST
+ if [ "$?" != "0" ]
+ then
+ echo " status " $?
+ exit 2
+ else
+ echo " Success"
+ fi
+ ###########################################
+ echo " Make Clean"
+ make clean
+ if [ "$?" != "0" ]
+ then
+ echo " status " $?
+ exit 2
+ else
+ echo " Success"
+ fi
+ ###########################################
+ echo " Make "
+ make
+ if [ "$?" != "0" ]
+ then
+ echo " status " $?
+ exit 2
+ else
+ echo " Success"
+ fi
+ #############################################
+ echo " Install"
+ make install
+ if [ "$?" != "0" ]
+ then
+ echo " status " $?
+ exit 2
+ else
+ echo " Success"
+ fi
+##############################################################
diff --git a/DSL/package.sh b/DSL/package.sh
new file mode 100755
index 0000000..3ec4c88
--- /dev/null
+++ b/DSL/package.sh
@@ -0,0 +1,176 @@
+##########################################################################################
+# Create the Package for DSL
+##########################################################################################
+# Note:
+# This script should be run from the current directory (./package.sh)
+# Don't forget to create the package directory two levels up from DSL
+#
+############################################################################################
+# Update Log
+# Date Name Description
+#
+# 07/03/06 DP Made the pagkage directory a relative path
+# Added some error checking. (you gota love rm -rf in a scipt. ;)
+#
+# 24/04/06 DP The required lib's have changed a bit.
+# Added libpangocairo
+# Added libcairo
+# Modified libpcre and libpcreposix
+# Added libXinerama
+# 19/07/06 DP Added gpsdrive sub directory to package directory
+#
+# 10/09/06 DP Updated additional package version numbers and directories
+# following move to debian testing (etch)
+############################################################################################
+ PACKAGENAME=gpsdrive
+ LOGFILE=package.log
+ LIBDIR=opt/gpsdrive/lib
+ ICONDIR=`pwd`
+
+ cd ../../package
+ if [ "$?" != "0" ]
+ then
+ echo
+ echo "--------------------------------------------------------"
+ echo "You will need to create the package staging area"
+ echo "The default is a folder called package up two levels"
+ echo "Next to the gpsdrive cvs folder"
+ echo "i.e. Up two levels from DSL"
+ echo "--------------------------------------------------------"
+ exit 1
+ else
+ if [ -d $PACKAGENAME ]
+ then
+ echo Package sub folder exists.
+ else
+ mkdir $PACKAGENAME
+ if [ "$?" != "0" ]
+ then
+ echo " Could not create package sub dir"
+ exit 1
+ fi
+ fi
+ cd $PACKAGENAME
+ echo Current Working Directory
+ pwd
+ fi
+
+ # Remove old package staging area
+ rm -rf opt
+ rm -rf home
+ rm -rf etc
+
+ # Make the install staging dir
+ mkdir opt
+
+ # Move the program into the pagkage staging area
+ cp -Pr /opt/gpsdrive ./opt
+
+ # Make the Icon item
+ mkdir home
+ mkdir home/dsl
+ mkdir home/dsl/.xtdesktop
+
+ # Copy the Icon and the .lnk desktop icon file
+ #
+ cp $ICONDIR/Gpsdrive.lnk home/dsl/.xtdesktop/Gpsdrive.lnk
+ cp $ICONDIR/Gpsdrive.gif home/dsl/.xtdesktop/Gpsdrive.gif
+
+ # Add other missing files required to run the program
+
+ # Files for libpcre3
+ cp /usr/lib/libpcre.a $LIBDIR
+ cp /usr/lib/libpcre.so.3.12.0 $LIBDIR
+ cp -d /usr/lib/libpcre.so $LIBDIR
+ cp -d /usr/lib/libpcre.so.3 $LIBDIR
+
+ cp /usr/lib/libpcreposix.a $LIBDIR
+ cp /usr/lib/libpcreposix.so.3.12.0 $LIBDIR
+ cp -d /usr/lib/libpcreposix.so $LIBDIR
+ cp -d /usr/lib/libpcreposix.so.3 $LIBDIR
+
+ # Files for Pixbuf
+ cp /usr/lib/gtk-2.0/2.4.0/engines/libpixmap.la $LIBDIR
+ cp /usr/lib/gtk-2.0/2.4.0/engines/libpixmap.a $LIBDIR
+ cp /usr/lib/gtk-2.0/2.4.0/engines/libpixmap.so $LIBDIR
+
+ # Files for libpangocairo
+ cp /usr/lib/libpangocairo-1.0.a $LIBDIR
+ cp /usr/lib/libpangocairo-1.0.la $LIBDIR
+ cp /usr/lib/libpangocairo-1.0.so.0 $LIBDIR
+
+ # libcairo
+ cp /usr/lib/libcairo.a $LIBDIR
+ cp /usr/lib/libcairo.la $LIBDIR
+ cp /usr/lib/libcairo.so.2.9.0 $LIBDIR
+ cp -d /usr/lib/libcairo.so $LIBDIR
+ cp -d /usr/lib/libcairo.so.2 $LIBDIR
+
+ # libXinerama
+ cp /usr/lib/libXinerama.a $LIBDIR
+ cp /usr/lib/libXinerama.so.1.0.0 $LIBDIR
+ cp -d /usr/lib/libXinerama.so.1 $LIBDIR
+
+
+ # Add other missing files required to run the program
+ # that don't live in the gpsdrive/lib directory
+ mkdir etc
+ mkdir etc/gtk-2.0
+ mkdir etc/pango
+ cp /etc/gtk-2.0/gdk-pixbuf.loaders etc/gtk-2.0
+ cp /etc/gtk-2.0/gtk.immodules etc/gtk-2.0
+ cp /etc/pango/pango.modules etc/pango
+ cp /etc/pango/pangox.aliases etc/pango
+
+ # Fix file ownership
+ chown -R 0.0 ./{opt/,etc}
+ chown -R 1001.50 ./home/dsl/
+
+ # Remove the old archive if any
+ rm -f gpsdrive.tar.gz
+
+ # Create the file list
+ find . > files.txt
+
+ # Remove unwanted files from the list
+ # -v sends all non matching lines to the output file
+ # -x matches the whole line only
+ echo "Building the files list "
+ cat files.txt \
+ | grep -vx . \
+ | grep -vx ./opt \
+ | grep -v /include \
+ | grep -v /doc \
+ | grep -v /gtk-doc \
+ | grep -vx ./home \
+ | grep -vx ./home/dsl \
+ | grep -vx ./var \
+ | grep -vx ./var/tmp \
+ | grep -vx .var/tmp/mydsk.menu \
+ | grep -vx ./files.txt \
+ | grep -v .gpsdrive.tar \
+ > includedfiles.txt
+ echo "Build file list status " $?
+
+ # Create the archive
+
+ echo " Creating the Archive "
+ tar -cvf gpsdrive.tar --no-recursion --numeric-owner -T includedfiles.txt >> $LOGFILE
+ echo " Create Archive Status " $?
+
+ echo " Compressing the Archive.... please wait "
+ gzip -9 gpsdrive.tar
+ echo " Compress Archive Status " $?
+
+ # Create an info file
+ # TODO
+
+ # Create an md5sum
+ # TODO
+ # md6sum gpsdrive.tar.gz > gpsdrive.tar.gz.md5.txt
+ #
+ # Finished
+ echo Finished
+ echo The built files can be found in.....
+ pwd
+################################################################