summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Serbinenko <phcoder@gmail.com>2015-11-08 21:24:18 +0100
committerVladimir Serbinenko <phcoder@gmail.com>2015-11-08 21:24:18 +0100
commitb2fc9acdc9674de2b930ee92229917881843ba92 (patch)
tree3ed25c3a5baf7fb92461451b235d754e1a1d5a55
parente07badcc31babb24ace4f96444bc484502427d3a (diff)
Adapt build-system to use imported xen headers.
-rw-r--r--conf/Makefile.common3
-rw-r--r--grub-core/Makefile.core.def9
-rw-r--r--include/grub/xen.h7
3 files changed, 6 insertions, 13 deletions
diff --git a/conf/Makefile.common b/conf/Makefile.common
index fcb8d2e1c..5083d5f1e 100644
--- a/conf/Makefile.common
+++ b/conf/Makefile.common
@@ -21,9 +21,6 @@ if COND_powerpc_ieee1275
CFLAGS_PLATFORM += -mcpu=powerpc
endif
-#FIXME: discover and check XEN headers
-CPPFLAGS_XEN = -I/usr/include
-
# Other options
CPPFLAGS_DEFAULT = -DGRUB_FILE=\"$(subst $(srcdir)/,,$<)\"
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
index 03e04ab39..d9fa0e339 100644
--- a/grub-core/Makefile.core.def
+++ b/grub-core/Makefile.core.def
@@ -59,9 +59,6 @@ kernel = {
ia64_efi_ldflags = '-Wl,-r,-d';
ia64_efi_stripflags = '--strip-unneeded -K start -R .note -R .comment -R .note.gnu.gold-version';
- x86_64_xen_cppflags = '$(CPPFLAGS_XEN)';
- i386_xen_cppflags = '$(CPPFLAGS_XEN)';
-
arm_efi_ldflags = '-Wl,-r,-d';
arm_efi_stripflags = '--strip-unneeded -K start -R .note -R .comment -R .note.gnu.gold-version';
@@ -604,7 +601,6 @@ module = {
module = {
name = lsxen;
common = commands/xen/lsxen.c;
- cppflags = '$(CPPFLAGS_XEN)';
enable = xen;
};
@@ -825,7 +821,6 @@ module = {
i386_coreboot = lib/i386/halt.c;
i386_qemu = lib/i386/halt.c;
xen = lib/xen/halt.c;
- xen_cppflags = '$(CPPFLAGS_XEN)';
efi = lib/efi/halt.c;
ieee1275 = lib/ieee1275/halt.c;
emu = lib/emu/halt.c;
@@ -846,7 +841,6 @@ module = {
mips_loongson = lib/mips/loongson/reboot.c;
mips_qemu_mips = lib/mips/qemu_mips/reboot.c;
xen = lib/xen/reboot.c;
- xen_cppflags = '$(CPPFLAGS_XEN)';
uboot = lib/uboot/reboot.c;
common = commands/reboot.c;
};
@@ -1526,7 +1520,6 @@ module = {
i386_xen = lib/i386/xen/relocator.S;
x86_64_xen = lib/x86_64/xen/relocator.S;
xen = lib/i386/relocator_common_c.c;
- xen_cppflags = '$(CPPFLAGS_XEN)';
extra_dist = lib/i386/relocator_common.S;
extra_dist = kern/powerpc/cache_flush.S;
@@ -1547,7 +1540,6 @@ module = {
sparc64_ieee1275 = lib/ieee1275/cmos.c;
powerpc_ieee1275 = lib/ieee1275/cmos.c;
xen = lib/xen/datetime.c;
- xen_cppflags = '$(CPPFLAGS_XEN)';
mips_arc = lib/arc/datetime.c;
enable = noemu;
@@ -1657,7 +1649,6 @@ module = {
name = linux;
x86 = loader/i386/linux.c;
xen = loader/i386/xen.c;
- xen_cppflags = '$(CPPFLAGS_XEN)';
i386_pc = lib/i386/pc/vesa_modes_table.c;
mips = loader/mips/linux.c;
powerpc_ieee1275 = loader/powerpc/ieee1275/linux.c;
diff --git a/include/grub/xen.h b/include/grub/xen.h
index 9ba3b8e6b..c31cc10c7 100644
--- a/include/grub/xen.h
+++ b/include/grub/xen.h
@@ -33,7 +33,12 @@
#include <grub/err.h>
#ifndef GRUB_SYMBOL_GENERATOR
-#include <stdint.h>
+typedef grub_int8_t int8_t;
+typedef grub_int16_t int16_t;
+typedef grub_uint8_t uint8_t;
+typedef grub_uint16_t uint16_t;
+typedef grub_uint32_t uint32_t;
+typedef grub_uint64_t uint64_t;
#include <xen/xen.h>
#include <xen/sched.h>