summaryrefslogtreecommitdiff
path: root/conf
diff options
context:
space:
mode:
authorVladimir Serbinenko <phcoder@gmail.com>2013-11-07 03:33:20 +0100
committerVladimir Serbinenko <phcoder@gmail.com>2013-11-07 03:33:20 +0100
commitcdc17f60dc8c26d15bf1b24479d5afa92e23205a (patch)
treedca50078331e33efbd65dd6987069c7673d39636 /conf
parentb35ec29927fd4f8e1852ad260b624d0214fc2886 (diff)
* configure.ac: Add -freg-struct-return on all platforms that
support it.
Diffstat (limited to 'conf')
-rw-r--r--conf/Makefile.common8
1 files changed, 4 insertions, 4 deletions
diff --git a/conf/Makefile.common b/conf/Makefile.common
index 9eaff2e49..33dbb0364 100644
--- a/conf/Makefile.common
+++ b/conf/Makefile.common
@@ -7,16 +7,16 @@ unexport LC_ALL
# Platform specific options
if COND_i386_pc
- CFLAGS_PLATFORM += -mrtd -mregparm=3 -freg-struct-return
+ CFLAGS_PLATFORM += -mrtd -mregparm=3
endif
if COND_i386_qemu
- CFLAGS_PLATFORM += -mrtd -mregparm=3 -freg-struct-return
+ CFLAGS_PLATFORM += -mrtd -mregparm=3
endif
if COND_i386_coreboot
- CFLAGS_PLATFORM += -mrtd -mregparm=3 -freg-struct-return
+ CFLAGS_PLATFORM += -mrtd -mregparm=3
endif
if COND_i386_ieee1275
- CFLAGS_PLATFORM += -mrtd -mregparm=3 -freg-struct-return
+ CFLAGS_PLATFORM += -mrtd -mregparm=3
endif
if COND_mips_loongson
CFLAGS_PLATFORM += -mexplicit-relocs