summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSolomon Peachy <pizza@shaftnet.org>2016-09-26 09:02:56 -0400
committerDidier Raboud <odyx@debian.org>2016-09-24 19:05:20 +0200
commitd0af5288def3fad3436c9f3f632ed4161e899b8b (patch)
tree13aab2edb027fb521dac977c07f7aab4aaf0a58a
parent112917b0acf923ffa3632fc19a1fbde71d676baf (diff)
build: We shouldn't enable modules when --with-modules=no or =static
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a9e4291..e5404fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -878,7 +878,7 @@ fi
# define what module system is to be used
AC_MSG_CHECKING([which module system will be used])
if test x$USE_LTDL = xtrue; then
- if test -z "$WITH_MODULES" ; then
+ if test -z "$WITH_MODULES" -o x$WITH_MODULES = xno -o x$WITH_MODULES = xstatic ; then
MODULE="false"
else
MODULE="true"
@@ -890,7 +890,7 @@ if test x$USE_LTDL = xtrue; then
AC_DEFINE(USE_LTDL, "1", [Use GNU libltdl as module loader])
AC_MSG_RESULT([ltdl])
elif test x$USE_DLOPEN = xtrue; then
- if test -z "$WITH_MODULES" ; then
+ if test -z "$WITH_MODULES" -o x$WITH_MODULES = xno -o x$WITH_MODULES = xstatic ; then
MODULE="false"
else
MODULE="true"