summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2010-08-15 11:53:32 +0100
committerRoger Leigh <rleigh@debian.org>2010-08-15 11:53:32 +0100
commit4bc88c4aa9026d5c679008a4dbbb8ec4d9a901bd (patch)
treec268c9ca117bceee9f60ae4f451465097a1bd1bf /ChangeLog
parentb7a746079a87b24dc0e64362e83463029e26c98f (diff)
Imported Upstream version 5.2.6
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog359
1 files changed, 359 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 5c8ee1a..32a30d3 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,362 @@
+2010-08-11 <rlk@sourceforge.net>
+
+ Files: NEWS (1.434) (+7 -0)
+ src/xml/escp2/inputslots/Makefile.am (1.10) (+2 -1)
+ src/xml/escp2/inputslots/pro3880.xml (1.1) (added)
+ src/xml/escp2/media/Makefile.am (1.15) (+2 -1)
+ src/xml/escp2/media/pro3880_ultrachrome_k3v.xml (1.1) (added)
+ src/xml/escp2/model/Makefile.am (1.21) (+3 -2)
+ src/xml/escp2/model/model_107.xml (1.1) (added)
+ src/xml/printers.xml (1.58) (+3 -1)
+
+ Preliminary support for Epson 3800 and 3880
+
+2010-08-10 <rlk@sourceforge.net>
+
+ Files: NEWS (1.433) (+6 -3)
+ src/xml/printers.xml (1.57) (+2 -1)
+
+ Add support for Canon PIXMA MP510
+
+2010-08-09 <rlk@sourceforge.net>
+
+ Files: NEWS (1.432) (+3 -3)
+ README (1.208) (+13 -13)
+ configure.ac (1.220) (+3 -3)
+
+ Prep for 5.2.6 release
+
+2010-08-09 <rlk@sourceforge.net>
+
+ Files: NEWS (1.431) (+20 -12)
+
+ Minor updates.
+
+2010-08-07 <rlk@sourceforge.net>
+
+ Files: src/main/print-pcl.c (1.159) (+3 -1)
+ src/xml/printers.xml (1.56) (+2 -2)
+
+ Add A3 support back to tabloid laser printers.
+
+ Add Super B support to 13" laser printers.
+
+ Correct definition of one printer.
+
+2010-08-07 <rlk@sourceforge.net>
+
+ Files: NEWS (1.430) (+142 -22)
+ src/main/print-pcl.c (1.158) (+49 -1)
+ src/xml/printers.xml (1.55) (+126 -17)
+
+ Add support for a number of Brother, Canon, Kyocera, Oki, Tektronix,
+ and Xerox laser printers.
+
+ Support tabloid-size laser printers.
+
+2010-08-07 <rlk@sourceforge.net>
+
+ Files: src/xml/printers.xml (1.54) (+2 -2)
+
+ Remove duplicate foomaticid tag on one printer.
+
+2010-08-07 <rlk@sourceforge.net>
+
+ Files: include/gutenprint/printers.h (1.7) (+17 -2)
+ src/foomatic/Makefile.am (1.53) (+4 -6)
+ src/foomatic/foomatic-generator.in (1.67) (+8 -62)
+ src/foomatic/foomatic-printermap (1.201) (removed)
+ src/foomatic/printers.c (1.14) (+30 -9)
+ src/main/printers.c (1.89) (+36 -2)
+ src/xml/printers.xml (1.53) (+1432 -1432)
+
+ Put Foomatic IDs in printers.xml and remove foomatic-printermap
+
+2010-08-06 <rlk@sourceforge.net>
+
+ Files: NEWS (1.429) (+3 -0)
+ src/foomatic/foomatic-printermap (1.200) (+3 -0)
+ src/xml/printers.xml (1.52) (+4 -1)
+
+ Support Canon MP360/370/390, from Gernot Hassenpflug
+
+2010-08-04 <rlk@sourceforge.net>
+
+ Files: include/gutenprint/util.h (1.9) (+3 -2)
+ src/main/array.c (1.17) (+13 -22)
+ src/main/color.c (1.11) (+9 -19)
+ src/main/curve.c (1.55) (+41 -49)
+ src/main/dither-inks.c (1.27) (+4 -5)
+ src/main/dither-main.c (1.62) (+7 -15)
+ src/main/dither-ordered.c (1.31) (+1 -2)
+ src/main/escp2-channels.c (1.90) (+8 -26)
+ src/main/escp2-papers.c (1.119) (+6 -24)
+ src/main/escp2-resolutions.c (1.52) (+4 -16)
+ src/main/gutenprint-internal.h (1.3) (+17 -8)
+ src/main/print-color.c (1.141) (+2 -6)
+ src/main/print-dither-matrices.c (1.38) (+2 -3)
+ src/main/print-escp2-data.c (1.273) (+10 -42)
+ src/main/print-escp2.c (1.431) (+4 -15)
+ src/main/print-lexmark.c (1.159) (+2 -6)
+ src/main/print-list.c (1.25) (+2 -3)
+ src/main/print-vars.c (1.90) (+23 -66)
+ src/main/print-weave.c (1.76) (+7 -26)
+ src/main/printers.c (1.88) (+1 -15)
+ src/main/sequence.c (1.28) (+49 -74)
+ src/main/xml.c (1.43) (+1 -2)
+
+ Lift the assert macro out of print-weave.c into
+ gutenprint-internal.h, and renamed it STPI_ASSERT to not collide with
+ <assert.h>. I've also made a few changes:
+
+ 1) It always uses stpi_erprintf rather than relying on the error
+ function in the optional stp_vars_t passed in. My intention is to
+ print out the stp_vars_t (very carefully) as a context if one is
+ provided.
+
+ 2) The macro reports the version of Gutenprint and appends a message
+ "Please report this bug". It also prepends "ERROR:" so that CUPS will
+ pick it up in its error log.
+
+ 3) Add debug flag to report tested assertions.
+
+2010-08-03 <rlk@sourceforge.net>
+
+ Files: src/testpattern/run-testpattern-2.in (1.37) (+36 -13)
+
+ Add -X argument to rerun test cases specified on stdin (these should
+ be taken from filenames generated by -O or MD5 sums from -m or -M).
+
+2010-07-21 <rlk@sourceforge.net>
+
+ Files: NEWS (1.428) (+14 -6)
+ src/foomatic/foomatic-printermap (1.199) (+7 -0)
+ src/xml/printers.xml (1.51) (+9 -1)
+
+ Add support for some Epson RX650-class printers
+
+2010-07-19 <rlk@sourceforge.net>
+
+ Files: src/ghost/ijsgutenprint.c (1.23) (+8 -5)
+
+ Use STP_SUPPRESS_MESSAGES to suppress debugging output.
+
+2010-07-19 <rlk@sourceforge.net>
+
+ Files: NEWS (1.427) (+15 -0)
+
+ Update release notes.
+
+2010-07-18 <rlk@sourceforge.net>
+
+ Files: src/main/Makefile.am (1.104) (+2 -3)
+
+ Complete removal of util.h.
+
+2010-07-18 <rlk@sourceforge.net>
+
+ Files: NEWS (1.426) (+3 -3)
+ README (1.207) (+13 -13)
+ configure.ac (1.219) (+3 -3)
+
+ Prep for 5.2.6-pre1
+
+2010-07-18 <rlk@sourceforge.net>
+
+ Files: src/xml/escp2/inks/pro_ultrachrome_k3.xml (1.9) (+8 -8)
+ src/xml/escp2/inks/pro_ultrachrome_k3v.xml (1.2) (+8 -8)
+
+ Rename channels to correspond with standard usage
+
+2010-07-18 <rlk@sourceforge.net>
+
+ Files: NEWS (1.425) (+10 -0)
+ src/foomatic/foomatic-printermap (1.198) (+3 -0)
+ src/xml/escp2/inks/Makefile.am (1.10) (+2 -1)
+ src/xml/escp2/inks/pro_ultrachrome_k3v.xml (1.1) (added)
+ src/xml/escp2/inputslots/Makefile.am (1.9) (+2 -1)
+ src/xml/escp2/inputslots/pro_cutter_roll_feed.xml (1.1) (added)
+ src/xml/escp2/media/Makefile.am (1.14) (+2 -1)
+ src/xml/escp2/media/pro_ultrachrome_k3.xml (1.3) (+3 -0)
+ src/xml/escp2/media/pro_ultrachrome_k3v.xml (1.1) (added)
+ src/xml/escp2/model/Makefile.am (1.20) (+7 -2)
+ src/xml/escp2/model/model_102.xml (1.1) (added)
+ src/xml/escp2/model/model_103.xml (1.1) (added)
+ src/xml/escp2/model/model_104.xml (1.1) (added)
+ src/xml/escp2/model/model_105.xml (1.1) (added)
+ src/xml/escp2/model/model_106.xml (1.1) (added)
+ src/xml/escp2/model/model_88.xml (1.7) (+9 -10)
+ src/xml/escp2/model/model_89.xml (1.6) (+12 -13)
+ src/xml/escp2/model/model_90.xml (1.6) (+12 -13)
+ src/xml/printers.xml (1.50) (+6 -3)
+
+ Add support for the Epson 4800, 4880 (from Lutz Sammer and David Stone),
+ and 11800.
+
+ Correct definitions of Epson 7800 and 9800 to use Ultrachrome K3 rather
+ than Ultrachrome inks.
+
+ Adjust definitions of Epson 7880, 9880, and 11880 to be consistent with
+ 4880.
+
+2010-07-18 <rlk@sourceforge.net>
+
+ Files: src/main/print-escp2.c (1.430) (+6 -3)
+
+ Enable use of grayscale mode in Stylus Pro printers and others when
+ using printer weave.
+
+2010-07-18 <rlk@sourceforge.net>
+
+ Files: README (1.206) (+2 -2)
+
+ Bump configuration block output
+
+2010-07-17 <rlk@sourceforge.net>
+
+ Files: NEWS (1.424) (+11 -1)
+ README (1.205) (+10 -10)
+
+ Bump version
+
+2010-07-17 <rlk@sourceforge.net>
+
+ Files: configure.ac (1.218) (+4 -4)
+
+ Bump version.
+
+2010-07-10 <rlk@sourceforge.net>
+
+ Files: src/gutenprintui2/panel.c (1.19) (+7 -2)
+
+ Allow image size to be less than 5% if the input image size is small enough.
+
+2010-07-05 <rlk@sourceforge.net>
+
+ Files: include/gutenprint/Makefile.am (1.4) (+1 -2)
+
+ Remove duplicate sequence.h.
+
+2010-07-03 <rlk@sourceforge.net>
+
+ Files: po/POTFILES.in (1.25) (+0 -1)
+
+ Complete removal of src/main/util.h.
+
+2010-06-26 <rlk@sourceforge.net>
+
+ Files: src/main/gutenprint-internal.h (1.2) (+23 -3)
+ src/main/util.h (1.35) (removed)
+
+ Merge internal util.h into gutenprint-internal.h to avoid two util.h files
+
+2010-06-26 <rlk@sourceforge.net>
+
+ Files: include/gutenprint/util.h (1.8) (+4 -2)
+ src/main/escp2-driver.c (1.56) (+12 -21)
+ src/main/print-olympus.c (1.96) (+4 -7)
+ src/main/print-util.c (1.117) (+7 -1)
+ src/main/printers.c (1.87) (+2 -2)
+
+ Fix stp_get_printer_by_device_id (compiler warnings should have caught this)
+
+ Add stp_write_raw() to avoid clumsy stp_zfwrite().
+
+ Fix drying time functions in Epson driver.
+
+2010-06-25 <rlk@sourceforge.net>
+
+ Files: src/main/escp2-driver.c (1.55) (+4 -4)
+
+ Fix ScanDryTime, ScanMinDryTime, and PageDryTime.
+
+2010-06-20 <rlk@sourceforge.net>
+
+ Files: src/main/print-escp2-data.c (1.272) (+12 -10)
+ src/main/print-escp2.c (1.429) (+16 -7)
+ src/main/print-escp2.h (1.138) (+23 -22)
+ src/xml/escp2/model/model_47.xml (1.10) (+1 -1)
+
+ Change HorizontalOnly borderless mode to VerticalRestricted, and add
+ a true HorizontalOnly borderless mode for printers that really do
+ support only borderless.
+
+2010-06-19 <faust3@sourceforge.net>
+
+ Files: src/foomatic/foomatic-printermap (1.197) (+1 -0)
+ src/main/canon-inks.h (1.24) (+10 -0)
+ src/main/canon-modes.h (1.32) (+5 -0)
+ src/main/canon-printers.h (1.50) (+14 -0)
+ src/xml/printers.xml (1.49) (+2 -1)
+
+ Canon PIXMA MP970 support patch by Sergei Epiphanov <serpiph qt nikiet.ru>
+
+2010-06-14 <rlk@sourceforge.net>
+
+ Files: src/main/print-escp2.c (1.428) (+2 -1)
+
+ Fix typo
+
+2010-06-14 <rlk@sourceforge.net>
+
+ Files: src/xml/escp2/model/Makefile.am (1.19) (+2 -1)
+ src/xml/escp2/model/model_101.xml (1.1) (added)
+ src/xml/printers.xml (1.48) (+5 -5)
+
+ Fix Epson S20, S21, T20, T21
+
+2010-06-14 <rlk@sourceforge.net>
+
+ Files: src/main/print-escp2.c (1.427) (+17 -2)
+
+ Add AllowOtherMedia to permit media sizes other than CDs when printing
+ to CD tray, for third party trays.
+
+2010-04-27 <rlk@sourceforge.net>
+
+ Files: src/xml/printers.xml (1.47) (+2 -2)
+
+ Canon ImageRunner 330s is large format.
+
+2010-04-19 <rlk@sourceforge.net>
+
+ Files: configure.ac (1.217) (+3 -3)
+ po/fi.po (1.1) (added)
+
+ Add Finnish translation
+
+2010-02-14 <rlk@sourceforge.net>
+
+ Files: po/hu.po (1.30) (+5494 -6467)
+
+ Update Hungarian translation
+
+===============================================================================
+Name: gutenprint-5_2_5
+
+2010-02-12 <rlk@sourceforge.net>
+
+ Files: po/cs.po (1.57) (+5006 -4636)
+ po/da.po (1.99) (+4988 -4616)
+ po/de.po (1.72) (+5397 -4899)
+ po/el.po (1.72) (+5007 -4636)
+ po/en_GB.po (1.165) (+4989 -4618)
+ po/es.po (1.70) (+5006 -4636)
+ po/fr.po (1.98) (+4989 -4618)
+ po/hu.po (1.29) (+4989 -4618)
+ po/it.po (1.9) (+4988 -4616)
+ po/ja.po (1.66) (+5006 -4636)
+ po/nb.po (1.31) (+5008 -4637)
+ po/nl.po (1.82) (+4988 -4616)
+ po/pl.po (1.76) (+5009 -4640)
+ po/pt.po (1.71) (+5006 -4636)
+ po/ru.po (1.4) (+4995 -4624)
+ po/sk.po (1.75) (+5006 -4636)
+ po/sv.po (1.101) (+4990 -4619)
+ po/zh_TW.po (1.31) (+4989 -4618)
+
+ Gutenprint 5.2.5 release
+
2010-02-12 <rlk@sourceforge.net>
Files: NEWS (1.423) (+5 -1)