summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2008-10-26 17:28:54 +0000
committerRoger Leigh <rleigh@debian.org>2008-10-26 17:28:54 +0000
commit33a17feb28af2d2aeabc8c7ab5ef509ea3de15a7 (patch)
treed444cf1a245694bd049a9e6722c41b8f280ad429 /Makefile.am
parent9d82a443d65ea3e4e015ba6988208231fa8fdc77 (diff)
Imported Upstream version 5.2.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 576eea8..976ed9b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
## Process this file with automake to produce Makefile.in
-## $Id: Makefile.am,v 1.151 2008/04/12 22:41:01 rlk Exp $
+## $Id: Makefile.am,v 1.154 2008/10/06 12:38:07 rlk Exp $
## Copyright (C) 2000-2004 Roger Leigh
##
## This program is free software; you can redistribute it and/or modify
@@ -30,6 +30,7 @@ include $(top_srcdir)/scripts/global.mk
SUBDIRS = include src samples test po man doc scripts
DISTDIRS = m4 m4extra
+docdir = $(datadir)/$(PACKAGE)/doc
## Rules
@@ -38,6 +39,17 @@ libtool: $(LIBTOOL_DEPS)
cd $(srcdir); \
$(SHELL) ./config.status --recheck
+# Don't list ChangeLog as a dependency here because it forces network
+# access, and because it usually runs as superuser rather than the user
+# who normally builds Gutenprint.
+install-data-local: NEWS AUTHORS COPYING README
+ $(mkdir_p) $(DESTDIR)$(docdir)
+ $(INSTALL_DATA) $(srcdir)/NEWS $(DESTDIR)$(docdir)
+ $(INSTALL_DATA) $(srcdir)/ChangeLog $(DESTDIR)$(docdir)
+ $(INSTALL_DATA) $(srcdir)/AUTHORS $(DESTDIR)$(docdir)
+ $(INSTALL_DATA) $(srcdir)/COPYING $(DESTDIR)$(docdir)
+ $(INSTALL_DATA) $(srcdir)/README $(DESTDIR)$(docdir)
+
# This rather strange-looking code ensures that the change log is only
# rebuilt if any of the CVS/Entries files have changed since the change log
# was last built.
@@ -60,7 +72,7 @@ ChangeLog: ChangeLogStamp
echo "ChangeLog: .noupdate found: NOT updating ChangeLog from CVS" ; \
elif test -d CVS ; then \
echo "ChangeLog: Updating ChangeLog from CVS" ; \
- cvs log | $(PERL) scripts/mkchlog > ChangeLog.tmp ; \
+ cvs log | $(PERL) scripts/mkchlog -e @sourceforge.net -X src/xml/escp2/resolutions -s '^(guten|gimp-|)print-[0-9]+_' > ChangeLog.tmp ; \
if test -s ChangeLog.tmp ; then \
mv ChangeLog.tmp ChangeLog ; \
else \
@@ -196,7 +208,7 @@ MAINTAINERCLEANFILES = \
$(CLEANMFOUR) \
$(CLEANPO)
-EXTRA_DIST = autogen.sh ChangeLogStamp
+EXTRA_DIST = autogen.sh ChangeLogStamp README.package
.PHONY: deb html install-cups install-gimp install-ghost snapshot ChangeLogPhony dist-time-check