summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2008-11-17 23:45:56 +0000
committerRoger Leigh <rleigh@debian.org>2008-11-17 23:45:56 +0000
commit15fd5cc391273464beef576568675599633a9827 (patch)
treee7d832b47e388c2691310404e2f9e2961d89705a /Makefile.in
parent33a17feb28af2d2aeabc8c7ab5ef509ea3de15a7 (diff)
Imported Upstream version 5.2.2
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in28
1 files changed, 14 insertions, 14 deletions
diff --git a/Makefile.in b/Makefile.in
index ac8309a..788e091 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -328,7 +328,7 @@ CLEANPO = \
po/remove-potcdate.sin \
po/Rules-quot
-CLEANFILES = .noupdate
+CLEANFILES = .noupdate ChangeLog.tmp
MAINTAINERCLEANFILES = \
ABOUT-NLS \
INSTALL \
@@ -852,23 +852,23 @@ ChangeLogStamp: ChangeLogPhony
ChangeLog: ChangeLogStamp
@cd $(top_srcdir) ; \
if test -f $(top_builddir)/.noupdate ; then \
- echo "ChangeLog: .noupdate found: NOT updating ChangeLog from CVS" ; \
+ echo "$@: .noupdate found: NOT updating $@ from CVS" ; \
elif test -d CVS ; then \
- echo "ChangeLog: Updating ChangeLog from CVS" ; \
- cvs log | $(PERL) scripts/mkchlog -e @sourceforge.net -X src/xml/escp2/resolutions -s '^(guten|gimp-|)print-[0-9]+_' > ChangeLog.tmp ; \
- if test -s ChangeLog.tmp ; then \
- mv ChangeLog.tmp ChangeLog ; \
+ echo "$@: Updating $@ from CVS" ; \
+ cvs log | $(PERL) scripts/mkchlog -e @sourceforge.net -X src/xml/escp2/resolutions -s '^(guten|gimp-|)print-[0-9]+_' > $@.tmp ; \
+ if test -s $@.tmp ; then \
+ mv $@.tmp $@ ; \
else \
- echo "ChangeLog: Failed to update ChangeLog ['touch .noupdate' to skip]" ; \
- $(RM) ChangeLog.tmp ; \
+ echo "$@: Failed to update $@ ['touch .noupdate' to skip]" ; \
+ $(RM) $@.tmp ; \
exit 1 ; \
fi \
- elif test -s ChangeLog ; then \
- echo "ChangeLog: This is not a CVS version of Gutenprint" ; \
- echo "ChangeLog: Not updating ChangeLog from CVS!" ; \
+ elif test -s $@ ; then \
+ echo "$@: This is not a CVS version of Gutenprint" ; \
+ echo "$@: Not updating $@ from CVS!" ; \
else \
- echo "ChangeLog: No ChangeLog or ChangeLog of zero size found!" ; \
- echo "ChangeLog: Failed to update ChangeLog ['touch .noupdate' to skip]" ; \
+ echo "$@: No $@ or $@ of zero size found!" ; \
+ echo "$@: Failed to update $@ ['touch .noupdate' to skip]" ; \
exit 1 ; \
fi
@@ -933,7 +933,7 @@ pdf:
snapshot:
$(MAKE) dist distdir=$(PACKAGE)`date +"%Y%m%d"`
-.PHONY: deb html install-cups install-gimp install-ghost snapshot ChangeLogPhony dist-time-check
+.PHONY: deb html install-cups install-gimp install-ghost snapshot ChangeLog Phony dist-time-check
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: