summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2019-09-13 17:56:14 +0200
committerDidier Raboud <odyx@debian.org>2019-09-13 17:56:14 +0200
commitb38516f13a1f563aa1eb7faf80965755ac63e3e6 (patch)
treefd60cd4095a45f7327d28dfe04bbfb34b7d7215a /Makefile.in
parente50542121e724e851fc5d6c68bb773f80c0bc12c (diff)
New upstream version 5.3.3
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in204
1 files changed, 98 insertions, 106 deletions
diff --git a/Makefile.in b/Makefile.in
index 18b54d6..3bb3145 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -94,16 +94,17 @@ build_triplet = @build@
host_triplet = @host@
subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
- $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/intlmacosx.m4 \
+am__aclocal_m4_deps = $(top_srcdir)/m4local/stp.m4 \
+ $(top_srcdir)/m4local/stp_cups.m4 \
+ $(top_srcdir)/m4local/stp_option.m4 \
+ $(top_srcdir)/m4/gettext.m4 $(top_srcdir)/m4/iconv.m4 \
$(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
$(top_srcdir)/m4/lib-prefix.m4 $(top_srcdir)/m4/libtool.m4 \
$(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
$(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
$(top_srcdir)/m4/nls.m4 $(top_srcdir)/m4/po.m4 \
- $(top_srcdir)/m4/progtest.m4 $(top_srcdir)/m4/stp.m4 \
- $(top_srcdir)/m4/stp_cups.m4 $(top_srcdir)/m4/stp_option.m4 \
- $(top_srcdir)/m4/stp_release.m4 $(top_srcdir)/configure.ac
+ $(top_srcdir)/m4/progtest.m4 $(top_srcdir)/m4/stp_release.m4 \
+ $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
DIST_COMMON = $(srcdir)/Makefile.am $(top_srcdir)/configure \
@@ -269,7 +270,6 @@ EXEEXT = @EXEEXT@
FGREP = @FGREP@
FIND = @FIND@
GENPPD_LIBS = @GENPPD_LIBS@
-GETTEXT_MACRO_VERSION = @GETTEXT_MACRO_VERSION@
GIMP2_CFLAGS = @GIMP2_CFLAGS@
GIMP2_LIBS = @GIMP2_LIBS@
GIMPTOOL2_CHECK = @GIMPTOOL2_CHECK@
@@ -378,7 +378,6 @@ VERSION = @VERSION@
WHICH_PPDS = @WHICH_PPDS@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
-XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
XZ = @XZ@
YACC = @YACC@
YFLAGS = @YFLAGS@
@@ -451,8 +450,10 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
ACLOCAL_AMFLAGS = -I m4 -I m4local
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(LOCAL_CPPFLAGS) $(GNUCFLAGS)
+BUILT_SOURCES = src/xml/xmli18n-tmp.h
SUBDIRS = include src samples test po man doc scripts
DISTDIRS = m4 m4extra
+CONFIGSUMMARYDIR = $(pkglibdir)/@GUTENPRINT_MAJOR_VERSION@.@GUTENPRINT_MINOR_VERSION@
#################################################################
# TESTING #
@@ -460,38 +461,38 @@ DISTDIRS = m4 m4extra
CPUS = `scripts/count-cpus`
# STP_PROFILE=full
-MAKECHECK = STP_TEST_SUITE=1 /usr/bin/time make -k -s -j$(CPUS) DISTCHECK_CONFIGURE_FLAGS=NO_PKGCONFIG_PATHS=1 check
-MAKEDISTCHECK = STP_TEST_SUITE=1 STP_TEST_DIST=1 /usr/bin/time make -k -s -j$(CPUS) DISTCHECK_CONFIGURE_FLAGS=NO_PKGCONFIG_PATHS=1 distcheck
+MAKECHECK = STP_TEST_SUITE=1 /usr/bin/time $(MAKE) -k -s -j$(CPUS) DISTCHECK_CONFIGURE_FLAGS=NO_PKGCONFIG_PATHS=1 check
+MAKEDISTCHECK = STP_TEST_SUITE=1 STP_TEST_DIST=1 /usr/bin/time $(MAKE) -k -s -j$(CPUS) DISTCHECK_CONFIGURE_FLAGS=NO_PKGCONFIG_PATHS=1 distcheck
MAKECHECK_PARALLEL = STP_PARALLEL=$(CPUS) $(MAKECHECK)
MAKEDISTCHECK_PARALLEL = STP_PARALLEL=$(CPUS) $(MAKEDISTCHECK)
-CLEANSCRIPTS = \
- scripts/depcomp \
- scripts/install-sh \
- scripts/ltconfig \
- scripts/mdate-sh \
- scripts/missing \
- scripts/mkinstalldirs
+# ...but we can't do
+# AM_TESTS_ENVIRONMENT=STP_PARALLEL=$(shell scripts/count-cpus)
+# because $(shell...) is (still only) a GNU extension, which we
+# want to avoid. And we can't do
+# AM_TESTS_ENVIRONMENT=STP_PARALLEL=`scripts/count-cpus`
+# because all expansions are lazy, so anything not in the root directory
+# won't find the script. And we can't even do
+# AM_TESTS_ENVIRONMENT=STP_PARALLEL=`(at)TOP_BUILDDIR(at)scripts/count-cpus`
+# because TOP_BUILDDIR itself is a relative path. And, just to make it
+# even more fun, we won't be able to do
+# AM_TESTS_ENVIRONMENT!=
+# syntax even if POSIX approves it because it's only present in GNU make 4,
+# but Apple doesn't use that.
+
+# check-%: is a GNU make extension, so we have to explicitly list the targets
+# of interest. Bah humbug.
+CHECK_TARGETS = check-parallel check-minimal check-fast check-full
+CHECK_VALGRIND_TARGETS = check-valgrind check-valgrind-minimal check-valgrind-fast
+DISTCHECK_TARGETS = distcheck-parallel distcheck-minimal distcheck-fast distcheck-full
+DISTCHECK_VALGRIND_TARGETS = distcheck-valgrind distcheck-valgrind-minimal distcheck-valgrind-fast
CLEANMFOUR = \
- m4/codeset.m4 \
- m4/gettext.m4 \
- m4/glibc21.m4 \
- m4/iconv.m4 \
- m4/intdiv0.m4 \
- m4/inttypes_h.m4 \
- m4/inttypes.m4 \
- m4/inttypes-pri.m4 \
- m4/isc-posix.m4 \
- m4/lcmessage.m4 \
- m4/lib-ld.m4 \
- m4/lib-link.m4 \
- m4/lib-prefix.m4 \
- m4/progtest.m4 \
- m4/stdint_h.m4 \
- m4/uintmax_t.m4 \
- m4/ulonglong.m4
+ m4/*
CLEANPO = \
+ po/ChangeLog \
+ po/gutenprint.pot \
+ po/Makefile.in.in \
po/boldquot.sed \
po/en@boldquot.header \
po/en@quot.header \
@@ -499,7 +500,8 @@ CLEANPO = \
po/Makevars.template \
po/quot.sed \
po/remove-potcdate.sin \
- po/Rules-quot
+ po/Rules-quot \
+ po/*~
CLEANFILES = .noupdate
MAINTAINERCLEANFILES = \
@@ -508,19 +510,21 @@ MAINTAINERCLEANFILES = \
INSTALL \
aclocal.m4 \
config.h.in \
+ config.h.in~ \
+ config.rpath \
configure \
+ git-version-stamp \
Makefile.in \
stamp-h.in \
stamp-h1.in \
stamp-h2.in \
stamp-h3.in \
stamp-h4.in \
- $(CLEANSCRIPTS) \
$(CLEANMFOUR) \
$(CLEANPO)
EXTRA_DIST = autogen.sh README.package git-version-stamp
-all: config.h
+all: $(BUILT_SOURCES) config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive
.SUFFIXES:
@@ -693,12 +697,6 @@ distdir: $(BUILT_SOURCES)
$(MAKE) $(AM_MAKEFLAGS) distdir-am
distdir-am: $(DISTFILES)
- @case `sed 15q $(srcdir)/NEWS` in \
- *"$(VERSION)"*) : ;; \
- *) \
- echo "NEWS not updated; not releasing" 1>&2; \
- exit 1;; \
- esac
$(am__remove_distdir)
test -d "$(distdir)" || mkdir "$(distdir)"
@srcdirstrip=`echo "$(srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
@@ -888,11 +886,13 @@ distcleancheck: distclean
$(distcleancheck_listfiles) ; \
exit 1; } >&2
check-am: all-am
-check: check-recursive
+check: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) check-recursive
all-am: Makefile config.h
installdirs: installdirs-recursive
installdirs-am:
-install: install-recursive
+install: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) install-recursive
install-exec: install-exec-recursive
install-data: install-data-recursive
uninstall: uninstall-recursive
@@ -923,6 +923,7 @@ distclean-generic:
maintainer-clean-generic:
@echo "This command is intended for maintainers to use"
@echo "it deletes files that may require special tools to rebuild."
+ -test -z "$(BUILT_SOURCES)" || rm -f $(BUILT_SOURCES)
-test -z "$(MAINTAINERCLEANFILES)" || rm -f $(MAINTAINERCLEANFILES)
clean: clean-recursive
@@ -992,9 +993,10 @@ ps: ps-recursive
ps-am:
-uninstall-am:
+uninstall-am: uninstall-local
-.MAKE: $(am__recursive_targets) all install-am install-strip
+.MAKE: $(am__recursive_targets) all check install install-am \
+ install-strip
.PHONY: $(am__recursive_targets) CTAGS GTAGS TAGS all all-am \
am--refresh check check-am clean clean-cscope clean-generic \
@@ -1012,7 +1014,7 @@ uninstall-am:
installcheck-am installdirs installdirs-am maintainer-clean \
maintainer-clean-generic mostlyclean mostlyclean-generic \
mostlyclean-libtool pdf pdf-am ps ps-am tags tags-am uninstall \
- uninstall-am
+ uninstall-am uninstall-local
.PRECIOUS: Makefile
@@ -1029,6 +1031,9 @@ $(top_builddir)/src/gutenprintui2/libgutenprintui2.la:
cd $(top_builddir)/src/gutenprintui2; \
$(MAKE)
+src/xml/xmli18n-tmp.h:
+ $(MAKE) -C src/xml
+
# Libtool dependency
libtool: $(LIBTOOL_DEPS)
cd $(srcdir); \
@@ -1037,6 +1042,7 @@ libtool: $(LIBTOOL_DEPS)
# Don't list ChangeLog as a dependency here because it forces network
# access, and because it usually runs as superuser rather than the user
# who normally builds Gutenprint.
+# Don't list config.summary either because it's generated by configure.
install-data-local: NEWS AUTHORS COPYING README
$(MKDIR_P) $(DESTDIR)$(docdir)
$(INSTALL_DATA) $(srcdir)/NEWS $(DESTDIR)$(docdir)
@@ -1044,27 +1050,60 @@ install-data-local: NEWS AUTHORS COPYING README
$(INSTALL_DATA) $(srcdir)/AUTHORS $(DESTDIR)$(docdir)
$(INSTALL_DATA) $(srcdir)/COPYING $(DESTDIR)$(docdir)
$(INSTALL_DATA) $(srcdir)/README $(DESTDIR)$(docdir)
+ $(MKDIR_P) $(DESTDIR)$(CONFIGSUMMARYDIR)
+ $(INSTALL_DATA) config.summary $(DESTDIR)$(CONFIGSUMMARYDIR)
# git log is local, so it's fast enough that we don't need to
# engage in any subterfuge like we did with CVS. It's really fast
# when we use a static file from the pre-Git era (since there are no
# live branches from that time) to save a lot of diffs.
-ChangeLog:
+# This isn't really the right spot for these checks.
+# It's perfectly legal to update the change log even if NEWS
+# or configure is out of date. But it greatly reduces build spew
+# to do it here, and manually updating the changelog is not a
+# normal thing to do.
+ChangeLog: dist-time-check dist-news-check
if [ -d .git -a -f ChangeLog.pre-5.2.11 ] ; then \
$(MAKE) -C scripts mkgitlog; \
scripts/mkgitlog -i ChangeLog.pre-5.2.11 -r gutenprint-5_2_11 > ChangeLog; \
fi
+dist: src/xml/xmli18n-tmp.h
+
dist-time-check:
@if [ "$(top_srcdir)/configure" -ot "$(top_srcdir)/configure.ac" ] ; then \
- echo "*** configure is out of date (older than configure.ac) -- rerun ./autogen.sh first!"; exit 1; \
+ echo 1>&2; \
+ echo "****************************************************************" 1>&2; \
+ echo "*** configure is out of date (older than configure.ac) -- rerun ./autogen.sh first!" 1>&2; \
+ echo "****************************************************************" 1>&2; \
+ echo 1>&2; \
+ exit 1; \
+ fi
+
+# This would normally be done by AM_INIT_AUTOMAKE. However,
+# we don't want to do this if we're building a snapshot, because
+# we don't want to update the NEWS file for each snapshot and
+# there's no convenient way I've found to conditionalize the
+# automake options.
+dist-news-check:
+ @if [ "$$STP_BUILD_SNAPSHOT" = "" ] ; then \
+ case "`sed 15q $(srcdir)/NEWS`" in \
+ *$(VERSION)*) : ;; \
+ *) \
+ echo 1>&2; \
+ echo "****************************************************************" 1>&2; \
+ echo "*** NEWS not updated to $(VERSION); not releasing" 1>&2; \
+ echo "****************************************************************" 1>&2; \
+ echo 1>&2; \
+ exit 1; \
+ esac ; \
fi
git-version-stamp:
if [ -d .git ] ; then scripts/gversion > /dev/null; fi
-dist-hook: dist-time-check git-version-stamp
+dist-hook: dist-time-check dist-news-check git-version-stamp
for dir in $(DISTDIRS) ; do \
if test -d $(srcdir)/$$dir ; then \
mkdir $(distdir)/$$dir; \
@@ -1081,66 +1120,16 @@ dist-hook: dist-time-check git-version-stamp
$(FIND) $(distdir) -name '*~' -print | xargs $(RM) -rf
snapshot: scripts/gversion git-version-stamp
- $(MAKE) dist distdir=$(PACKAGE)-`scripts/gversion`-`date +"%Y%m%d"`
+ $(MAKE) dist distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d%H%M%S"`
-# ...but we can't do
-# AM_TESTS_ENVIRONMENT=STP_PARALLEL=$(shell scripts/count-cpus)
-# because $(shell...) is (still only) a GNU extension, which we
-# want to avoid. And we can't do
-# AM_TESTS_ENVIRONMENT=STP_PARALLEL=`scripts/count-cpus`
-# because all expansions are lazy, so anything not in the root directory
-# won't find the script. And we can't even do
-# AM_TESTS_ENVIRONMENT=STP_PARALLEL=`(at)TOP_BUILDDIR(at)scripts/count-cpus`
-# because TOP_BUILDDIR itself is a relative path. And, just to make it
-# even more fun, we won't be able to do
-# AM_TESTS_ENVIRONMENT!=
-# syntax even if POSIX approves it because it's only present in GNU make 4,
-# but Apple doesn't use that.
-
-check-parallel: scripts/count-cpus
- $(MAKECHECK_PARALLEL)
-
-check-minimal: scripts/count-cpus
- STP_TEST_PROFILE=minimal $(MAKECHECK_PARALLEL)
-
-check-fast: scripts/count-cpus
- STP_TEST_PROFILE=fast $(MAKECHECK_PARALLEL)
+$(CHECK_TARGETS) $(CHECK_VALGRIND_TARGETS):
+ STP_TEST_PROFILE=`echo $@ |sed -e s/check-// -e s/-/_/g -e s/parallel//` $(MAKECHECK_PARALLEL)
-check-full: scripts/count-cpus
- STP_TEST_PROFILE=full $(MAKECHECK_PARALLEL)
-
-check-valgrind-minimal: scripts/count-cpus
- STP_TEST_PROFILE=valgrind_minimal $(MAKECHECK_PARALLEL)
-
-check-valgrind-fast: scripts/count-cpus
- STP_TEST_PROFILE=valgrind_fast $(MAKECHECK_PARALLEL)
-
-check-valgrind: scripts/count-cpus
- STP_TEST_PROFILE=valgrind $(MAKECHECK_PARALLEL)
-
-distcheck-parallel: scripts/count-cpus
- $(MAKEDISTCHECK_PARALLEL)
-
-distcheck-minimal: scripts/count-cpus
- STP_TEST_PROFILE=minimal $(MAKEDISTCHECK_PARALLEL)
-
-distcheck-fast: scripts/count-cpus
- STP_TEST_PROFILE=fast $(MAKEDISTCHECK_PARALLEL)
-
-distcheck-full: scripts/count-cpus
- STP_TEST_PROFILE=full $(MAKEDISTCHECK_PARALLEL)
-
-distcheck-valgrind-minimal: scripts/count-cpus
- STP_TEST_PROFILE=valgrind_minimal $(MAKEDISTCHECK_PARALLEL)
-
-distcheck-valgrind-fast: scripts/count-cpus
- STP_TEST_PROFILE=valgrind_fast $(MAKEDISTCHECK_PARALLEL)
-
-distcheck-valgrind: scripts/count-cpus
- STP_TEST_PROFILE=valgrind $(MAKEDISTCHECK_PARALLEL)
+$(DISTCHECK_TARGETS) $(DISTCHECK_VALGRIND_TARGETS):
+ STP_TEST_PROFILE=`echo $@ |sed -e s/distcheck-// -e s/-/_/g -e s/parallel//` $(MAKEDISTCHECK_PARALLEL)
checksums: scripts/count-cpus
- STP_PARALLEL=$(CPUS) make -C src/testpattern checksums-release
+ STP_PARALLEL=$(CPUS) $(MAKE) -j$(CPUS) -C src/testpattern checksums-release
build-release: scripts/build-release scripts/count-cpus
STP_PARALLEL=$(CPUS) /usr/bin/time scripts/build-release
@@ -1151,6 +1140,9 @@ sanity: scripts/build-release scripts/count-cpus
distclean-local:
-rm -f config.summary
+uninstall-local:
+ -rm -f $(DESTDIR)$(CONFIGSUMMARYDIR)/config.summary
+
.PHONY: deb html install-cups install-gimp snapshot ChangeLog Phony dist-time-check git-version-stamp
# Tell versions [3.59,3.63) of GNU make to not export all variables.