summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSolomon Peachy <pizza@shaftnet.org>2016-09-25 15:13:06 -0400
committerDidier Raboud <odyx@debian.org>2016-09-24 19:05:20 +0200
commit112917b0acf923ffa3632fc19a1fbde71d676baf (patch)
tree31cc372a004755a1d3152cdde34a8d4ea3dc0368 /configure.ac
parentc8f5e0cee42c345ab59d33c3df7f3e50ccb8a920 (diff)
build: Fix inverted tests that broke module loads.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5919a71..a9e4291 100644
--- a/configure.ac
+++ b/configure.ac
@@ -878,7 +878,7 @@ fi
# define what module system is to be used
AC_MSG_CHECKING([which module system will be used])
if test x$USE_LTDL = xtrue; then
- if test -n "$WITH_MODULES" ; then
+ if test -z "$WITH_MODULES" ; then
MODULE="false"
else
MODULE="true"
@@ -890,7 +890,7 @@ if test x$USE_LTDL = xtrue; then
AC_DEFINE(USE_LTDL, "1", [Use GNU libltdl as module loader])
AC_MSG_RESULT([ltdl])
elif test x$USE_DLOPEN = xtrue; then
- if test -n "$WITH_MODULES" ; then
+ if test -z "$WITH_MODULES" ; then
MODULE="false"
else
MODULE="true"