summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2014-04-16 08:13:45 +0200
committerDidier Raboud <odyx@debian.org>2014-04-16 08:13:45 +0200
commit68062125a3214a6262bb1899b81f93abb35c8be9 (patch)
treec2eaee20fb0e6771187aa50f9fa4fb4850564f5b /configure.ac
parentd7d42f6c969dc54157d85b7b6b611581bbfa7595 (diff)
Imported Upstream version 5.2.10~pre2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index b423cc6..1c557e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-dnl $Id: configure.ac,v 1.257 2014/02/15 16:15:36 rlk Exp $
+dnl $Id: configure.ac,v 1.260 2014/03/07 02:47:32 rlk Exp $
dnl Copyright (C) 2001-2004 Roger Leigh
dnl
dnl This program is free software; you can redistribute it and/or modify
@@ -48,15 +48,16 @@ dnl 3 (that is, GCI - GBA) and go directly from 2 to 4.
dnl
dnl For example:
dnl GCI=3, GBA=1 => .soname = libgutenprint.so.2.1
-dnl GCI=4, GBA=2 => .soname = libgutenprint.so.2.2
+dnl GCI=4, GBA=2 => .soname = libgutenprint.so.2.2 (5.2.9)
+dnl GCI=5, GBA=3 => .soname = libgutenprint.so.2.3 (5.2.10)
dnl (and so on for 5.2 releases, which must remain compatible)
dnl GCI=4, GBA=0 => .soname = libgutenprint.so.4.0
dnl GCI=5, GBA=1 => .soname = libgutenprint.so.4.1
dnl GCI=6, GBA=2 => .soname = libgutenprint.so.4.2
dnl (for Gutenprint 5.3 or 5.4 or 6.0 or whatever)
-dnl GCI=5, GBA=0 => .soname = libgutenprint.so.4.0
-dnl GCI=6, GBA=1 => .soname = libgutenprint.so.4.1
-dnl GCI=7, GBA=2 => .soname = libgutenprint.so.4.2
+dnl GCI=5, GBA=0 => .soname = libgutenprint.so.5.0
+dnl GCI=6, GBA=1 => .soname = libgutenprint.so.5.1
+dnl GCI=7, GBA=2 => .soname = libgutenprint.so.5.2
dnl (for the next major/minor release beyond that)
dnl
dnl Typically, programs will require a certain major number to be matched
@@ -77,16 +78,16 @@ pushdef([GUTENPRINT_NAME], [gutenprint])
pushdef([GUTENPRINT_MAJOR_VERSION], [5])
pushdef([GUTENPRINT_MINOR_VERSION], [2])
pushdef([GUTENPRINT_MICRO_VERSION], [10])
-pushdef([GUTENPRINT_EXTRA_VERSION], [-pre1])
-pushdef([GUTENPRINT_CURRENT_INTERFACE], [4])
-pushdef([GUTENPRINT_BINARY_AGE], [2])
+pushdef([GUTENPRINT_EXTRA_VERSION], [-pre2])
+pushdef([GUTENPRINT_CURRENT_INTERFACE], [5])
+pushdef([GUTENPRINT_BINARY_AGE], [3])
pushdef([GUTENPRINTUI2_CURRENT_INTERFACE], [1])
pushdef([GUTENPRINTUI2_BINARY_AGE], [0])
pushdef([GUTENPRINT_VERSION], GUTENPRINT_MAJOR_VERSION.GUTENPRINT_MINOR_VERSION.GUTENPRINT_MICRO_VERSION[]GUTENPRINT_EXTRA_VERSION)
AC_INIT(GUTENPRINT_NAME, GUTENPRINT_VERSION, [gimp-print-devel@lists.sourceforge.net])
AC_PREREQ(2.53)
-AC_REVISION($Revision: 1.257 $)
+AC_REVISION($Revision: 1.260 $)
AC_CONFIG_SRCDIR(src/main/print-vars.c)
AC_CONFIG_AUX_DIR(scripts)
STP_INIT