summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2012-07-09 23:15:00 +0100
committerRoger Leigh <rleigh@debian.org>2012-07-09 23:15:00 +0100
commitccd50c2bd4db57503722816aa23a5092cbe69f40 (patch)
tree7b2fffb9ec06a2f0fcf3b25dba66cc04409db70e /configure.ac
parent3514df18b289ec827cb6e4c446419feab1813231 (diff)
Imported Upstream version 5.2.9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 23 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 0dc3241..5a0da63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-dnl $Id: configure.ac,v 1.233 2012/06/05 01:51:22 rlk Exp $
+dnl $Id: configure.ac,v 1.236 2012/07/02 11:47:36 rlk Exp $
dnl Copyright (C) 2001-2004 Roger Leigh
dnl
dnl This program is free software; you can redistribute it and/or modify
@@ -23,33 +23,39 @@ dnl
dnl Since the last release:
dnl 1. if only source code (not the interface) has changed, set
dnl GUTENPRINT_MICRO_VERSION += 1;
-dnl GUTENPRINT_INTERFACE_AGE += 1;
dnl 2. if any functions have been added, removed, or changed, set
-dnl GUTENPRINT_INTERFACE_AGE = 0;
dnl GUTENPRINT_CURRENT_INTERFACE += 1;
dnl 3. if interfaces have been added, set
dnl GUTENPRINT_BINARY_AGE += 1;
-dnl 4. if interfaces have been removed, set
+dnl or, if interfaces have been removed, set
+dnl GUTENPRINT_CURRENT_INTERFACE -= GUTENPRINT_BINARY_AGE
dnl GUTENPRINT_BINARY_AGE = 0;
dnl
+dnl The .soname version is
+dnl (GUTENPRINT_CURRENT_INTERFACE - GUTENPRINT_BINARY_AGE).GUTENPRINT_BINARY_AGE
+dnl Example: if GUTENPRINT_CURRENT_INTERFACE is 3 and GUTENPRINT_BINARY_AGE is
+dnl 1, the version is 2.1. To get 2.2, GUTENPRINT_CURRENT_INTERFACE would be
+dnl incremented to 4 and GUTENPRINT_BINARY_AGE to 2.
+dnl
+dnl *NOTE*: due to an error preparing 5.2.8, we must skip over major version of
+dnl 3 and go directly from 2 to 4.
+dnl
dnl For more detailed information, see the libtool info documentation.
dnl
pushdef([GUTENPRINT_NAME], [gutenprint])
pushdef([GUTENPRINT_MAJOR_VERSION], [5])
pushdef([GUTENPRINT_MINOR_VERSION], [2])
-pushdef([GUTENPRINT_MICRO_VERSION], [8])
+pushdef([GUTENPRINT_MICRO_VERSION], [9])
pushdef([GUTENPRINT_EXTRA_VERSION], [])
pushdef([GUTENPRINT_CURRENT_INTERFACE], [3])
-pushdef([GUTENPRINT_INTERFACE_AGE], [0])
-pushdef([GUTENPRINT_BINARY_AGE], [0])
+pushdef([GUTENPRINT_BINARY_AGE], [1])
pushdef([GUTENPRINTUI2_CURRENT_INTERFACE], [1])
-pushdef([GUTENPRINTUI2_INTERFACE_AGE], [0])
pushdef([GUTENPRINTUI2_BINARY_AGE], [0])
pushdef([GUTENPRINT_VERSION], GUTENPRINT_MAJOR_VERSION.GUTENPRINT_MINOR_VERSION.GUTENPRINT_MICRO_VERSION[]GUTENPRINT_EXTRA_VERSION)
AC_INIT(GUTENPRINT_NAME, GUTENPRINT_VERSION, [gimp-print-devel@lists.sourceforge.net])
AC_PREREQ(2.53)
-AC_REVISION($Revision: 1.233 $)
+AC_REVISION($Revision: 1.236 $)
AC_CONFIG_SRCDIR(src/main/print-vars.c)
AC_CONFIG_AUX_DIR(scripts)
STP_INIT
@@ -76,21 +82,19 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
[GUTENPRINT_MICRO_VERSION]=GUTENPRINT_MICRO_VERSION
[GUTENPRINT_EXTRA_VERSION]=GUTENPRINT_EXTRA_VERSION
[GUTENPRINT_CURRENT_INTERFACE]=GUTENPRINT_CURRENT_INTERFACE
-[GUTENPRINT_INTERFACE_AGE]=GUTENPRINT_INTERFACE_AGE
+[GUTENPRINT_INTERFACE_AGE]=0
[GUTENPRINT_BINARY_AGE]=GUTENPRINT_BINARY_AGE
[GUTENPRINT_VERSION]=GUTENPRINT_VERSION
[GUTENPRINTUI2_CURRENT_INTERFACE]=GUTENPRINTUI2_CURRENT_INTERFACE
-[GUTENPRINTUI2_INTERFACE_AGE]=GUTENPRINTUI2_INTERFACE_AGE
+[GUTENPRINTUI2_INTERFACE_AGE]=0
[GUTENPRINTUI2_BINARY_AGE]=GUTENPRINTUI2_BINARY_AGE
popdef([GUTENPRINT_MAJOR_VERSION])
popdef([GUTENPRINT_MINOR_VERSION])
popdef([GUTENPRINT_MICRO_VERSION])
popdef([GUTENPRINT_EXTRA_VERSION])
popdef([GUTENPRINT_CURRENT_INTERFACE])
-popdef([GUTENPRINT_INTERFACE_AGE])
popdef([GUTENPRINT_BINARY_AGE])
popdef([GUTENPRINTUI2_CURRENT_INTERFACE])
-popdef([GUTENPRINTUI2_INTERFACE_AGE])
popdef([GUTENPRINTUI2_BINARY_AGE])
AC_SUBST([GUTENPRINT_MAJOR_VERSION])
@@ -738,7 +742,11 @@ AC_CHECK_LIB(dl, dlopen, [DLOPEN_LIBS="-ldl"])
AC_CHECK_LIB(m,pow,
GUTENPRINT_LIBDEPS="${GUTENPRINT_LIBDEPS} -lm"
- gutenprint_libdeps="${gutenprint_libdeps} -lm")
+ gutenprint_libdeps="${gutenprint_libdeps} -lm"
+ GUTENPRINTUI2_LIBDEPS="${GUTENPRINT_LIBDEPS} -lm"
+ gutenprintui2_libdeps="${gutenprint_libdeps} -lm"
+ LIBM=-lm
+)
STP_CUPS_LIBS
@@ -950,6 +958,7 @@ AC_SUBST(gutenprintui2_cflags)
gutenprintui2_libs="${GUTENPRINTUI2_LIBS} ${gutenprintui2_libdeps}"
AC_SUBST(gutenprintui2_libs)
AC_SUBST(gutenprintui2_libdeps)
+AC_SUBST(LIBM)
AC_SUBST(LIBREADLINE_DEPS)
AC_SUBST(MAINTAINER_CFLAGS)
AC_SUBST(PLUG_IN_PATH)