summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2016-10-05 09:16:08 +0200
committerDidier Raboud <odyx@debian.org>2016-10-05 09:16:08 +0200
commitd69d392d8c45cdcc93e58f0e1bdbb2b66d6b9566 (patch)
treefbd96013c3d605249b167a97c8862f38f8a1cdee /configure.ac
parent7f5731038556e5b03d2a886163ca2c873c77333d (diff)
New upstream version 5.2.12~pre3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 12 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 5919a71..de15233 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,9 +77,9 @@ pushdef([GUTENPRINT_NAME], [gutenprint])
pushdef([GUTENPRINT_MAJOR_VERSION], [5])
pushdef([GUTENPRINT_MINOR_VERSION], [2])
pushdef([GUTENPRINT_MICRO_VERSION], [12])
-pushdef([GUTENPRINT_EXTRA_VERSION], [-pre2])
-pushdef([GUTENPRINT_CURRENT_INTERFACE], [6])
-pushdef([GUTENPRINT_BINARY_AGE], [4])
+pushdef([GUTENPRINT_EXTRA_VERSION], [-pre3])
+pushdef([GUTENPRINT_CURRENT_INTERFACE], [7])
+pushdef([GUTENPRINT_BINARY_AGE], [5])
pushdef([GUTENPRINTUI2_CURRENT_INTERFACE], [1])
pushdef([GUTENPRINTUI2_BINARY_AGE], [0])
pushdef([GUTENPRINT_VERSION], GUTENPRINT_MAJOR_VERSION.GUTENPRINT_MINOR_VERSION.GUTENPRINT_MICRO_VERSION[]GUTENPRINT_EXTRA_VERSION)
@@ -514,6 +514,8 @@ AC_PROG_INSTALL
AC_PROG_LN_S
AM_PROG_LEX
AC_PROG_YACC
+AC_PROG_MKDIR_P
+AC_PATH_PROG([BZIP2], [bzip2])
AC_PATH_PROG([TEST], [test])
AC_PATH_PROG([TRUE], [true])
AC_PATH_PROG([FIND], [find])
@@ -640,7 +642,7 @@ dnl Compiler flags
if test x$ac_compiler_gnu = "xyes"; then
STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072],, [GNUCFLAGS])
if test x${USE_MAINTAINER_MODE} = xyes ; then
- STP_ADD_COMPILER_ARGS([-pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
+ STP_ADD_COMPILER_ARGS([-D_POSIX_C_SOURCE=200809L -std=c99 -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
fi
if test x$ENABLE_DEBUG = xyes ; then
STP_ADD_COMPILER_ARG([-g])
@@ -878,7 +880,7 @@ fi
# define what module system is to be used
AC_MSG_CHECKING([which module system will be used])
if test x$USE_LTDL = xtrue; then
- if test -n "$WITH_MODULES" ; then
+ if test -z "$WITH_MODULES" -o x$WITH_MODULES = xno -o x$WITH_MODULES = xstatic ; then
MODULE="false"
else
MODULE="true"
@@ -890,7 +892,7 @@ if test x$USE_LTDL = xtrue; then
AC_DEFINE(USE_LTDL, "1", [Use GNU libltdl as module loader])
AC_MSG_RESULT([ltdl])
elif test x$USE_DLOPEN = xtrue; then
- if test -n "$WITH_MODULES" ; then
+ if test -z "$WITH_MODULES" -o x$WITH_MODULES = xno -o x$WITH_MODULES = xstatic ; then
MODULE="false"
else
MODULE="true"
@@ -1019,6 +1021,10 @@ AC_CONFIG_FILES([src/testpattern/run-testpattern-2],
[chmod +x src/testpattern/run-testpattern-2])
AC_CONFIG_FILES([src/testpattern/compare-checksums],
[chmod +x src/testpattern/compare-checksums])
+AC_CONFIG_FILES([src/testpattern/compress-checksums],
+ [chmod +x src/testpattern/compress-checksums])
+AC_CONFIG_FILES([src/testpattern/uncompress-checksums],
+ [chmod +x src/testpattern/uncompress-checksums])
AC_CONFIG_FILES([src/cups/test-rastertogutenprint],
[chmod +x src/cups/test-rastertogutenprint])
AC_CONFIG_FILES([src/testpattern/Makefile])