summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2009-08-02 12:01:21 +0100
committerRoger Leigh <rleigh@debian.org>2009-08-02 12:01:21 +0100
commit0f09a5be038c93c1bd5ca2988e152345bbf74c00 (patch)
tree279995ae9eece33b9b05cd82993f4fce98356fe8 /configure.ac
parenta68ece422e0be1a0101dae2fa2408ef0e533c2e9 (diff)
Imported Upstream version 5.2.4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 18 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3e2f4a9..add2fea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-dnl $Id: configure.ac,v 1.209 2008/12/21 00:04:24 rlk Exp $
+dnl $Id: configure.ac,v 1.214 2009/07/26 20:36:15 rlk Exp $
dnl Copyright (C) 2001-2004 Roger Leigh
dnl
dnl This program is free software; you can redistribute it and/or modify
@@ -37,10 +37,10 @@ dnl
pushdef([GUTENPRINT_NAME], [gutenprint])
pushdef([GUTENPRINT_MAJOR_VERSION], [5])
pushdef([GUTENPRINT_MINOR_VERSION], [2])
-pushdef([GUTENPRINT_MICRO_VERSION], [3])
+pushdef([GUTENPRINT_MICRO_VERSION], [4])
pushdef([GUTENPRINT_EXTRA_VERSION], [])
pushdef([GUTENPRINT_CURRENT_INTERFACE], [2])
-pushdef([GUTENPRINT_INTERFACE_AGE], [3])
+pushdef([GUTENPRINT_INTERFACE_AGE], [5])
pushdef([GUTENPRINT_BINARY_AGE], [0])
pushdef([GUTENPRINTUI2_CURRENT_INTERFACE], [1])
pushdef([GUTENPRINTUI2_INTERFACE_AGE], [0])
@@ -49,7 +49,7 @@ pushdef([GUTENPRINT_VERSION], GUTENPRINT_MAJOR_VERSION.GUTENPRINT_MINOR_VERSION.
AC_INIT(GUTENPRINT_NAME, GUTENPRINT_VERSION, [gimp-print-devel@lists.sourceforge.net])
AC_PREREQ(2.53)
-AC_REVISION($Revision: 1.209 $)
+AC_REVISION($Revision: 1.214 $)
AC_CONFIG_SRCDIR(src/main/print-vars.c)
AC_CONFIG_AUX_DIR(scripts)
STP_INIT
@@ -139,7 +139,7 @@ dnl Specify a configuration file.
AM_CONFIG_HEADER([config.h])
dnl Available languages (translations)
-ALL_LINGUAS="cs da de el en_GB es fr hu it ja nb nl pl pt sk sv zh_TW"
+ALL_LINGUAS="cs da de el en_GB es fr hu it ja nb nl pl pt ru sk sv zh_TW"
AC_SUBST(ALL_LINGUAS)
dnl Set up libtool scripts.
@@ -1105,6 +1105,18 @@ if test $warnings_emitted -ne 0 ; then
echo '*** NOTE: Please review the warnings shown above carefully!'
fi
echo
-echo "Finished configuring. Please review the configuration summary above."
+if test "$BUILD_GIMP2" = "no" -o "$BUILD_CUPS" = "no" ; then
+ echo "VERY IMPORTANT:"
+ echo "If you expect to build the CUPS driver or the enhanced Print plugin for"
+ echo "GIMP, but the output above indicates that that component will not be built,"
+ echo "it almost certainly indicates that development packages required to build"
+ echo "that component are not installed on your system. Please read the README"
+ echo "file and install the necessary development packages before reporting any"
+ echo "error to the development team. Depending upon your operating system version,"
+ echo "you may have to install packages from the installation medium or over"
+ echo "the network."
+ echo
+fi
+echo "Finished configuring. Please review CAREFULLY the configuration summary above."
echo "Type 'make clean' followed by 'make' to build the package"
echo "then 'make install' to install it."