summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2008-11-01 16:25:07 +0000
committerRoger Leigh <rleigh@debian.org>2008-11-01 16:25:07 +0000
commit7e376f5e6281a783be7db69fbd25b6f68d8401ff (patch)
treef88a3666d24a42c2f1ba254f4438455e6b4e70ff /debian/rules
parent476a9ebf8563f2ce3f17ab1757698511b356cfd8 (diff)
[rules] Use quilt in place of dpatch
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 14 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index cb9c668..bb71635 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,7 +8,7 @@
export DH_OPTIONS
# Use dpatch.
-include /usr/share/dpatch/dpatch.make
+include /usr/share/quilt/quilt.make
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
@@ -23,6 +23,17 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
+update-patch-series:
+ mkdir -p $(CURDIR)/debian/patches
+ rm -f $(CURDIR)/debian/patches/*.patch
+ git format-patch -o $(CURDIR)/debian/patches patches ^upstream | \
+ xargs -n 1 basename > $(CURDIR)/debian/patches/series
+ for patch in $$(ls $(CURDIR)/debian/patches/*.patch); do \
+ lines=$$(cat $$patch | wc -l); \
+ head -n $$(($$lines - 3)) $$patch > $${patch}.chomped; \
+ mv $${patch}.chomped $$patch; \
+ done
+
autoconfigure: autoconfigure-stamp
autoconfigure-stamp: debian/control
dh_testdir
@@ -41,7 +52,7 @@ autoconfigure-stamp: debian/control
build: build-stamp debian/control
-build-stamp: patch-stamp autoconfigure-stamp
+build-stamp: patch autoconfigure-stamp
dh_testdir
cd debian/build; \
@@ -128,4 +139,4 @@ binary-arch: build install
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install autoconfigure patch unpatch
+.PHONY: build clean binary-indep binary-arch binary install autoconfigure patch unpatch update-patch-series