summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2006-08-12 18:31:14 +0100
committerRoger Leigh <rleigh@debian.org>2008-10-26 16:17:02 +0000
commitdd943a6805d632e2ad379362f438369e6d6e3e33 (patch)
tree889b0b83f433cb141e18eadb0a50dcea2b52b1fc /debian/rules
parent2cee506fef24acf85160dc2608b45ca56003a13d (diff)
Imported Debian patch 5.0.0-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 1489f1b..fb03318 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,5 @@
#!/usr/bin/make -f
# rules to package gutenprint
-# $Id: rules,v 1.58 2005/06/26 17:06:59 rleigh Exp $
#
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -25,8 +24,8 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
endif
# Get upstream version, and define libgutenprint suffix
-#UPSTREAM_VERSION = $(shell dpkg-parsechangelog | grep ^Version | sed "s/.* //" | sed "s/-[^-]*$$//")
-UPSTREAM_VERSION = 5.0.0-rc3
+UPSTREAM_VERSION = $(shell dpkg-parsechangelog | grep ^Version | sed "s/.* //" | sed "s/-[^-]*$$//")
+#UPSTREAM_VERSION = 5.0.0
UPSTREAM_VERSION_COMPACT = $(shell echo '$(UPSTREAM_VERSION)' | sed "s/\(.*\..*\)\..*/\1/"
#LIBRARY_VERSION = -$(UPSTREAM_VERSION)
LIBRARY_VERSION = 2
@@ -103,7 +102,7 @@ binary-indep: build install
dh_installexamples -i
dh_installchangelogs -i NEWS
dh_link -i
- dh_compress -i
+ dh_compress -i -X.pdf -X.odt
dh_fixperms -i
dh_installdeb -i
dh_gencontrol -i
@@ -126,7 +125,7 @@ binary-arch: build install
dh_installchangelogs -a NEWS
dh_strip -a
dh_link -a
- dh_compress -a
+ dh_compress -a -X.pdf -X.odt
dh_fixperms -a
# Strip DT_RPATH from CUPS binaries.
find debian/cupsys-driver-gutenprint/usr/lib -type f -perm +0111 -print0 | xargs -0 chrpath --delete