summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2014-05-27 10:50:33 +0200
committerDidier Raboud <odyx@debian.org>2014-05-27 10:50:33 +0200
commit868c899f93a1008935d25d985d24b5f070b25158 (patch)
treede2b7c0f91ef083bbfd91c12d6d83aea616c3706 /debian/rules
parentbb0ee5d0b2b9dd92761c24fa6679ef21d0de26cd (diff)
Fix drivers listing by re-introduction --libdir as well as the specific dh_makeshlibs and dh_shlibdeps calls, unfortunately dropped in the packaging cleanup
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index ee8fad5..5bca6eb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,6 +20,7 @@ override_dh_autoreconf:
override_dh_auto_configure:
dh_auto_configure -- \
+ --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
--disable-static --enable-shared --disable-rpath \
--disable-static-genppd \
--with-modules=dlopen \
@@ -66,6 +67,12 @@ override_dh_auto_test:
override_dh_perl:
dh_perl -d
+override_dh_makeshlibs:
+ dh_makeshlibs -a -V -X usr/lib/$(DEB_HOST_MULTIARCH)/gutenprint
+
+override_dh_shlibdeps:
+ dh_shlibdeps -a -X usr/lib/$(DEB_HOST_MULTIARCH)/gutenprint -ldebian/libgutenprint2/usr/lib/$(DEB_HOST_MULTIARCH):debian/libgutenprintui2-1/usr/lib/$(DEB_HOST_MULTIARCH)
+
override_dh_fixperms:
dh_fixperms
# Make the gutenprint52+usb backend run as root, since /dev/bus/usb/*